Skip to content

Commit

Permalink
app-emacs/distel: Bump to version 4.1.1.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.75, Repoman-2.3.17
Signed-off-by: Ulrich Müller <[email protected]>
  • Loading branch information
ulm committed Sep 5, 2019
1 parent 655894f commit 2976eea
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emacs/distel/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST distel-4.0.6.tar.gz 210257 BLAKE2B 615682bfc2b773a78ad85d4817135144dda787d1db57b2743ea2fca8ed672fc1e37f6bc23803c9cc2b6096e7376d318cd7c25c3133f7b9c1326dbd451273841b SHA512 510f82b6794379d89020d234462e09251e0db285ebc111eaf096e32a4e3619384650cb2b47ed68d38762a496504b58981c73ca5b930bd0eb1407aee9599c149f
DIST distel-4.1.1.tar.gz 214189 BLAKE2B 0a24039c11d603814ca352ccc09e776b2431ab1172c195a528aba6ecd85eeb15d9739bb37fcc850fd33e2af928eb9d2c7bc8a1721b46f79792ec658f58d41a4e SHA512 3ef73a650775f25f8e77c78cfaec3d2277a4e097128819d118ba566ac477455a1764383959f1d8eca33f8dedfa937eab605dfff899d344b9b03262c2abc7ac44
40 changes: 40 additions & 0 deletions app-emacs/distel/distel-4.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit elisp

DESCRIPTION="Distributed Emacs Lisp for Erlang"
HOMEPAGE="https://massemanet.github.io/distel/
https://www.emacswiki.org/emacs/DistributedEmacsLisp"
SRC_URI="https://github.com/massemanet/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

# "New BSD License" according to https://code.google.com/p/distel/
# "MIT" according to https://github.com/massemanet/distel
LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

RDEPEND=">=dev-lang/erlang-11.2.5[emacs]"
BDEPEND="${RDEPEND}"

SITEFILE="50${PN}-gentoo.el"

src_compile() {
emake base info
cd elisp || die
elisp-compile *.el
}

src_install() {
emake prefix="${ED}"/usr \
ELISP_DIR="${ED}${SITELISP}/${PN}" install
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
doinfo doc/distel.info
dodoc AUTHORS ChangeLog NEWS README*
use doc && dodoc doc/gorrie02distel.pdf
docinto html
dodoc doc/distel/*.html
}

0 comments on commit 2976eea

Please sign in to comment.