Skip to content

Commit

Permalink
app-doc/kicad-doc: add 8.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Huang Rui <[email protected]>
Signed-off-by: Yixun Lan <[email protected]>
  • Loading branch information
vowstar authored and dlan17 committed Feb 28, 2024
1 parent edc589a commit 298439e
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-doc/kicad-doc/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST kicad-doc-7.0.10.tar.bz2 107407186 BLAKE2B 5b55745beb57b713e646dbcfbbc5ee1a
DIST kicad-doc-7.0.7.tar.bz2 104103652 BLAKE2B f5ce0ccde126c062dd877ce8023b0c22e33bc1df47e12494d6a41cb198e0100c690fb9325f6e8b74198af77af1c6afb92f6a6f8c417828527bfa8904c88f6432 SHA512 fd37e06dcac907d8fca6cdf8e3eaf2c5197a82572d92f2b2af8aca8ea3603e7dd4ffc1c77b1e28aee245b4d611dca2a3565eec1d23051925d9969582232862c1
DIST kicad-doc-7.0.8.tar.bz2 107229731 BLAKE2B b8a190701ea3a4b065b8446a59837ec7f43cf1f6213e4f4d34da5467097d48c9825e4ee4caa5f9f2f889ff5b3120eba436545c83cae14143ad9fff7f07f0cb75 SHA512 0ddf90cdeccc686b98406875e6528e9dc046f8b0e0cc9a5903135af6d6e6a87d34fd102e1472d8347972b645e72d30659272f0d72febcf7766b43715dcff1b63
DIST kicad-doc-7.0.9.tar.bz2 107422748 BLAKE2B 735a0789c610e710bfebbb13477f32074a3e75a68a361c2907d09242ba0d28a4cd8c43173b462ff2d364080f26147cedba52b2b476aab56410038f3636e55a1e SHA512 7056cba04b71423d30d8b3592d26d2dc325c82dcdd55cd406151ee0b5c5e62921cc2bcd44ece75a0b764b4e3965b38f077f9f7e656c5e39bccc97a883075cd8d
DIST kicad-doc-8.0.0.tar.bz2 89704073 BLAKE2B 9f461e581eaeb712a30d13629a7f32dbf22bfb72a7745a2ac68dc0e4c6f6e5c6a01c36871e5c37b8738b7d40a4a91fc57f7a29d9bb255287876ba7d46690b895 SHA512 5bc2241a1030cba10ac25c09c237d32675d163789e2bdbfcf87c3d454fc7dadc08c4a73074bae3a4bb764d9ad30fde3a99f871aade92e37780ee64c4f131f01e
59 changes: 59 additions & 0 deletions app-doc/kicad-doc/kicad-doc-8.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="Electronic Schematic and PCB design tools manuals"
HOMEPAGE="https://docs.kicad.org/"

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.com/kicad/services/kicad-doc.git"
inherit git-r3
# x11-misc-util/macros only required on live ebuilds
LIVE_DEPEND=">=x11-misc/util-macros-1.18"
else
SRC_URI="https://gitlab.com/kicad/services/${PN}/-/archive/${PV}/${P}.tar.bz2"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
fi

LICENSE="|| ( GPL-3+ CC-BY-3.0 ) GPL-2"
SLOT="0"
# TODO: Change default back to +pdf once asciidoctor-pdf is packaged?
IUSE="+html pdf"

LANG_USE=" l10n_ca l10n_de l10n_en l10n_es l10n_fr l10n_id l10n_it l10n_ja l10n_pl l10n_ru l10n_zh"
IUSE+=${LANG_USE}
REQUIRED_USE="|| ( html pdf ) ^^ ( ${LANG_USE} )"
unset LANG_USE

# TODO: need asciidoctor-pdf for pdf
# bug #697450
BDEPEND="
>=dev-ruby/asciidoctor-2.0.12
>=app-text/dblatex-0.3.10
>=app-text/po4a-0.45
>=sys-devel/gettext-0.18
dev-perl/Unicode-LineBreak
dev-util/source-highlight
l10n_ca? ( dev-texlive/texlive-langspanish )
l10n_de? ( dev-texlive/texlive-langgerman )
l10n_en? ( dev-texlive/texlive-langenglish )
l10n_es? ( dev-texlive/texlive-langspanish )
l10n_fr? ( dev-texlive/texlive-langfrench )
l10n_it? ( dev-texlive/texlive-langitalian )
l10n_ja? ( dev-texlive/texlive-langjapanese media-fonts/vlgothic )
l10n_pl? ( dev-texlive/texlive-langpolish )
l10n_ru? ( dev-texlive/texlive-langcyrillic )
l10n_zh? ( dev-texlive/texlive-langchinese )"

src_configure() {
local mycmakeargs=(
-DPDF_GENERATOR="DBLATEX"
-DBUILD_FORMATS="$(usev html);$(usev pdf)"
-DSINGLE_LANGUAGE="${L10N}"
-DKICAD_DOC_PATH="${EPREFIX}"/usr/share/doc/${P}/help
)
cmake_src_configure
}

0 comments on commit 298439e

Please sign in to comment.