Skip to content

Commit

Permalink
app-admin/logstash-bin: bump to 5.2.0
Browse files Browse the repository at this point in the history
Signed-off-by: Andrew Savchenko <[email protected]>
  • Loading branch information
hydrapolic authored and bircoph committed Feb 13, 2017
1 parent ad8d6b4 commit 29955b9
Show file tree
Hide file tree
Showing 3 changed files with 64 additions and 1 deletion.
1 change: 1 addition & 0 deletions app-admin/logstash-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST logstash-2.4.0.tar.gz 83882952 SHA256 622c435c5c0f40e205fd4d9411eb409cc52992cf62dde4c7cd46e480cd8247cc SHA512 27f7e22fcfbeabe58bef1220399a80b32b56b5e2af17c0279e3f583ed5170be649b961b92c3eef33120ce238f126a3cb32e614bd8109bd8c266b538888c5324d WHIRLPOOL 2d1db78ff21d86e22f709600b086dfc253120e6a659d46c1e6ebc6d62dfffd48f0a440c33fa9a1cd7014108f5ae88afa4ccd25211ce57b1a4856f756a855c71e
DIST logstash-5.1.2.zip 100044055 SHA256 99fd514b6241310c78aefca2cd895c1cec4cd426aa08fccf7e8bba26567573c3 SHA512 4186f942dd555dc1284bc657cbd3a61de8aa67a50bd2f7b725d3364e5fca61029cadb0ca4f9e1c4a36078805fd015128ddcd7773e19e643eaddd5ae2fa9c6673 WHIRLPOOL 1127a419a35e42de59a4bd61fe5b75e39daad69d0646019417abf83f44639a86fd2b1ffc687b6cc551562045ef3d2d901d7985437d158094d4d054e4a93bfd5d
DIST logstash-5.2.0.zip 100036780 SHA256 875b5dab32a801ad489088fd4da5c2c18bf6292f58e7d17499b83fb9041a6d57 SHA512 30094d4f3f33394b4b6c1083058ab7fe2c33a4fb399f5866d01a472aa851984ec338eca67fbaf004abbd627a9286d8e4d129cdc1dcab627111b0a4d0a78295a7 WHIRLPOOL cee54f5b9c76209be142931755be69f620043beef75d8f6d8a289e2ae5d9c6b7fd5578967eade987fc43f7a219464551f556ca077e2f9d03b9e2960a4ec3d7fe
DIST logstash-all-plugins-2.4.0.tar.gz 139743651 SHA256 b2ffe60745ece2140ebc4610f42543dcf3ff5ead2707f0b36f0b70e8ddf0baff SHA512 9627f6119d129b4dcdc41ff43e49a3880f4ba5fcb3ee11e1ec821929d542c93629b0f58ded6741c96da49cba16b05eca141acdeee0ed060389abc3f467bba593 WHIRLPOOL 49ddc27d6030ae65aaab0acabda478644232f92cbd2bbe3d1b118782c5ce1167edb2a485def982f3b6c8138f084e79a783273dd50519a82085b984259f7e19d4
2 changes: 1 addition & 1 deletion app-admin/logstash-bin/files/logstash.initd4
Original file line number Diff line number Diff line change
Expand Up @@ -64,7 +64,7 @@ start_pre() {

stop() {
ebegin "Stopping logstash"
if [ "${KILL_ON_STOP_TIMEOUT}" == "1" ]; then
if [ "${KILL_ON_STOP_TIMEOUT}" = "1" ]; then
start-stop-daemon --stop \
--pidfile=${pidfile} \
--retry=TERM/5/KILL/5
Expand Down
62 changes: 62 additions & 0 deletions app-admin/logstash-bin/logstash-bin-5.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit user

MY_PN="${PN%-bin}"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="Tool for managing events and logs"
HOMEPAGE="https://www.elastic.co/products/logstash"
SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.zip"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"

RESTRICT="strip"
QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"

RDEPEND="virtual/jre:1.8"

S="${WORKDIR}/${MY_P}"

pkg_setup() {
enewgroup ${MY_PN}
enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
}

src_install() {
keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
keepdir "/var/log/${MY_PN}"

insinto "/usr/share/${MY_PN}"
newins "${FILESDIR}/agent.conf.sample2" agent.conf

insinto "/opt/${MY_PN}"
doins -r .
fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"

insinto /etc/logrotate.d
newins "${FILESDIR}/${MY_PN}.logrotate" "${MY_PN}"

newconfd "${FILESDIR}/${MY_PN}.confd2" "${MY_PN}"
newinitd "${FILESDIR}/${MY_PN}.initd4" "${MY_PN}"
}

pkg_postinst() {
ewarn "The default user changed from root to ${MY_PN}. If you wish to run as root (for"
ewarn "example to read local logs), be sure to change LS_USER and LS_GROUP in"
ewarn "${EROOT%/}/etc/conf.d/${MY_PN}"
einfo
einfo "Getting started with logstash:"
einfo " https://www.elastic.co/guide/en/logstash/current/getting-started-with-logstash.html"
einfo ""
einfo "Packages that might be interesting:"
einfo " app-misc/elasticsearch"
einfo " dev-python/elasticsearch-curator"
einfo " www-apps/kibana-bin"
}

0 comments on commit 29955b9

Please sign in to comment.