forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/gst-plugins-bad: disable vnmc and nsf plugins to resolve C…
…VE-2016-9445, CVE-2016-9446 and CVE-2016-9447 Gentoo-bug: 600142 Acked-by: Mart Raudsepp <[email protected]> Package-Manager: portage-2.3.2
- Loading branch information
Michael Palimaka
committed
Nov 20, 2016
1 parent
ed57283
commit 29b0d74
Showing
1 changed file
with
58 additions
and
0 deletions.
There are no files selected for viewing
58 changes: 58 additions & 0 deletions
58
media-libs/gst-plugins-bad/gst-plugins-bad-0.10.23-r4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
GST_ORG_MODULE="gst-plugins-bad" | ||
inherit eutils flag-o-matic gstreamer | ||
|
||
DESCRIPTION="Less plugins for GStreamer" | ||
HOMEPAGE="https://gstreamer.freedesktop.org/" | ||
SRC_URI+=" https://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}-h264-patches.tar.xz" | ||
|
||
LICENSE="LGPL-2" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux" | ||
IUSE="+orc" | ||
|
||
RDEPEND=" | ||
>=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] | ||
>=media-libs/gst-plugins-base-0.10.36:${SLOT}[${MULTILIB_USEDEP}] | ||
>=media-libs/gstreamer-0.10.36:${SLOT}[${MULTILIB_USEDEP}] | ||
orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] ) | ||
" | ||
DEPEND="${RDEPEND}" | ||
RDEPEND="${RDEPEND} | ||
!<media-plugins/gst-plugins-farsight-0.12.11:${SLOT}" | ||
|
||
src_prepare() { | ||
# Patches from 0.10 branch fixing h264 baseline decoding; bug #446384 | ||
epatch "${WORKDIR}/${P}-h264-patches"/*.patch | ||
# Fix CVE-2015-0797, bug #553742 | ||
epatch "${FILESDIR}"/${P}-CVE-2015-0797.patch | ||
} | ||
|
||
src_configure() { | ||
strip-flags | ||
replace-flags "-O3" "-O2" | ||
filter-flags "-fprefetch-loop-arrays" # (Bug #22249) | ||
|
||
multilib-minimal_src_configure | ||
} | ||
|
||
multilib_src_configure() { | ||
# Disable vnmc and nsf plugins due to security bug 600142 | ||
gstreamer_multilib_src_configure \ | ||
--disable-nsf \ | ||
--disable-vmnc \ | ||
$(use_enable orc) \ | ||
--disable-examples \ | ||
--disable-debug \ | ||
--disable-static | ||
} | ||
|
||
multilib_src_install_all() { | ||
DOCS="AUTHORS ChangeLog NEWS README RELEASE" | ||
einstalldocs | ||
prune_libtool_files --modules | ||
} |