Skip to content

Commit

Permalink
kde-apps/kopete: Version bump 15.08.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
johu committed Aug 26, 2015
1 parent 244d4e4 commit 29d7235
Show file tree
Hide file tree
Showing 3 changed files with 169 additions and 1 deletion.
1 change: 1 addition & 0 deletions kde-apps/kopete/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kopete-15.08.0.tar.xz 6326028 SHA256 b900bc313558201066042827758990afe4ff6aea6abe9b9da085be8d93b0ef81 SHA512 5b8bf08442db65ec0ec2c3055b29305ee076cddcac861dbf5d37165b0bd3daf46bed3cb5cd5c5b50f561aff1fe71c05027dfc33997182ae819eff0d85e3fa340 WHIRLPOOL 2bc4cec0f50a45f45b07daec3eae8420e365af2425f047b8e1a052e2ae9f95af11bdd050966a4d35e5b61516492e7ff4a2bf7ff0d9dd373b31a2c87d7ad8fc48
DIST kopete-4.14.3.tar.xz 6317288 SHA256 ba23c6dea57233e0861865a1d76c356b0d3f7037f95e2166d0daef14e6c13845 SHA512 33a433da426e7a4a519f033bb14635f31c92954f8e6c46b41759f4e1e41197aed9d07894b163a1e484648ac0e9f92914afe20dfbaa8ddff56b8751d426afd9fc WHIRLPOOL 62d8df47f3214b8cf05fc9ffab3662cc10a1402fd2d33339adb91cd91651c2652dc1dd637130f9e77bf77825b23e19c813f5c43614160cd4dcec945c19e3542e
167 changes: 167 additions & 0 deletions kde-apps/kopete/kopete-15.08.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,167 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="optional"
inherit kde4-base

DESCRIPTION="KDE multi-protocol IM client"
HOMEPAGE="https://kopete.kde.org https://www.kde.org/applications/internet/kopete"
KEYWORDS="~amd64 ~x86"
IUSE="debug ssl v4l"

# tests hang, last checked for 4.2.96
RESTRICT=test

# Available plugins
#
# addbookmarks: NO DEPS
# alias: NO DEPS (disabled upstream)
# autoreplace: NO DEPS
# contactnotes: NO DEPS
# highlight: NO DEPS
# history: NO DEPS
# latex: virtual/latex as RDEPEND
# nowlistening: NO DEPS
# otr: libotr
# pipes: NO DEPS
# privacy: NO DEPS
# statistics: dev-db/sqlite:3
# texteffect: NO DEPS
# translator: NO DEPS
# urlpicpreview: NO DEPS
# webpresence: libxml2 libxslt
# NOTE: By default we enable all plugins that don't have any dependencies
PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
+nowlistening otr +pipes +privacy +statistics +texteffect +translator
+urlpicpreview webpresence"

# Available protocols
#
# gadu: net-libs/libgadu @since 4.3
# groupwise: app-crypt/qca:2
# irc: NO DEPS, probably will fail so inform user about it
# xmpp: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
# meanwhile: net-libs/meanwhile
# oscar: NO DEPS
# telepathy: net-libs/decibel
# testbed: NO DEPS
# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
# yahoo: media-libs/jasper
# zeroconf (bonjour): NO DEPS
PROTOCOLS="gadu groupwise jingle meanwhile oscar skype
sms testbed winpopup +xmpp yahoo zeroconf"

# disabled protocols
# telepathy: net-libs/decibel
# irc: NO DEPS
# msn: net-libs/libmsn
# qq: NO DEPS

IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"

COMMONDEPEND="
$(add_kdebase_dep kdelibs 'zeroconf?')
$(add_kdebase_dep kdepimlibs)
dev-libs/libpcre
>=dev-qt/qtgui-4.4.0:4[mng]
media-libs/phonon[qt4]
media-libs/qimageblitz
!aqua? (
x11-libs/libX11
x11-libs/libXScrnSaver
)
gadu? ( >=net-libs/libgadu-1.8.0[threads] )
groupwise? ( app-crypt/qca:2[qt4(+)] )
jingle? (
dev-libs/expat
dev-libs/openssl:0
>=media-libs/mediastreamer-2.3.0
media-libs/speex
net-libs/libsrtp
net-libs/ortp:=
)
meanwhile? ( net-libs/meanwhile )
otr? ( >=net-libs/libotr-4.0.0 )
statistics? ( dev-db/sqlite:3 )
v4l? ( media-libs/libv4l )
webpresence? (
dev-libs/libxml2
dev-libs/libxslt
)
xmpp? (
app-crypt/qca:2[qt4(+)]
net-dns/libidn
sys-libs/zlib
)
yahoo? ( media-libs/jasper )
"
RDEPEND="${COMMONDEPEND}
latex? (
|| (
media-gfx/imagemagick
media-gfx/graphicsmagick[imagemagick]
)
virtual/latex-base
)
sms? ( app-mobilephone/smssend )
ssl? ( app-crypt/qca:2[openssl] )
winpopup? ( net-fs/samba )
"
# telepathy? ( net-libs/decibel )"
DEPEND="${COMMONDEPEND}
jingle? ( dev-libs/jsoncpp )
!aqua? ( x11-proto/scrnsaverproto )
"

src_configure() {
local x x2
# Handle common stuff
local mycmakeargs=(
$(cmake-utils_use_with jingle GOOGLETALK)
$(cmake-utils_use_with jingle LiboRTP)
$(cmake-utils_use_with jingle Mediastreamer)
$(cmake-utils_use_with jingle Speex)
$(cmake-utils_use_disable v4l VIDEOSUPPORT)
)
# enable protocols
for x in ${PROTOCOLS}; do
case ${x/+/} in
zeroconf) x2=bonjour ;;
xmpp) x2=jabber ;;
*) x2='' ;;
esac
mycmakeargs+=($(cmake-utils_use_with ${x/+/} ${x2}))
done

mycmakeargs+=( -DWITH_Libmsn=OFF -DWITH_qq=OFF )

# enable plugins
for x in ${PLUGINS}; do
mycmakeargs+=($(cmake-utils_use_with ${x/+/}))
done

kde4-base_src_configure
}

pkg_postinst() {
kde4-base_pkg_postinst

#if use telepathy; then
# elog "To use kopete telepathy plugins, you need to start gabble first:"
# elog "GABBLE_PERSIST=1 telepathy-gabble &"
# elog "export TELEPATHY_DATA_PATH='${EPREFIX}/usr/share/telepathy/managers/'"
#fi

if ! use ssl; then
if use xmpp ; then # || use irc; then
if ! has_version "app-crypt/qca:2[openssl]" ; then
elog "In order to use ssl in xmpp you'll need to"
elog "install app-crypt/qca package with USE=openssl."
fi
fi
fi
}
2 changes: 1 addition & 1 deletion kde-apps/kopete/kopete-4.14.3-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -78,7 +78,7 @@ COMMONDEPEND="
groupwise? ( app-crypt/qca:2[qt4(+)] )
jingle? (
dev-libs/expat
dev-libs/openssl
dev-libs/openssl:0
>=media-libs/mediastreamer-2.3.0
media-libs/speex
net-libs/libsrtp
Expand Down

0 comments on commit 29d7235

Please sign in to comment.