Skip to content

Commit

Permalink
app-emulation/ganeti: version bump to 2.15.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
chutz committed Nov 19, 2015
1 parent ad3dd28 commit 29e2ed3
Show file tree
Hide file tree
Showing 5 changed files with 390 additions and 1 deletion.
1 change: 1 addition & 0 deletions app-emulation/ganeti/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,5 @@ DIST ganeti-2.12.1.tar.gz 4353529 SHA256 bd1b33d12485f4de25cca74dcf2e5354067cdda
DIST ganeti-2.12.3.tar.gz 4373350 SHA256 e66fc4c3dde1e90d85749ceb5c1c90bd6eaed1d139796829833b74337d2d4148 SHA512 7715db8e472e4ac99bf184028cd9853495153485c6638bcddba2d05ce958b6b44d3be07290780bb27b22337ae646881d6b0a30bbe87b7249106ac34d22bdd6c2 WHIRLPOOL e24d695d5acc582905ae7ba003e3fe6e6aa6ea4f9135daf76b953864c392803cd1c6ed81eb0e96652038f289bf450f3ac1a428c46d7a2573bc39a9451a47694e
DIST ganeti-2.13.0.tar.gz 4573781 SHA256 30ccfa971b15d49b45a4bfb75bb9631c0993adbd7feac0562c11305ae8c13753 SHA512 bd847ae7e12cb978fae59a458a4d0e33fee470c51748964453b5d0ea6615e6d959519c84922e92229e942a88f1ad88a6d1cb655f58391d033d5f5dfc249ef941 WHIRLPOOL 925159e36fde1cd36214b4fe54b4e06958cc8bd3ded28e32bc4f99842aafcb4c53c701c8a651421559dc13b4d18ae2cc11f1b9d1d2da1e862561cca81d009bda
DIST ganeti-2.14.1.tar.gz 4655994 SHA256 ae90c69f0c02d2ee558363a1c021dfaaaf4ccb59b662a72fa6485b406766e133 SHA512 2d3927bf888ea56df6b6275a869979c53d4b01e2e527e2dddea2a4835c90e85831e9e7691162999e5c58e9d214e03a37690e84f8fde9f1a0631897b06db348c3 WHIRLPOOL 3554161afd646af41e587fffa9dc85788f6ef13102121c636802946b64161cdeaeea326103171b70577b06635eebf6988b2f3942024a944612642aefd92b89bb
DIST ganeti-2.15.1.tar.gz 4701531 SHA256 a0bc6b9f78c8c9440ca67a73e2011d4499776e18ff42289dff66e90f0a532b72 SHA512 198dd17c8cb1670b1db39f9dd9fdcc416648d5a8c6ed9cbfc2ef3db32ed88a3b445729774a89516f60d443360f42c1fe3cf5c9c015127a4aa1c95027d86d96ba WHIRLPOOL df03b5334299533b34c063026edc57a1be76af74797266bbf1ffba9c3c36aa4fafb2c04687043d4ed734652c1c07d61a06e3c4281721021351845a21a17d8866
DIST ganeti-2.4.5.tar.gz 1828118 SHA256 9141379f3802238fb209309ec12f7090d872b77d7a473c91fe766d1fcec97c89 SHA512 e3abc2fd7c031fbef41c6e993f4cb129fa1dd4cb8c44961a2574da23832fd8412b8b3664b2e05ba8236cb8e58e8d70c3c9081f3f1b6dba8ffdc28d298c8a5099 WHIRLPOOL 897c2b3cdf0c7b03232a4ec99314439dbd29afd65eb2502d21a9f197cc098323a4b9ec0671c24ef7aad44b5327316ee68731e7e5304c8730d03f8ca908b93b62
53 changes: 53 additions & 0 deletions app-emulation/ganeti/files/ganeti-2.15-daemon-util.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
diff --git a/daemons/daemon-util.in b/daemons/daemon-util.in
index 7636fc9..9c681ab 100644
--- a/daemons/daemon-util.in
+++ b/daemons/daemon-util.in
@@ -31,25 +31,26 @@ set -e

@SHELL_ENV_INIT@

-readonly defaults_file="$SYSCONFDIR/default/ganeti"
-
-# This is a list of all daemons and the order in which they're started. The
-# order is important as there are dependencies between them. On shutdown,
-# they're stopped in reverse order.
-DAEMONS=(
- ganeti-noded
- ganeti-confd
- ganeti-wconfd
- ganeti-rapi
- ganeti-luxid
- ganeti-kvmd
- )
+readonly defaults_file="$SYSCONFDIR/conf.d/ganeti"

# This is the list of daemons that are loaded on demand; they should only be
# stopped, not started.
ON_DEMAND_DAEMONS=(
ganeti-metad
)
+DAEMONS=( ganeti-noded ganeti-confd )
+
+_is_master() {
+ [ -z "${GANETI_MASTER}" ] && GANETI_MASTER="$(gnt-cluster getmaster)"
+ [ -z "${LOCAL_HOSTNAME}" ] && LOCAL_HOSTNAME="$(hostname -f)"
+ [ "${GANETI_MASTER}" = "${LOCAL_HOSTNAME}" ]
+}
+
+if _is_master; then
+ DAEMONS+=( ganeti-wconfd ganeti-rapi ganeti-luxid )
+fi
+
+DAEMONS+=( ganeti-kvmd )

_mond_enabled() {
[[ "@CUSTOM_ENABLE_MOND@" == True ]]
@@ -246,7 +247,7 @@ check() {
return 1
fi
elif type -p start-stop-daemon >/dev/null; then
- start-stop-daemon --stop --signal 0 --quiet \
+ start-stop-daemon --signal 0 --quiet \
--pidfile $pidfile
else
_ignore_error status \
26 changes: 26 additions & 0 deletions app-emulation/ganeti/files/ganeti-2.15-python-mock.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
diff --git a/test/py/cmdlib/test_unittest.py b/test/py/cmdlib/test_unittest.py
index f93f99d..2d0d083 100644
--- a/test/py/cmdlib/test_unittest.py
+++ b/test/py/cmdlib/test_unittest.py
@@ -85,7 +85,7 @@ class TestLUTestDelay(CmdlibTestCase):

self.ExecOpCode(op)

- self.rpc.call_test_delay.assert_called_once()
+ assert self.rpc.call_test_delay.called

def testFailingRpc(self):
op = opcodes.OpTestDelay(duration=DELAY_DURATION,
diff --git a/test/py/testutils/__init__.py b/test/py/testutils/__init__.py
index 27ca425..04ea0ee 100644
--- a/test/py/testutils/__init__.py
+++ b/test/py/testutils/__init__.py
@@ -242,7 +242,7 @@ def patch_object(*args, **kwargs):
This function unifies the different variations.

"""
- import mock
+ from mock import mock
try:
# pylint: disable=W0212
return mock._patch_object(*args, **kwargs)
309 changes: 309 additions & 0 deletions app-emulation/ganeti/ganeti-2.15.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,309 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=(python2_7)
use test && PYTHON_REQ_USE="ipv6"

inherit eutils user autotools bash-completion-r1 python-single-r1 versionator

MY_PV="${PV/_rc/~rc}"
MY_PV="${MY_PV/_beta/~beta}"
MY_P="${PN}-${MY_PV}"
SERIES="$(get_version_component_range 1-2)"

if [[ ${PV} =~ [9]{4,} ]] ; then
EGIT_REPO_URI="git://git.ganeti.org/ganeti.git"
inherit git-2
KEYWORDS=""
GIT_DEPEND="dev-python/docutils
dev-python/sphinx[${PYTHON_USEDEP}]
media-gfx/graphviz
media-fonts/urw-fonts"
else
SRC_URI="http://downloads.ganeti.org/releases/${SERIES}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Ganeti is a virtual server management software tool"
HOMEPAGE="http://www.ganeti.org/"

LICENSE="GPL-2"
SLOT="0"
IUSE="drbd haskell-daemons htools ipv6 kvm lxc monitoring multiple-users rbd syslog test xen"
REQUIRED_USE="|| ( kvm xen lxc ) ${PYTHON_REQUIRED_USE}"

USER_PREFIX="${GANETI_USER_PREFIX:-"gnt-"}"
GROUP_PREFIX="${GANETI_GROUP_PREFIX:-"${USER_PREFIX}"}"

DOC_DEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/docutils
media-fonts/urw-fonts
media-gfx/graphviz"

DEPEND="
dev-libs/openssl:0
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
dev-python/pyinotify[${PYTHON_USEDEP}]
dev-python/pycurl[${PYTHON_USEDEP}]
dev-python/ipaddr[${PYTHON_USEDEP}]
dev-python/bitarray[${PYTHON_USEDEP}]
net-analyzer/arping
net-analyzer/fping
net-misc/bridge-utils
net-misc/curl[ssl]
net-misc/openssh
net-misc/socat
sys-apps/iproute2
sys-fs/lvm2
>=sys-apps/baselayout-2.0
dev-lang/ghc
dev-haskell/cabal:0=
dev-haskell/cabal-install:0=
>=dev-haskell/mtl-2.1.1:0=
>=dev-haskell/old-time-1.1.0.0:0=
>=dev-haskell/random-1.0.1.1:0=
haskell-daemons? ( >=dev-haskell/text-0.11.1.13:0= )
>=dev-haskell/transformers-0.3.0.0:0=
>=dev-haskell/attoparsec-0.10.1.1:0=
<dev-haskell/attoparsec-0.13:0
>=dev-haskell/base64-bytestring-1.0.0.1:0=
<dev-haskell/base64-bytestring-1.1:0=
>=dev-haskell/crypto-4.2.4:0=
<dev-haskell/crypto-4.3:0=
>=dev-haskell/curl-1.3.7:0=
<dev-haskell/curl-1.4:0=
>=dev-haskell/hinotify-0.3.2:0=
<dev-haskell/hinotify-0.4:0=
>=dev-haskell/hslogger-1.1.4:0=
<dev-haskell/hslogger-1.3:0=
>=dev-haskell/json-0.5:0=
<dev-haskell/json-0.9:0=
>=dev-haskell/lens-3.10:0=
<dev-haskell/lens-4.8:0=
>=dev-haskell/lifted-base-0.2.0.3:0=
<dev-haskell/lifted-base-0.3:0=
>=dev-haskell/monad-control-0.3.1.3:0=
<dev-haskell/monad-control-1.1:0=
>=dev-haskell/network-2.3.0.13:0=
<dev-haskell/network-2.7:0=
>=dev-haskell/parallel-3.2.0.2:3=
<dev-haskell/parallel-3.3:3=
>=dev-haskell/temporary-1.1.2.3:0=
<dev-haskell/temporary-1.3:0=
>=dev-haskell/regex-pcre-0.94.2:0=
<dev-haskell/regex-pcre-0.95:0=
>=dev-haskell/transformers-base-0.4.1:0=
<dev-haskell/transformers-base-0.5:0=
>=dev-haskell/utf8-string-0.3.7:0=
<dev-haskell/utf8-string-0.4:0=
>=dev-haskell/zlib-0.5.3.3:0=
<dev-haskell/zlib-0.6:0=
>=dev-haskell/psqueue-1.1:0=
<dev-haskell/psqueue-1.2:0=
>=dev-haskell/snap-core-0.8.1:0=
<dev-haskell/snap-core-0.10:0=
>=dev-haskell/snap-server-0.8.1:0=
<dev-haskell/snap-server-0.10:0=
>=dev-haskell/case-insensitive-0.4.0.1
dev-haskell/vector:0=
<dev-haskell/semigroupoids-4.1:0=
<dev-haskell/contravariant-0.6
<dev-haskell/transformers-compat-0.4[three]
xen? ( >=app-emulation/xen-3.0 )
kvm? (
dev-python/psutil
app-emulation/qemu
)
lxc? ( app-emulation/lxc )
drbd? (
|| (
<sys-cluster/drbd-8.5
sys-cluster/drbd-utils
)
)
rbd? ( sys-cluster/ceph )
ipv6? ( net-misc/ndisc6 )
${PYTHON_DEPS}
${GIT_DEPEND}"
RDEPEND="${DEPEND}
!app-emulation/ganeti-htools"
DEPEND+="sys-devel/m4
app-text/pandoc
>=dev-haskell/test-framework-0.6:0=
<dev-haskell/test-framework-0.9:0=
>=dev-haskell/test-framework-hunit-0.2.7:0=
<dev-haskell/test-framework-hunit-0.4:0=
>=dev-haskell/test-framework-quickcheck2-0.2.12.1:0=
<dev-haskell/test-framework-quickcheck2-0.4:0=
test? (
dev-python/mock
dev-python/pyyaml
dev-haskell/haddock:0=
>=dev-haskell/hunit-1.2.4.2:0=
<dev-haskell/hunit-1.3:0=
>=dev-haskell/quickcheck-2.4.2:2=
<dev-haskell/quickcheck-2.8:2=
sys-apps/fakeroot
net-misc/socat
dev-util/shelltestrunner
${DOC_DEPEND}
)"

PATCHES=(
"${FILESDIR}/${PN}-2.12-start-stop-daemon-args.patch"
"${FILESDIR}/${PN}-2.11-add-pgrep.patch"
"${FILESDIR}/${PN}-2.15-daemon-util.patch"
"${FILESDIR}/${PN}-2.7-fix-tests.patch"
"${FILESDIR}/${PN}-2.9-disable-root-tests.patch"
"${FILESDIR}/${PN}-2.9-skip-cli-test.patch"
"${FILESDIR}/${PN}-2.10-rundir.patch"
"${FILESDIR}/${PN}-2.12-qemu-enable-kvm.patch"
"${FILESDIR}/${PN}-2.11-tests.patch"
"${FILESDIR}/${PN}-lockdir.patch"
"${FILESDIR}/${PN}-2.11-dont-nest-libdir.patch"
"${FILESDIR}/${PN}-2.11-dont-print-man-help.patch"
"${FILESDIR}/${PN}-2.11-daemon-util-tests.patch"
"${FILESDIR}/${PN}-2.13-process_unittest.patch"
"${FILESDIR}/${PN}-2.15-python-mock.patch"
)

REQUIRED_USE="kvm? ( || ( amd64 x86 ) )"

S="${WORKDIR}/${MY_P}"

QA_WX_LOAD="
usr/lib*/${PN}/${SERIES}/usr/sbin/ganeti-*d
usr/lib*/${PN}/${SERIES}/usr/bin/htools
"

pkg_setup () {
local user
python-single-r1_pkg_setup

if use multiple-users; then
for user in gnt-{masterd,confd,luxid,rapi,daemons,admin}; do
enewgroup ${user}
enewuser ${user} -1 -1 -1 ${user}
done
fi
}

src_prepare() {
local testfile
epatch "${PATCHES[@]}"

# not sure why these tests are failing
# should remove this on next version bump if possible
for testfile in test/py/import-export_unittest.bash; do
printf '#!/bin/bash\ntrue\n' > "${testfile}"
done

# take the sledgehammer approach to bug #526270
grep -lr '/bin/sh' "${S}" | xargs -r -- sed -i 's:/bin/sh:/bin/bash:g'

[[ ${PV} =~ [9]{4,} ]] && ./autogen.sh
rm autotools/missing
eautoreconf
}

src_configure () {
# this is kind of a hack to work around the removal of the qemu-kvm wrapper
local kvm_arch

if use amd64; then
kvm_arch=x86_64
elif use x86; then
kvm_arch=i386
elif use kvm; then
die "Could not determine qemu system to use for kvm"
fi

econf --localstatedir=/var \
--sharedstatedir=/var \
--disable-symlinks \
--docdir=/usr/share/doc/${P} \
--with-ssh-initscript=/etc/init.d/sshd \
--with-export-dir=/var/lib/ganeti-storage/export \
--with-os-search-path=/usr/share/${PN}/os \
$(use_enable test haskell-tests) \
$(usex multiple-users "--with-default-user=" "" "gnt-daemons" "") \
$(usex multiple-users "--with-user-prefix=" "" "${USER_PREFIX}" "") \
$(usex multiple-users "--with-default-group=" "" "gnt-daemons" "") \
$(usex multiple-users "--with-group-prefix=" "" "${GROUP_PREFIX}" "") \
$(use_enable syslog) \
$(use_enable monitoring) \
$(usex kvm '--with-kvm-path=' '' "/usr/bin/qemu-system-${kvm_arch}" '') \
$(usex haskell-daemons "--enable-confd=haskell" '' '' '')
}

src_install () {
emake V=1 DESTDIR="${D}" install || die "emake install failed"

newinitd "${FILESDIR}"/ganeti.initd-r3 ${PN}
newconfd "${FILESDIR}"/ganeti.confd-r2 ${PN}

if use kvm; then
newinitd "${FILESDIR}"/ganeti-kvm-poweroff.initd ganeti-kvm-poweroff
newconfd "${FILESDIR}"/ganeti-kvm-poweroff.confd ganeti-kvm-poweroff
fi

# ganeti installs it's own docs in a generic location
rm -rf "${D}"/{usr/share/doc/${PN},run}

sed -i "s:/usr/$(get_libdir)/${PN}/tools/burnin:burnin:" doc/examples/bash_completion
newbashcomp doc/examples/bash_completion gnt-instance
bashcomp_alias gnt-instance burnin ganeti-{cleaner,confd} \
h{space,check,scan,info,ail,arep,roller,squeeze,bal} \
gnt-{os,job,filter,debug,storage,group,node,network,backup,cluster}

dodoc INSTALL UPGRADE NEWS README doc/*.rst
dohtml -r doc/html/* doc/css/*.css

docinto examples
dodoc doc/examples/{ganeti.cron,gnt-config-backup} doc/examples/*.ocf

docinto examples/hooks
dodoc doc/examples/hooks/{ipsec,ethers}

insinto /etc/cron.d
newins doc/examples/ganeti.cron ${PN}

insinto /etc/logrotate.d
newins doc/examples/ganeti.logrotate ${PN}

# need to dodir rather than keepdir here (bug #552482)
dodir /var/lib/${PN}

keepdir /var/log/${PN}/
keepdir /usr/share/${PN}/${SERIES}/os/
keepdir /var/lib/ganeti-storage/{export,file,shared}/

dosym ${SERIES} "/usr/share/${PN}/default"
dosym ${SERIES} "/usr/$(get_libdir)/${PN}/default"

python_fix_shebang "${ED}" "${D}"/usr/"$(get_libdir)"/${PN}/${SERIES}
}

pkg_postinst() {
if use multiple-users; then
elog "You have enable multiple user support, the users for this must"
elog "be created. You can use the provided tool for this, which is"
elog "located at:"
elog " /usr/$(get_libdir)/${PN}/tools/users-setup"
fi
}

src_test () {
PATH="${S}/scripts:${S}/src:${PATH}" \
TMPDIR="/tmp" \
GANETI_MASTER="$(hostname -f)" \
emake check || die "emake check failed"
}
Loading

0 comments on commit 29e2ed3

Please sign in to comment.