Skip to content

Commit

Permalink
dev-python/tqdm: Bump to 4.65.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 9, 2023
1 parent 1292a2d commit 29ff23d
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/tqdm/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST tqdm-4.65.0.tar.gz 167542 BLAKE2B b1f7b5666600dd5c476ffc9852cdc8905b8819b6b3f812e00495fa38780dda0c59e48956881d46919ce57b13da9dde519fa7e22d91ed58fe43172da8e9043653 SHA512 86315b57d8ceec69ee8970b25372b26b03d2d37f6d06e037e712bf16c7f56eac1c4049291e451c7df62273b91ba7149b400efd0186ceee90268d854e7b476c47
DIST tqdm-4.65.2.tar.gz 167099 BLAKE2B 5b3d1444aacd3ffa46149889ed5eee3bc851da2c000fcfbd06ceda811ad6df3fd7f9b5da90e7124930ebfd8249a52d194d807d7f8e8b1170966d2b1e6128fc7b SHA512 012810c5844f4034388469a4ce71382067a42960a534e2720d412483b3668040367e94c1865dcd44855cf1f2c7e28312b6084d579348492d7ca3ba5241395f40
45 changes: 45 additions & 0 deletions dev-python/tqdm/tqdm-4.65.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..12} )

inherit bash-completion-r1 distutils-r1 pypi

DESCRIPTION="Add a progress meter to your loops in a second"
HOMEPAGE="
https://github.com/tqdm/tqdm/
https://pypi.org/project/tqdm/
"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
IUSE="examples"

BDEPEND="
dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-timeout[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

EPYTEST_IGNORE=(
# Skip unpredictable performance tests
tests/tests_perf.py
)

python_install_all() {
doman tqdm/tqdm.1
newbashcomp tqdm/completion.sh tqdm
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
distutils-r1_python_install_all
}

0 comments on commit 29ff23d

Please sign in to comment.