forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-kernel/linux-firmware: Update snapshot
Package-Manager: Portage-2.3.36, Repoman-2.3.9
- Loading branch information
Showing
2 changed files
with
120 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST linux-firmware-20180103.tar.gz 138263360 BLAKE2B b7af0f94bf7111a1f4a10c7403f43dbfe837912ccf3afd4bcc362e483bcf15e02df76a37b112b2545c67bfbb2df031890dead100552e402ffc4727041409d891 SHA512 ed95205c075b47a2f30d9c96181ca0047de017abb1b5904f7c504a0afb8ea673c179980eb92d5690dd1a5cfb29815f224f384b4dcc472f80ddc90af3b2cbd4ce | ||
DIST linux-firmware-20180416.tar.gz 149436328 BLAKE2B 1da8140b8805b4c4d1c12940fe2cb71a8d4fc41ceccdd306f1dbc0c20e986b8a4cef09a1e82bd0c270fad22722738ddb4d7eb2ba81553dfddbb76a3039552d97 SHA512 cf416c7ae8d70a8c36955e7fccff16194515f3b4964e80cba268b5ab2816ea0661bc4ea47ff3bf0c5f47dbdc7abceb39c5586117a6796b5b94bd6ef740424b27 | ||
DIST linux-firmware-20180507.tar.gz 150551499 BLAKE2B 66cd52d64fdeb02e12e1b8fd6b578e2722bac9e9381fc949f7418425390521004e6d145e943ebc5b804989278f6c204806079db98074f842066350f6fcc7de40 SHA512 6ffdfdd5a730d62d476255bbd26252ddd24dfbf926b4a0e684f31f93a65d86f645a19cb0e8773b64cbd93a6840a991bc8767f6b483553a3b822a734014c1f94c | ||
DIST microcode_amd_fam17h.tar.gz 2204 BLAKE2B 20f3b006587f49fced335fd38711da2384a1f5cd0b93a483d7022d8aa211dc855427a637583dd2eae9f108120f2fda4b80db081d48d3332da906de8e10b94464 SHA512 d3b52797a5968f8da76d39322780e61d04bab5d810b0b07d64e469fcd67998e4191b0e0a9ab7e4c27189941369ef1b2850bbbb1458fd9bbeb958c98f6e378510 |
119 changes: 119 additions & 0 deletions
119
sys-kernel/linux-firmware/linux-firmware-20180507.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,119 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit savedconfig | ||
|
||
if [[ ${PV} == 99999999* ]]; then | ||
inherit git-r3 | ||
SRC_URI="" | ||
EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git" | ||
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86" | ||
else | ||
GIT_COMMIT="8fc2d4e55685bf73b6f7752383da9067404a74bb" | ||
SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.gz -> ${P}.tar.gz | ||
mirror://gentoo/microcode_amd_fam17h.tar.gz | ||
https://dev.gentoo.org/~whissi/dist/${PN}/microcode_amd_fam17h.tar.gz" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86" | ||
fi | ||
|
||
DESCRIPTION="Linux firmware files" | ||
HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git" | ||
|
||
LICENSE="linux-firmware ( BSD ISC MIT no-source-code ) GPL-2 GPL-2+ freedist" | ||
SLOT="0" | ||
IUSE="savedconfig" | ||
|
||
DEPEND="" | ||
RDEPEND="!savedconfig? ( | ||
!sys-firmware/alsa-firmware[alsa_cards_ca0132] | ||
!sys-firmware/alsa-firmware[alsa_cards_korg1212] | ||
!sys-firmware/alsa-firmware[alsa_cards_maestro3] | ||
!sys-firmware/alsa-firmware[alsa_cards_sb16] | ||
!sys-firmware/alsa-firmware[alsa_cards_ymfpci] | ||
!media-tv/cx18-firmware | ||
!<sys-firmware/ivtv-firmware-20080701-r1 | ||
!media-tv/linuxtv-dvb-firmware[dvb_cards_cx231xx] | ||
!media-tv/linuxtv-dvb-firmware[dvb_cards_cx23885] | ||
!media-tv/linuxtv-dvb-firmware[dvb_cards_usb-dib0700] | ||
!net-dialup/ueagle-atm | ||
!net-dialup/ueagle4-atm | ||
!net-wireless/ar9271-firmware | ||
!net-wireless/i2400m-fw | ||
!net-wireless/libertas-firmware | ||
!sys-firmware/rt61-firmware | ||
!net-wireless/rt73-firmware | ||
!net-wireless/rt2860-firmware | ||
!net-wireless/rt2870-firmware | ||
!sys-block/qla-fc-firmware | ||
!sys-firmware/amd-ucode | ||
!sys-firmware/iwl1000-ucode | ||
!sys-firmware/iwl2000-ucode | ||
!sys-firmware/iwl2030-ucode | ||
!sys-firmware/iwl3945-ucode | ||
!sys-firmware/iwl4965-ucode | ||
!sys-firmware/iwl5000-ucode | ||
!sys-firmware/iwl5150-ucode | ||
!sys-firmware/iwl6000-ucode | ||
!sys-firmware/iwl6005-ucode | ||
!sys-firmware/iwl6030-ucode | ||
!sys-firmware/iwl6050-ucode | ||
!sys-firmware/iwl3160-ucode | ||
!sys-firmware/iwl7260-ucode | ||
!sys-firmware/iwl7265-ucode | ||
!sys-firmware/iwl3160-7260-bt-ucode | ||
!sys-firmware/radeon-ucode | ||
)" | ||
#add anything else that collides to this | ||
|
||
QA_PREBUILT="lib/firmware/*" | ||
|
||
src_unpack() { | ||
if [[ ${PV} == 99999999* ]]; then | ||
git-r3_src_unpack | ||
else | ||
default | ||
# rename directory from git snapshot tarball | ||
mv ${PN}-*/ ${P} || die | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
mv "${WORKDIR}"/microcode_amd_fam17h.bin "${S}"/amd-ucode || die | ||
|
||
echo "# Remove files that shall not be installed from this list." > ${PN}.conf | ||
find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf | ||
|
||
if use savedconfig; then | ||
restore_config ${PN}.conf | ||
ebegin "Removing all files not listed in config" | ||
find * \( \! -type d -and \! -name ${PN}.conf \) \ | ||
| sort ${PN}.conf ${PN}.conf - \ | ||
| uniq -u | xargs -r rm | ||
eend $? || die | ||
# remove empty directories, bug #396073 | ||
find -type d -empty -delete || die | ||
fi | ||
} | ||
|
||
src_install() { | ||
if use !savedconfig; then | ||
save_config ${PN}.conf | ||
fi | ||
rm ${PN}.conf || die | ||
insinto /lib/firmware/ | ||
doins -r * | ||
} | ||
|
||
pkg_preinst() { | ||
if use savedconfig; then | ||
ewarn "USE=savedconfig is active. You must handle file collisions manually." | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
elog "If you are only interested in particular firmware files, edit the saved" | ||
elog "configfile and remove those that you do not want." | ||
} |