forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/libayatana-appindicator: add 0.5.93
Closes: https://bugs.gentoo.org/929024 Closes: https://bugs.gentoo.org/923717 Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
2 changed files
with
51 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST libayatana-appindicator-0.5.91.tar.gz 158269 BLAKE2B e1df60ce2b3ff5712cabf627a54e0767dcbc94d4e11c96a18fd20079642e6d033bfdd9e57d12235c72075cef1d711f5b042fb0a6282a6120018c8cdcc3b4033c SHA512 cc8631814c881640bf2de91a43205c3405fd1fefcd7d58f259171d0926bf7ab08f9361076f4eea1dd8876e8931f9c9230babd3a328f34dc298bc9c4ff004f8ee | ||
DIST libayatana-appindicator-0.5.92.tar.gz 159271 BLAKE2B 22edc6060daa1a225d025c326853493eca05809e8bff8b42a010b17ac8cc5684f4ff33cd24412230ddeaa44ac1b323f9c92f9249de44453ea243b2bb0cb54e0a SHA512 69f4eeeae55665608441f31bf354b22f393e25b3ed46873b98d0231960b4f2fb38c7902c559289f086b018b9596a634f2b2ee97b7ed12ded2a7a790c5d476f9f | ||
DIST libayatana-appindicator-0.5.93.tar.gz 162627 BLAKE2B 323853db4253d9d9b5d094dc21e731d6a9420dd6dcdcc93de73ef41d8d71e9819171e790be37f634864ee2372b0519008d1f81714b178fb2ae383f3f644d9440 SHA512 0477555de74d98a52d6415f5a5a2550aede1db0b54e9df3e761a0ad697b753b5b81827324df860c5ef0fd38c903b07dd8f4bf3129a2bb764d77f9028b03570b4 |
50 changes: 50 additions & 0 deletions
50
dev-libs/libayatana-appindicator/libayatana-appindicator-0.5.93.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
VALA_USE_DEPEND="vapigen" | ||
|
||
inherit cmake vala virtualx | ||
|
||
DESCRIPTION="Ayatana Application Indicators (Shared Library)" | ||
HOMEPAGE="https://github.com/AyatanaIndicators/libayatana-appindicator" | ||
SRC_URI="https://github.com/AyatanaIndicators/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3 LGPL-2 LGPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
RDEPEND=" | ||
>=dev-libs/glib-2.37:2 | ||
>=x11-libs/gtk+-3.24:3[introspection] | ||
dev-libs/libdbusmenu[gtk3] | ||
>=dev-libs/libayatana-indicator-0.8.4 | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="$(vala_depend) | ||
test? ( dev-util/dbus-test-runner ) | ||
" | ||
|
||
src_prepare() { | ||
vala_setup | ||
cmake_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs+=( | ||
-DVALA_COMPILER="${VALAC}" | ||
-DVAPI_GEN="${VAPIGEN}" | ||
-DENABLE_TESTS="$(usex test)" | ||
-DENABLE_GTKDOC=OFF | ||
-DENABLE_BINDINGS_MONO=OFF | ||
-DFLAVOUR_GTK2=OFF | ||
-DFLAVOUR_GTK3=ON | ||
) | ||
cmake_src_configure | ||
} | ||
|
||
src_test() { | ||
virtx cmake_src_test | ||
} |