Skip to content

Commit

Permalink
app-crypt/gpgme: fix broken build with setuptools 72.2
Browse files Browse the repository at this point in the history
It's totally broken with the only setuptools we have in-tree. Revbump
directly to stable.

Bug: pypa/setuptools#4642
Signed-off-by: Eli Schwartz <[email protected]>
  • Loading branch information
eli-schwartz committed Sep 10, 2024
1 parent 4193e3e commit 2ad1ddf
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
From ecd0c86d62351d267bdc9566286c532a394c711b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ingo=20Kl=C3=B6cker?= <[email protected]>
Date: Mon, 2 Sep 2024 15:33:25 +0200
Subject: [PATCH] build,python: Fix build with setuptools 72.2.0+

* lang/python/setup.py.in (BuildExtFirstHack.run): Extend members of the
extension instead of lists that were passed to the extension.
--

setuptools 72.2.0 integrated changes in distutils which included
"Support for Pathlike objects in data files and extensions". With this
change the extensions now take a copy of the sources list passed to the
constructor instead of keeping a reference to the passed list. Hence,
modifying the sources list that was passed to the extension didn't
change the sources list of the extension anymore. This is fixed by
modifying the sources list of the extension directly. For consistency
we do the same for the swig_opts list.

GnuPG-bug-id: 7281
---
lang/python/setup.py.in | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/lang/python/setup.py.in b/lang/python/setup.py.in
index 7b64ba7b..d6f537e0 100755
--- a/lang/python/setup.py.in
+++ b/lang/python/setup.py.in
@@ -217,9 +217,9 @@ class BuildExtFirstHack(build):
def run(self):
self._generate()

- swig_sources.extend((self._in_build_base('gpgme.i'),
- self._in_build_base('helpers.c')))
- swig_opts.extend([
+ swige.sources.extend((self._in_build_base('gpgme.i'),
+ self._in_build_base('helpers.c')))
+ swige.swig_opts.extend([
'-I' + self.build_base, '-outdir',
os.path.join(self.build_lib, 'gpg')
])
Original file line number Diff line number Diff line change
Expand Up @@ -69,6 +69,8 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-1.18.0-tests-start-stop-agent-use-command-v.patch
"${FILESDIR}"/${PN}-1.23.1-tests-gnupg-no-tofu.patch
# backport fix for setuptools 72.2 breakage
"${FILESDIR}"/ecd0c86d62351d267bdc9566286c532a394c711b.patch
)

src_prepare() {
Expand Down

0 comments on commit 2ad1ddf

Please sign in to comment.