Skip to content

Commit

Permalink
dev-libs/cl: Version 1.2.4.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Sep 29, 2018
1 parent f2962e6 commit 2afd015
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/cl/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST cl-1.2.3.tar.gz 137921 BLAKE2B 66e79e60d9e5b16b7ff15ecfbccb928ce293a39ad72b403d885c676cd5eed0d1a08e7359a5f38bdfe22db485aacc314c0956585a04fdf3d2d6c10903b352172e SHA512 aaa19700b1b54921ea8194e1b7fcb2dbb11f22c32108fd99d0cd9796c7524a49653dcc97c8c8b34f7739d0b972cbbc3cf61b929e342429b524b11df93e434863
DIST cl-1.2.4.tar.gz 142258 BLAKE2B 28d72842c092ceb81722769136e2282fdf7062f630eae0fb2097f4b2ae0690e41bb96d3fd947186d90b88a68982f5af03bf0cf0f6375304f6a1d05395f018701 SHA512 f7a7f24abf6c374b42f9aa809984c818ac2514d013ff224b3392b2b5df1ba75f2b393ad0bcd822c4118dd0034ed4e815f83041f0b2350ba71def1b33b42e8801
33 changes: 33 additions & 0 deletions dev-libs/cl/cl-1.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils multilib

DESCRIPTION="OpenCL bindings for Erlang"
HOMEPAGE="https://github.com/tonyrog/cl"
SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
>=dev-lang/erlang-16
virtual/opencl
dev-util/rebar
"
DEPEND="${RDEPEND}"

S=${WORKDIR}/${PN}-${P}

src_compile() {
rebar compile || die
}

src_install() {
ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
CL_DIR="${ERLANG_DIR}/${P}"
insinto "${CL_DIR}"
doins -r ebin src include c_src examples
}

0 comments on commit 2afd015

Please sign in to comment.