Skip to content

Commit

Permalink
dev-ruby/pg: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
mrueg committed Sep 8, 2015
1 parent e57e178 commit 2b08814
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/pg/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pg-0.17.1.gem 142848 SHA256 e7933e8f7f184c28e820ed85ddfb3ad8a13933b2b2ab8656aa8f81cb0aa610a6 SHA512 fb637256d084af3b41ba4130f866924df957a63c29d029b99995bf553e545b3d4064e682b00d0604bf495a853a8800b9c8eba34718e96c651c9a697281ae4a62 WHIRLPOOL 81e0a99d023a49b29b8be1b11290cd0f102cec92adc63a8ed10e215dcd3ef43b8ce5e1916d0f155790e9304670bb0c96921346663798acb5fb973e47fdadfe9f
DIST pg-0.18.2.gem 216576 SHA256 ee4e81f2cdb397d866f15c54f057f1172c8098dc5a8d1ce2883806198d5bbdab SHA512 14707bc4e1c5700cf30b0541c14d31681986c7574281ea878a1d17f89a8986abdd00c7c64c763b56bf675fe0b9be177c4ca9822842cee75a2b57cad49d396a4f WHIRLPOOL 66f2fb4d13ee6da34112cacdd0d4be19a99345b3e17301cd154541e12cb9e799383257584e6cd7bdf60a9f6b888be3ecdefa12d1a7729b7901362ce390d4fad5
DIST pg-0.18.3.gem 218624 SHA256 0cbddb3e2d36b5db262abc1f12a17e1e972f2778c056729f61d6bf1e1b1ce301 SHA512 dc4152dd7b546f3e182075ecd9086ca88c462b570d948f7879de8084e36f19fc6256ab8e5b3ac2ff267f43998a99f44c159c84af47e6637fa14b2aa16f14b139 WHIRLPOOL 8ca2b8613ce6725c92466d83bec37f577f7c6ecad0acc08eeb6c91325c8f936d17a5fb77b25dd659db1a3ebd21cc246016424c65d483da771e3657b2fe157ea8
63 changes: 63 additions & 0 deletions dev-ruby/pg/pg-0.18.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
# ruby19 test fail
USE_RUBY="ruby20 ruby21 ruby22"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_TASK_DOC="docs"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="ChangeLog Contributors.rdoc README.rdoc History.rdoc"

inherit multilib ruby-fakegem

DESCRIPTION="Ruby extension library providing an API to PostgreSQL"
HOMEPAGE="https://bitbucket.org/ged/ruby-pg/"

LICENSE="|| ( GPL-2 Ruby )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

RDEPEND+=" dev-db/postgresql"
DEPEND+=" dev-db/postgresql
test? ( >=dev-db/postgresql-9.4[server,threads] )"

ruby_add_bdepend "
doc? (
dev-ruby/hoe
|| ( >=dev-ruby/yard-0.6.1 dev-ruby/rdoc ) )"

all_ruby_prepare() {
# hack the Rakefile to make it sure that it doesn't load
# rake-compiler (so that we don't have to depend on it and it
# actually works when building with USE=doc).
sed -i \
-e '/Rakefile.cross/s:^:#:' \
-e '/ExtensionTask/,/^end$/ s:^:#:' \
Rakefile || die
}

each_ruby_configure() {
${RUBY} -C ext extconf.rb || die "extconf.rb failed"
}

each_ruby_compile() {
emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
cp ext/*$(get_libname) lib || die
}

each_ruby_test() {
if [[ "${EUID}" -ne "0" ]]; then
# Make the rspec call explicit, this way we don't have to depend
# on rake-compiler (nor rubygems) _and_ we don't have to rebuild
# the whole extension from scratch.
RSPEC_VERSION=3 ruby-ng_rspec
else
ewarn "The userpriv feature must be enabled to run tests."
eerror "Testsuite will not be run."
fi
}

0 comments on commit 2b08814

Please sign in to comment.