Skip to content

Commit

Permalink
gnome-base/gnome-shell: bump to 3.24.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
ttambet authored and leio committed Jul 14, 2017
1 parent d086543 commit 2b374e3
Show file tree
Hide file tree
Showing 2 changed files with 207 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/gnome-shell/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gnome-shell-3.22.3.tar.xz 1952576 SHA256 d1e6bd80ddd1fef92d80b518d4dbeffa296e8f003402551b8c37c42744b7d42f SHA512 47d67910b321a182d3ecd41f20cd923ec433cc93ab04b0b31351ca0229505ecbf343b1307585e557ee757845dc09b2371b0c2197717ed532b71878c186337ee9 WHIRLPOOL 9487f2626cc3ec0b3410c5ec65ceabb114e82d256ab1190464c6c787ca7cfd9e617358c19f84d64955943434b96c0521b5e57ea868da1c291a4874f1f3181613
DIST gnome-shell-3.24.2.tar.xz 1981416 SHA256 70c79a38b5aa19b0a8f73d833ceba2648bce319f9e5e96f567f4efdc2a63e2f6 SHA512 28fc399e48d45f3eb1625c854651bf63628bfdf0ec32528c7eef11dabaee1aa5731ae3e863c640b0c31961f9346276c284e7415e9f82284c0f2dd87fbd8fc860 WHIRLPOOL 0ca67b3a17215caa8d658298892cafff2c794ee39efa01913236490ae15688cb5f78a5cc890d336abeadf8dc0fadc248459e2f1e6a52c63c34bcdb50f8fa0e58
206 changes: 206 additions & 0 deletions gnome-base/gnome-shell/gnome-shell-3.24.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,206 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python{3_4,3_5} )

inherit autotools gnome2 multilib pax-utils python-r1 systemd

DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell"

LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
IUSE="+bluetooth +networkmanager nsplugin +nls -openrc-force"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"

# libXfixes-5.0 needed for pointer barriers
# FIXME:
# * gstreamer support is currently automagic
COMMON_DEPEND="
>=app-accessibility/at-spi2-atk-2.5.3
>=dev-libs/atk-2[introspection]
>=app-crypt/gcr-3.7.5[introspection]
>=dev-libs/glib-2.45.3:2[dbus]
>=dev-libs/gjs-1.47.0
>=dev-libs/gobject-introspection-1.49.1:=
dev-libs/libical:=
>=x11-libs/gtk+-3.15.0:3[introspection]
>=dev-libs/libcroco-0.6.8:0.6
>=gnome-base/gnome-desktop-3.7.90:3=[introspection]
>=gnome-base/gsettings-desktop-schemas-3.21.3
>=gnome-extra/evolution-data-server-3.17.2:=
>=media-libs/gstreamer-0.11.92:1.0
>=net-im/telepathy-logger-0.2.4[introspection]
>=net-libs/telepathy-glib-0.19[introspection]
>=sys-auth/polkit-0.100[introspection]
>=x11-libs/libXfixes-5.0
x11-libs/libXtst
>=x11-wm/mutter-3.23.91[introspection]
>=x11-libs/startup-notification-0.11
${PYTHON_DEPS}
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-libs/dbus-glib
dev-libs/libxml2:2
media-libs/libcanberra[gtk3]
media-libs/mesa
>=media-sound/pulseaudio-2
>=net-libs/libsoup-2.40:2.4[introspection]
x11-libs/libX11
x11-libs/gdk-pixbuf:2[introspection]
x11-apps/mesa-progs
bluetooth? ( >=net-wireless/gnome-bluetooth-3.9[introspection] )
networkmanager? (
app-crypt/libsecret
>=gnome-extra/nm-applet-0.9.8
>=net-misc/networkmanager-0.9.8:=[introspection] )
nsplugin? ( >=dev-libs/json-glib-0.13.2 )
"
# Runtime-only deps are probably incomplete and approximate.
# Introspection deps generated using:
# grep -roe "imports.gi.*" gnome-shell-* | cut -f2 -d: | sort | uniq
# Each block:
# 1. Introspection stuff needed via imports.gi.*
# 2. gnome-session is needed for gnome-session-quit
# 3. Control shell settings
# 4. Systemd needed for suspending support
# 5. xdg-utils needed for xdg-open, used by extension tool
# 6. adwaita-icon-theme and dejavu font neeed for various icons & arrows
# 7. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c
# 8. IBus is needed for nls integration
RDEPEND="${COMMON_DEPEND}
app-accessibility/at-spi2-core:2[introspection]
>=app-accessibility/caribou-0.4.8
dev-libs/libgweather:2[introspection]
>=sys-apps/accountsservice-0.6.14[introspection]
>=sys-power/upower-0.99:=[introspection]
x11-libs/pango[introspection]
>=gnome-base/gnome-session-2.91.91
>=gnome-base/gnome-settings-daemon-3.8.3
!openrc-force? ( >=sys-apps/systemd-31 )
x11-misc/xdg-utils
media-fonts/dejavu
>=x11-themes/adwaita-icon-theme-3.19.90
networkmanager? (
net-misc/mobile-broadband-provider-info
sys-libs/timezone-data )
nls? ( >=app-i18n/ibus-1.4.99[dconf(+),gtk3,introspection] )
"
# avoid circular dependency, see bug #546134
PDEPEND="
>=gnome-base/gdm-3.5[introspection]
>=gnome-base/gnome-control-center-3.8.3[bluetooth(+)?,networkmanager(+)?]
"
DEPEND="${COMMON_DEPEND}
dev-libs/libxslt
>=dev-util/gdbus-codegen-2.45.3
>=dev-util/gtk-doc-am-1.17
gnome-base/gnome-common
>=sys-devel/gettext-0.19.6
virtual/pkgconfig
!!=dev-lang/spidermonkey-1.8.2*
"
# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
# https://bugs.gentoo.org/show_bug.cgi?id=360413

src_prepare() {
# Change favorites defaults, bug #479918
eapply "${FILESDIR}"/${PN}-3.22.0-defaults.patch

# Fix automagic gnome-bluetooth dep, bug #398145
eapply "${FILESDIR}"/${PN}-3.12-bluetooth-flag.patch

# Add missing path to libmutter-clutter when building .gir, bug #597842
eapply "${FILESDIR}"/${PN}-3.22.0-gir-build-fix.patch

eautoreconf
gnome2_src_prepare
}

src_configure() {
# Do not error out on warnings
gnome2_src_configure \
--enable-browser-plugin \
--enable-man \
$(use_enable !openrc-force systemd) \
$(use_with bluetooth) \
$(use_enable networkmanager) \
$(use_enable nsplugin browser-plugin) \
BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
}

src_install() {
gnome2_src_install
python_replicate_script "${ED}/usr/bin/gnome-shell-extension-tool"
python_replicate_script "${ED}/usr/bin/gnome-shell-perf-tool"

# Required for gnome-shell on hardened/PaX, bug #398941
# Future-proof for >=spidermonkey-1.8.7 following polkit's example
if has_version '<dev-lang/spidermonkey-1.8.7'; then
pax-mark mr "${ED}usr/bin/gnome-shell"{,-extension-prefs}
elif has_version '>=dev-lang/spidermonkey-1.8.7[jit]'; then
pax-mark m "${ED}usr/bin/gnome-shell"{,-extension-prefs}
# Required for gnome-shell on hardened/PaX #457146 and #457194
# PaX EMUTRAMP need to be on
elif has_version '>=dev-libs/libffi-3.0.13[pax_kernel]'; then
pax-mark E "${ED}usr/bin/gnome-shell"{,-extension-prefs}
else
pax-mark m "${ED}usr/bin/gnome-shell"{,-extension-prefs}
fi
}

pkg_postinst() {
gnome2_pkg_postinst

if ! has_version 'media-libs/gst-plugins-good:1.0' || \
! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
ewarn "To make use of GNOME Shell's built-in screen recording utility,"
ewarn "you need to either install media-libs/gst-plugins-good:1.0"
ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
fi

if has_version "<x11-drivers/ati-drivers-12"; then
ewarn "GNOME Shell has been reported to show graphical corruption under"
ewarn "x11-drivers/ati-drivers-11.*; you may want to switch to open-source"
ewarn "drivers."
fi

if ! has_version "media-libs/mesa[llvm]"; then
elog "llvmpipe is used as fallback when no 3D acceleration"
elog "is available. You will need to enable llvm USE for"
elog "media-libs/mesa."
fi

# https://bugs.gentoo.org/show_bug.cgi?id=563084
if has_version "x11-drivers/nvidia-drivers[-kms]"; then
ewarn "You will need to enable kms support in x11-drivers/nvidia-drivers,"
ewarn "otherwise Gnome will fail to start"
fi

if ! systemd_is_booted; then
ewarn "${PN} needs Systemd to be *running* for working"
ewarn "properly. Please follow this guide to migrate:"
ewarn "https://wiki.gentoo.org/wiki/Systemd"
fi

if use openrc-force; then
ewarn "You are enabling 'openrc-force' USE flag to skip systemd requirement,"
ewarn "this can lead to unexpected problems and is not supported neither by"
ewarn "upstream neither by Gnome Gentoo maintainers. If you suffer any problem,"
ewarn "you will need to disable this USE flag system wide and retest before"
ewarn "opening any bug report."
fi
}

0 comments on commit 2b374e3

Please sign in to comment.