forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/gdbus-codegen: bump to 2.54.3
Bug: https://bugs.gentoo.org/651830 Package-Manager: Portage-2.3.40, Repoman-2.3.9
- Loading branch information
Showing
3 changed files
with
69 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST glib-2.50.3.tar.xz 7589284 BLAKE2B 8648e5d9e8f4c943ca3ec5a5ec01f380f55f76555bf4ec731e211b33d0e23c29ea2a9323e2e839f35f89f292863df76d4e8c622fc44c0e5905eb904576618dbd SHA512 ef35806c15170b6608445f255136c0bebd2d433adf903c2af2865f6a57b4f2fcfc1e4a7cea1a0dac48ff5fe26248fbf7886dba4a8d209506f0a94160df8fb7af | ||
DIST glib-2.52.3.tar.xz 7679972 BLAKE2B 8d9f6b714571bd04ab9717fbf9ded8556664e43dcdb7dd59436b8b7f1a8a5cdf98e9ce60ca1ead941af1d57688044fefb6c749fa735084622a3482b058864ff6 SHA512 a068f2519cfb82de8d4b7f004e7c1f15e841cad4046430a83b02b359d011e0c4077cdff447a1687ed7c68f1a11b4cf66b9ed9fc23ab5f0c7c6be84eb0ddc3017 | ||
DIST glib-2.54.3.tar.xz 7836536 BLAKE2B 140e7cf09a41b72a5b22e5b87e9674cbfdfe1b82f3cf5f0fd3ecb2ed6b1f62a90f8b4c0bc2f655e297f91394f771f6ecad210357e31f104ee49ca178be6b9d76 SHA512 23eb4458684624f80c17aa784eab42a38eec87bb5979fcfe56f0bc63b5c7bcf8251a0d4ea916fe2c8109ff5b14a4b60c6260755d079ff984c0d8e6a2871d307d |
22 changes: 22 additions & 0 deletions
22
dev-util/gdbus-codegen/files/gdbus-codegen-2.54.3-sitedir.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
diff --git a/gio/gdbus-2.0/codegen/gdbus-codegen.in b/gio/gdbus-2.0/codegen/gdbus-codegen.in | ||
index 8050981..932410a 100644 | ||
--- a/gdbus-codegen.in | ||
+++ b/gdbus-codegen.in | ||
@@ -28,16 +28,7 @@ filedir = os.path.dirname(__file__) | ||
|
||
if srcdir is not None: | ||
path = os.path.join(srcdir, 'gio', 'gdbus-2.0') | ||
-elif os.path.basename(filedir) == 'bin': | ||
- # Make the prefix containing gdbus-codegen 'relocatable' at runtime by | ||
- # adding /some/prefix/bin/../share/glib-2.0 to the python path | ||
- path = os.path.join(filedir, '..', 'share', 'glib-2.0') | ||
else: | ||
- # Assume that the modules we need are in the current directory and add the | ||
- # parent directory to the python path. | ||
- path = os.path.join(filedir, '..') | ||
- | ||
-sys.path.insert(0, os.path.abspath(path)) | ||
-from codegen import codegen_main | ||
+ from gdbus_codegen import codegen_main | ||
|
||
sys.exit(codegen_main.codegen_main()) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
GNOME_ORG_MODULE="glib" | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} ) | ||
PYTHON_REQ_USE="xml" | ||
|
||
inherit gnome.org distutils-r1 | ||
|
||
DESCRIPTION="GDBus code and documentation generator" | ||
HOMEPAGE="https://www.gtk.org/" | ||
|
||
LICENSE="LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos" | ||
IUSE="" | ||
|
||
RDEPEND="${PYTHON_DEPS}" | ||
DEPEND="${RDEPEND}" | ||
|
||
# To prevent circular dependencies with glib[test] | ||
PDEPEND=">=dev-libs/glib-${PV}:2" | ||
|
||
S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen" | ||
|
||
python_prepare_all() { | ||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.54.3-sitedir.patch" | ||
) | ||
distutils-r1_python_prepare_all | ||
|
||
sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die | ||
cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed" | ||
sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed" | ||
} | ||
|
||
src_test() { | ||
einfo "Skipping tests. This package is tested by dev-libs/glib" | ||
einfo "when merged with FEATURES=test" | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all # no-op, but prevents QA warning | ||
doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1" | ||
} |