Skip to content

Commit

Permalink
app-portage/repoman: Bump to version 2.3.18
Browse files Browse the repository at this point in the history
 #690786 Support metadata/layout.conf restrict-allowed
 #699514 Detect dosym absolute paths starting with ${D}, ${ED} etc.
 #699508 Fix unsafe string interpolation.

Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Nov 9, 2019
1 parent a95264d commit 2b90833
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-portage/repoman/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST repoman-2.3.11.tar.bz2 86807 BLAKE2B f5bf8e9b7bac7816ee9b1139d0e0d30e99fc06da4fb742e430c237d9be0e6261bcf5d8f3412f1c20a34e2766c5acc86176b4731f20adc9554de9949bd5622a5d SHA512 331614554bb7ba49b8b63b8612642426fb458aa84de78bb9958be85d03e43d662fc094ecd2472a6f06c6b4f0368ec0542083b04c25f7d8b6aabb432cd2b32367
DIST repoman-2.3.16.tar.bz2 86739 BLAKE2B dc3e3b5e72df751cfacc17e6f5c847160438a4d6f5d86b4dd17ab8a3a69cd0502f2965934c456ea7538f228c40364535e861c489ab2a09a0df14183b111e9a38 SHA512 d0e8bee1e3bd6dd8aecb1278fc7877768552612c4638488b61a9b8856ad9cd7333c7d52f0c334925d90170a1d8af20e9ead6533edbc10cae02baec629dece121
DIST repoman-2.3.17.tar.bz2 86732 BLAKE2B 95324a3513513349f3127b5c758766d3a05f9aa47ed9cbf1808a49b402b90004c469c2d621e5402358c307f53bfa04ac2873d0b3c5d6bc8548a092f9cde408b2 SHA512 a3c798482d5f91b61c979636876e8f127c5c84627b433c20343f359bc89b65b48f17fbe0d34fb0a8b9cbd3aabbacef71302ad87abc88763f51829e74a9d9f8fd
DIST repoman-2.3.18.tar.bz2 86765 BLAKE2B 99ba098b17d676a24c03cd37fb8aa81ce34e178af0973083e67196af88acb4473b0992e6c7706aefc20f4540c03544776fe74dcef7e6b1e1789ea95e43e457d4 SHA512 f041acc2f848f02a14cc8b50ad6e9b556db5a3409fb31b6d3e3e1755b44439252a90bee50e004f5921fd6326307c80a140a58e833bb6d902a603d96970cd6ef0
63 changes: 63 additions & 0 deletions app-portage/repoman/repoman-2.3.18.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
PYTHON_REQ_USE='bzip2(+)'

inherit distutils-r1

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
S="${WORKDIR}/${P}/repoman"
else
SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"

LICENSE="GPL-2"
SLOT="0"
IUSE=""

RDEPEND="
>=sys-apps/portage-2.3.72[${PYTHON_USEDEP}]
>=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"

python_test() {
esetup.py test
}

python_install() {
# Install sbin scripts to bindir for python-exec linking
# they will be relocated in pkg_preinst()
distutils-r1_python_install \
--system-prefix="${EPREFIX}/usr" \
--bindir="$(python_get_scriptdir)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
--sbindir="$(python_get_scriptdir)" \
--sysconfdir="${EPREFIX}/etc" \
"${@}"
}

pkg_postinst() {
if [[ -z {REPLACING_VERSIONS} ]]; then
elog ""
elog "This release of repoman is from the new portage/repoman split"
elog "release code base."
elog "This new repoman code base is still being developed. So its API's"
elog "are not to be considered stable and are subject to change."
elog "The code released has been tested and considered ready for use."
elog "This however does not guarantee it to be completely bug free."
elog "Please report any bugs you may encounter."
elog ""
fi
}

0 comments on commit 2b90833

Please sign in to comment.