forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-apps/fwupd: Bump to version 1.0.8
Closes: https://bugs.gentoo.org/654594 Package-Manager: Portage-2.3.41, Repoman-2.3.9
- Loading branch information
Lars Wendler
committed
Jun 29, 2018
1 parent
2273f20
commit 2ba45b9
Showing
2 changed files
with
103 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST fwupd-1.0.5.tar.gz 1564037 BLAKE2B 1b97cf35e2531fc11b901f061dc30ac0c6b745f32f0b2f756e428509121ac3269d8d51c273566290cba2b840c890ce1274a268d46c35bd6486a932454c2d2cfa SHA512 dbbd0ae574c493de5d89f58e0050e44fd3cd1353807131d7e821ae02cffd4da594855df0ed35e9ceb72bdfc9c4b670e022d184c24897bf2ed370ce545c578621 | ||
DIST fwupd-1.0.6.tar.gz 1569675 BLAKE2B 1e6b4acc52696cc08086647ce69d4901e78201817423a53f1a6af5f9c5b7be658a5f343c88aa358788aa9d51859b29d8ea7269ec855841652a37a88ba577e01e SHA512 8daaf5d5cb91260c443448a874f92d948bf878dc44c586dbd4a75323dd834ba3b106fe570e30c7a0aefe4c4a7008b6db1ec2948a948b3fb94906ef1fe3f2e35a | ||
DIST fwupd-1.0.8.tar.gz 1584132 BLAKE2B 7744d14a02bd9847c0c1efe8ff8365abccf9d5213150687815d3e1236844ec71dbf161e5f5d7be32103c3613640680b5b2a017f1a60a30df93fc55bf5d765f74 SHA512 11bdc1dd77697b690e849bde59e54cf289cde32f410f9f7e8911a874f0a265b091ac2e335f784f54b64f835f2750a63a74092cc5eaf7a6c70eaa6d06995d131e |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,102 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
# Package requires newer meson than eclass provides | ||
MESON_AUTO_DEPEND="no" | ||
PYTHON_COMPAT=( python3_4 python3_5 python3_6 ) | ||
|
||
inherit meson python-single-r1 vala xdg-utils | ||
|
||
DESCRIPTION="Aims to make updating firmware on Linux automatic, safe and reliable" | ||
HOMEPAGE="https://fwupd.org" | ||
SRC_URI="https://github.com/hughsie/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
|
||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="colorhug dell doc gpg +man pkcs7 systemd test uefi uefi_labels" | ||
REQUIRED_USE=" | ||
${PYTHON_REQUIRED_USE} | ||
" | ||
|
||
RDEPEND=" | ||
${PYTHON_DEPS} | ||
app-arch/libarchive:= | ||
dev-db/sqlite | ||
>=dev-libs/appstream-glib-0.7.4:=[introspection] | ||
>=dev-libs/glib-2.45.8:2 | ||
dev-libs/libgpg-error | ||
dev-libs/libgudev:= | ||
>=dev-libs/libgusb-0.2.9[introspection] | ||
dev-python/pillow[${PYTHON_USEDEP}] | ||
dev-python/pycairo[${PYTHON_USEDEP}] | ||
dev-python/pygobject:3[cairo,${PYTHON_USEDEP}] | ||
>=net-libs/libsoup-2.51.92:2.4[introspection] | ||
>=sys-auth/polkit-0.103 | ||
virtual/libelf:0= | ||
colorhug? ( >=x11-misc/colord-1.2.12:0= ) | ||
dell? ( | ||
sys-libs/efivar | ||
>=sys-libs/libsmbios-2.3.3 | ||
) | ||
gpg? ( | ||
app-crypt/gpgme | ||
dev-libs/libgpg-error | ||
) | ||
pkcs7? ( >=net-libs/gnutls-3.4.4.1:= ) | ||
systemd? ( >=sys-apps/systemd-231 ) | ||
!systemd? ( >=sys-auth/consolekit-1.0.0 ) | ||
uefi? ( >=sys-apps/fwupdate-10 ) | ||
uefi_labels? ( | ||
x11-libs/pango | ||
x11-libs/cairo | ||
media-libs/freetype | ||
media-libs/fontconfig | ||
media-fonts/dejavu | ||
media-fonts/source-han-sans | ||
) | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
app-arch/gcab | ||
app-arch/libarchive | ||
>=dev-util/meson-0.41.0 | ||
>=dev-util/ninja-1.7.2 | ||
virtual/pkgconfig | ||
$(vala_depend) | ||
doc? ( dev-util/gtk-doc ) | ||
man? ( app-text/docbook-sgml-utils ) | ||
test? ( net-libs/gnutls[tools] ) | ||
" | ||
|
||
REQUIRED_USE="dell? ( uefi )" | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e "s/'--create'/'--absolute-name', '--create'/" data/tests/builder/meson.build || die | ||
vala_src_prepare | ||
} | ||
|
||
src_configure() { | ||
xdg_environment_reset | ||
local emesonargs=( | ||
-Dconsolekit="$(usex systemd false true)" | ||
-Dgpg="$(usex gpg true false)" | ||
-Dgtkdoc="$(usex doc true false)" | ||
-Dman="$(usex man true false)" | ||
-Dpkcs7="$(usex pkcs7 true false)" | ||
-Dplugin_colorhug="$(usex colorhug true false)" | ||
-Dplugin_dell="$(usex dell true false)" | ||
-Dplugin_synaptics="$(usex dell true false)" | ||
# requires libtbtfwu which is not packaged (yet?) | ||
-Dplugin_thunderbolt=false | ||
-Dplugin_uefi="$(usex uefi true false)" | ||
-Dplugin_uefi-labels="$(usex uefi_labels true false)" | ||
-Dsystemd="$(usex systemd true false)" | ||
-Dtests="$(usex test true false)" | ||
) | ||
meson_src_configure | ||
} |