Skip to content

Commit

Permalink
dev-python/vcstools: initial import; ebuild by me.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
aballier committed Sep 17, 2015
1 parent f4f4072 commit 2bdd3d5
Show file tree
Hide file tree
Showing 4 changed files with 124 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/vcstools/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST vcstools-0.1.37.tar.gz 54213 SHA256 8d66379c5e5772a42b9680c9120a718bdc904745be22096d1f2bd5934cd625fc SHA512 c2992fd9977dd5cb0090319b828add26f60769bb7649d873e8edcac45c23a913667cde31f7ab658d5ce7de82930a5eb0ea9083994ea93b6ee9433966e70ee7b2 WHIRLPOOL aea89a863217ad09e2d183aa04f5c5173f6e7330ff2bfa1e713ab910f3ad0017e95fbf69c1cd94c10e20b7baa5974ad40fe9efda546860ef2a35f100808eb09e
5 changes: 5 additions & 0 deletions dev-python/vcstools/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>ros</herd>
</pkgmetadata>
59 changes: 59 additions & 0 deletions dev-python/vcstools/vcstools-0.1.37.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/vcstools/vcstools"
fi

inherit ${SCM} distutils-r1

DESCRIPTION="Python library for interacting with various VCS systems"
HOMEPAGE="http://wiki.ros.org/vcstools"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
http://github.com/vcstools/vcstools/archive/${PV}.tar.gz -> ${P}.tar.gz
"
KEYWORDS="~amd64 ~arm"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND="
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-vcs/git
dev-vcs/bzr
dev-vcs/mercurial
dev-vcs/subversion
)
"

python_test() {
# From travis.yml
# Set git config to silence some stuff in the tests
git config --global user.email "[email protected]"
git config --global user.name "Foo Bar"
# Set the hg user
echo -e "[ui]\nusername = Your Name <[email protected]>" >> ~/.hgrc
# Set the bzr user
bzr whoami "Your Name <[email protected]>"
#git config --global user.email "[email protected]"
#git config --global user.name "Your Name"

nosetests --with-coverage --cover-package vcstools || die
}
59 changes: 59 additions & 0 deletions dev-python/vcstools/vcstools-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )

SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
EGIT_REPO_URI="https://github.com/vcstools/vcstools"
fi

inherit ${SCM} distutils-r1

DESCRIPTION="Python library for interacting with various VCS systems"
HOMEPAGE="http://wiki.ros.org/vcstools"
if [ "${PV#9999}" != "${PV}" ] ; then
SRC_URI=""
KEYWORDS=""
else
SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
http://github.com/vcstools/vcstools/archive/${PV}.tar.gz -> ${P}.tar.gz
"
KEYWORDS="~amd64 ~arm"
fi

LICENSE="BSD"
SLOT="0"
IUSE="test"

RDEPEND="
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-vcs/git
dev-vcs/bzr
dev-vcs/mercurial
dev-vcs/subversion
)
"

python_test() {
# From travis.yml
# Set git config to silence some stuff in the tests
git config --global user.email "[email protected]"
git config --global user.name "Foo Bar"
# Set the hg user
echo -e "[ui]\nusername = Your Name <[email protected]>" >> ~/.hgrc
# Set the bzr user
bzr whoami "Your Name <[email protected]>"
#git config --global user.email "[email protected]"
#git config --global user.name "Your Name"

nosetests --with-coverage --cover-package vcstools || die
}

0 comments on commit 2bdd3d5

Please sign in to comment.