Skip to content

Commit

Permalink
dev-util/dialog: Version 1.3.20191110
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Nov 12, 2019
1 parent 1dca4ae commit 2bf0210
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/dialog/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST dialog-1.3-20170131.tgz 507783 BLAKE2B a98c436eabc8d06619bd64a8b1d647a0712630f0f89565253636ef2f38333ca6926177aa0c2001305b0c06fc7a1f576cda87da493183402ef9ec3cdc3fa8be23 SHA512 818b4e9d0d5ee55377b78ccceacf59a78e5e6d6fbc09e24a19e62b4988ff8de32f3364132b9ee88c86e126114eda45c82d86397d5f26fae81a6bda91be979786
DIST dialog-1.3-20190808.tar.gz 537376 BLAKE2B 38c849ef12ae6c5fc703fe5f8d172c92ba9c6d498e163d622b5dfc7c638a7058fbca79ecfbf1f3e4f274fd53c6cce0d4ef0f67fc5efb8dc16b451064d609e214 SHA512 780cecaf68616723242426f9e78c772f81ec63f0761f67061c4fa06510ba9ca229c921ee15443b63c1581726751f79bf3e6d3b6b8148bbbb3a986043b6b82f86
DIST dialog-1.3-20191110.tar.gz 540825 BLAKE2B 972d5b9d73c413274f09a590886838010feb55817ec94416dbf0da645824e92df9f7e02b9fbf22c226f2fa213876a6fa6de4f1af1ce94a93c53f22ede8d30926 SHA512 858a0cc095a4d52ce50bb77cc46a95ef64bcff1dc9526eb352b8d1d8884949186d1ea93af342eab8cf8a236efc9357bc5be2d1f1564a6f64536026bc1b894397
50 changes: 50 additions & 0 deletions dev-util/dialog/dialog-1.3.20191110.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIA_P=${PN}-$(ver_cut 1-2)-$(ver_cut 3)
DESCRIPTION="tool to display dialog boxes from a shell"
HOMEPAGE="https://invisible-island.net/dialog/"
SRC_URI="https://dev.gentoo.org/~jer/${DIA_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0/15"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="examples minimal nls static-libs unicode"

RDEPEND="
>=sys-libs/ncurses-5.2-r5:=[unicode?]
"
DEPEND="
${RDEPEND}
nls? ( sys-devel/gettext )
!minimal? ( sys-devel/libtool )
!<=sys-freebsd/freebsd-contrib-8.9999
"
S=${WORKDIR}/${DIA_P}

src_prepare() {
default
sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
}

src_configure() {
econf \
--disable-rpath-hack \
$(use_enable nls) \
$(use_with !minimal libtool) \
--with-libtool-opts=$(usex static-libs '' '-shared') \
--with-ncurses$(usex unicode w '')
}

src_install() {
use minimal && default || emake DESTDIR="${D}" install-full

use examples && dodoc -r samples

dodoc CHANGES README

find "${ED}" -name '*.la' -delete || die
}

0 comments on commit 2bf0210

Please sign in to comment.