forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
net-analyzer/nagios-check_rbl: new version 1.4.1 with perl-5.26 support.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST check_rbl-1.3.7-r1.tar.gz 38565 SHA256 dbe76bd24ab9404817f74fd895dfeb1c55d296fe9a8264a4c631c5139ea31247 SHA512 a918090b2c1e93095b155215de559b0d7f35c949e9c9d27c7b6dc91e21391b03d716154dd90ea1a68deeabce5afde3c9e5746190910f18bf1d3e08ff20d02431 WHIRLPOOL 31a13de7cfc650deea83d8c7cf148358046260502c34e3d643ad53c1e96854b0194da80fac3d95cf5fa06b01d9224fb9716ce3e281148ce174f89e75bb418023 | ||
DIST check_rbl-1.4.1.tar.gz 47585 SHA256 6121e01be4b65f4ed34e8387366a616ceef79f74e44322f68ea8d384c193a177 SHA512 3023aab6ba42dec46cb93eb2ef15e1998a1b3226bd1f143441e14a4271279ac9b24b85b9fc41a382eb203e5d2846b7f4ea4fe27db99d75b104d9182ea53079cb WHIRLPOOL 535cbfad9cb300e51526ea7127ed5c25a2274a0ade4aaa98e3755793fc82ac7adc91a34adba6af2a8d0708869317c33aeccfaaf5bf6c6b2f44974c0db9f99406 |
53 changes: 53 additions & 0 deletions
53
net-analyzer/nagios-check_rbl/nagios-check_rbl-1.4.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DESCRIPTION="Monitor whether or not a host is blacklisted" | ||
HOMEPAGE="https://github.com/matteocorti/check_rbl" | ||
|
||
MY_P="${P/nagios-/}" | ||
SRC_URI="${HOMEPAGE}/releases/download/v${PV}/${MY_P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
|
||
KEYWORDS="~amd64 ~hppa ~x86" | ||
IUSE="" | ||
|
||
# The package's INSTALL/Makefile.PL files specify its dependencies. | ||
# | ||
# * Data::Validate::Domain (dev-perl/Data-Validate-Domain) | ||
# * Data::Validate::IP (dev-perl/Data-Validate-IP) | ||
# * IO::Select (dev-lang/perl) | ||
# * Monitoring::Plugin (dev-perl/Monitoring-Plugin) | ||
# * Monitoring::Plugin::Getopt (dev-perl/Monitoring-Plugin) | ||
# * Monitoring::Plugin::Threshold (dev-perl/Monitoring-Plugin) | ||
# * Net::DNS (dev-perl/Net-DNS) | ||
# * Net::IP (dev-perl/Net-IP) | ||
# * Readonly (dev-perl/Readonly) | ||
# | ||
RDEPEND="dev-lang/perl | ||
dev-perl/Data-Validate-Domain | ||
dev-perl/Data-Validate-IP | ||
dev-perl/Monitoring-Plugin | ||
dev-perl/Net-DNS | ||
dev-perl/Net-IP | ||
dev-perl/Readonly" | ||
DEPEND="${RDEPEND}" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
src_configure() { | ||
perl Makefile.PL INSTALLDIRS=vendor || die | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins | ||
|
||
# It's simplest to move this file after it's been installed. | ||
dodir "${nagiosplugindir}" | ||
mv "${D}"/usr/bin/check_rbl "${D}"/"${nagiosplugindir}" || die | ||
} |