forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/gdbus-codegen: bump to 2.52.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST glib-2.48.2.tar.xz 6408644 SHA256 f25e751589cb1a58826eac24fbd4186cda4518af772806b666a3f91f66e6d3f4 SHA512 2eac104eb2207d0a6488992e48069a34b417f51e141364f281ab7b0953a6de88be177b1c694dd9464a856c9a5d8021e3cf0193a8d9c5aaf6ea11f1f9ff743c43 WHIRLPOOL cba211000d5597e93d01113e5f2b6736e47f4daa00935a53af182b3304fef9a1ac25f78995c7a53cc1234261433a1bbd1ec751c87b556845a15da720af5b971b | ||
DIST glib-2.50.3.tar.xz 7589284 SHA256 82ee94bf4c01459b6b00cb9db0545c2237921e3060c0b74cff13fbc020cfd999 SHA512 ef35806c15170b6608445f255136c0bebd2d433adf903c2af2865f6a57b4f2fcfc1e4a7cea1a0dac48ff5fe26248fbf7886dba4a8d209506f0a94160df8fb7af WHIRLPOOL fc8effb457005a234ccb164d74026cec4af7f9a70eef0a8d58efebfacdcf0d7f7713042a9476e6a89e4effbdf4b0d59377811790557cc991cf6b397e5e984f93 | ||
DIST glib-2.52.1.tar.xz 7676312 SHA256 948c26b817f2d77e2a6cdd5082c60a51bf5dea854890286a1d5d4ccde5ce586f SHA512 6f0475b4ee1078867671a79b1751674926ba1caa872cec3896e2830c61c3cde67972afa9f2d606a2b6705e9846222462b003c6e966a9b63982f3fc3fb58c4d37 WHIRLPOOL 95552f8f8adcbd20f2491cf34cbb60b507716a5be22a6331b23847814a6a4d335ca7f0ed71347c516233fe3814e1021869c391f6bbaadad2cc73690737764e90 | ||
DIST glib-2.52.2.tar.xz 7672064 SHA256 f00e5d9e2a2948b1da25fcba734a6b7a40f556de8bc9f528a53f6569969ac5d0 SHA512 3ea49b75b6f80d9974ebd3c40518d5aaffffd9d9d008c1ae3302690fa34899b91ae59c87f8235077129bbd8b01ef19211efb89bc7fdb08d0254b07735b1ba92d WHIRLPOOL f8e6a75b95ace42291a49307f6d9ad30070eddc5160fee21165c0d23db929da92cc3b0e78b907b05ff8c60d6dd68b19139862a970af373ee720f7a5538554138 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="5" | ||
GNOME_ORG_MODULE="glib" | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} ) | ||
PYTHON_REQ_USE="xml" | ||
|
||
inherit eutils gnome.org distutils-r1 | ||
|
||
DESCRIPTION="GDBus code and documentation generator" | ||
HOMEPAGE="http://www.gtk.org/" | ||
|
||
LICENSE="LGPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos" | ||
IUSE="" | ||
|
||
RDEPEND="${PYTHON_DEPS}" | ||
DEPEND="${RDEPEND}" | ||
|
||
# To prevent circular dependencies with glib[test] | ||
PDEPEND=">=dev-libs/glib-${PV}:2" | ||
|
||
S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen" | ||
|
||
python_prepare_all() { | ||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.40.0-sitedir.patch" | ||
) | ||
distutils-r1_python_prepare_all | ||
|
||
sed -e 's:#!@PYTHON@:#!/usr/bin/env python:' gdbus-codegen.in > gdbus-codegen || die | ||
cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed" | ||
sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed" | ||
} | ||
|
||
src_test() { | ||
einfo "Skipping tests. This package is tested by dev-libs/glib" | ||
einfo "when merged with FEATURES=test" | ||
} | ||
|
||
python_install_all() { | ||
distutils-r1_python_install_all # no-op, but prevents QA warning | ||
doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1" | ||
} |