Skip to content

Commit

Permalink
dev-java/janino: add 3.1.6
Browse files Browse the repository at this point in the history
Signed-off-by: Volkmar W. Pogatzki <[email protected]>
Signed-off-by: Florian Schmaus <[email protected]>
  • Loading branch information
vaukai authored and Flowdalic committed Apr 15, 2022
1 parent 825fee5 commit 2c587f4
Show file tree
Hide file tree
Showing 3 changed files with 104 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/janino/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST janino-2.7.0.zip 992669 BLAKE2B cc9ba79d0fc9af5bbe73f167dee6d15619b40b75852fcc227eaf5399e427cde2aeca4b6ef3ff21f303b71dbc21f432cc3e844583cafce3cb073eec1a1498c45a SHA512 0fe0faf16c9d7c63ed14b156bbf75b1ce6deebda24fc0eb0176e96693de9877187694dfb39e748523329430332a36017b2d7d04b2b26ef0847fde7396106185f
DIST janino-3.1.6.tar.gz 1730264 BLAKE2B a4e15b7b9a9d17b8762f5964171a01da3ce6f1045b8830c9a6e9a0d35c5096376fd667103360791f6848c762177f48f858e4e6233205fb6ff8258e6582211b89 SHA512 6e729733f74e0cc24db56c4030de8751c131c94b3abf0519288cc7539b5dda45de8c33e8dd37d8e70565ad0c3a3122cac7c73d77bc5f92a16db0b0f7ea7436d3
100 changes: 100 additions & 0 deletions dev-java/janino/janino-3.1.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,100 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Skeleton command:
# java-ebuilder --generate-ebuild --workdir . --pom janino/pom.xml --download-uri https://codeload.github.com/janino-compiler/janino/tar.gz/v3.1.6 --slot 0 --keywords "~amd64" --ebuild JANjanino-3.1.6.ebuild

EAPI=8

JAVA_PKG_IUSE="doc source test"
MAVEN_ID="org.codehaus.janino:janino:3.1.6"
JAVA_TESTING_FRAMEWORKS="junit-4"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="An embedded compiler for run-time compilation purposes"
HOMEPAGE="https://janino-compiler.github.io/janino/"
SRC_URI="https://codeload.github.com/janino-compiler/janino/tar.gz/v${PV} -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"

# Common dependencies
# POM: janino/pom.xml
# org.codehaus.janino:commons-compiler:3.1.6 -> !!!groupId-not-found!!!

# Compile dependencies
# POM: janino/pom.xml
# org.apache.ant:ant:1.10.9 -> !!!groupId-not-found!!!
# POM: janino/pom.xml
# test? junit:junit:4.13.1 -> >=dev-java/junit-4.13.2:4

DEPEND="
>=virtual/jdk-1.8:*
dev-java/ant-core:0
"

RDEPEND="
>=virtual/jre-1.8:*"

S="${WORKDIR}/${P}/janino"

src_prepare() {
default
java-pkg_clean
}

src_compile() {
JAVA_SRC_DIR="../commons-compiler/src/main/java"
JAVA_JAR_FILENAME="commons-compiler.jar"
java-pkg-simple_src_compile
JAVA_GENTOO_CLASSPATH_EXTRA+=":commons-compiler.jar"
rm -r target || die

JAVA_CLASSPATH_EXTRA="ant-core"
JAVA_SRC_DIR="src/main/java"
JAVA_RESOURCE_DIRS="src/main/resources"
JAVA_JAR_FILENAME="janino.jar"
java-pkg-simple_src_compile
JAVA_GENTOO_CLASSPATH_EXTRA+=":janino.jar"
rm -r target || die

if use doc; then
JAVA_SRC_DIR=(
"../commons-compiler/src/main/java"
"src/main/java"
)
JAVA_JAR_FILENAME="ignoreme.jar"
java-pkg-simple_src_compile
fi
}

src_test() {
JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="../commons-compiler/src/test/java"
JAVA_TEST_RESOURCE_DIRS="../commons-compiler/src/test/resources"
java-pkg-simple_src_test

JAVA_TEST_GENTOO_CLASSPATH="junit-4"
JAVA_TEST_SRC_DIR="src/test/java"
JAVA_TEST_RESOURCE_DIRS="src/test/resources"
echo 'We are in '"$(pwd)"
java-pkg-simple_src_test
}

src_install() {
default

java-pkg_dojar "commons-compiler.jar"
java-pkg_dojar "janino.jar"

if use doc; then
java-pkg_dojavadoc target/api
fi

if use source; then
java-pkg_dosrc "../commons-compiler/src/main/java/*"
java-pkg_dosrc "src/main/java/*"
fi
}
3 changes: 3 additions & 0 deletions dev-java/janino/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,4 +5,7 @@
<email>[email protected]</email>
<name>Java</name>
</maintainer>
<longdescription>
The "JANINO" implementation of the "commons-compiler" API: Super-small, super-fast, independent from the JDK's "tools.jar".
</longdescription>
</pkgmetadata>

0 comments on commit 2c587f4

Please sign in to comment.