Skip to content

Commit

Permalink
sys-boot/syslinux: fix quoting for toolchain functions
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/show_bug.cgi?id=585186

Package-Manager: portage-2.2.28
  • Loading branch information
chithanh committed Jun 9, 2016
1 parent fe41bde commit 2c743a1
Show file tree
Hide file tree
Showing 5 changed files with 12 additions and 12 deletions.
4 changes: 2 additions & 2 deletions sys-boot/syslinux/syslinux-3.86.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -47,7 +47,7 @@ src_unpack() {
}

src_compile() {
emake CC=$(tc-getCC) installer || die
emake CC="$(tc-getCC)" installer || die
}

src_install() {
Expand Down
4 changes: 2 additions & 2 deletions sys-boot/syslinux/syslinux-4.07.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2013 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -60,7 +60,7 @@ src_unpack() {
}

src_compile() {
emake CC=$(tc-getCC) installer || die
emake CC="$(tc-getCC)" installer || die
}

src_install() {
Expand Down
4 changes: 2 additions & 2 deletions sys-boot/syslinux/syslinux-5.10.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -63,7 +63,7 @@ src_prepare() {
}

src_compile() {
emake CC=$(tc-getCC) installer
emake CC="$(tc-getCC)" installer
}

src_install() {
Expand Down
6 changes: 3 additions & 3 deletions sys-boot/syslinux/syslinux-6.03.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -89,15 +89,15 @@ src_compile() {
# build system abuses the LDFLAGS variable to pass arguments to ld
unset LDFLAGS
if [[ ! -z ${loaderarch} ]]; then
emake CC=$(tc-getCC) LD=$(tc-getLD) ${loaderarch}
emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch}
fi
emake CC=$(tc-getCC) LD=$(tc-getLD) ${loaderarch} installer
emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch} installer
}

src_install() {
# parallel install fails sometimes
einfo "loaderarch=${loaderarch}"
emake -j1 LD=$(tc-getLD) INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
emake -j1 LD="$(tc-getLD)" INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
dodoc README NEWS doc/*.txt
}

Expand Down
6 changes: 3 additions & 3 deletions sys-boot/syslinux/syslinux-6.04_pre1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -89,15 +89,15 @@ src_compile() {
# build system abuses the LDFLAGS variable to pass arguments to ld
unset LDFLAGS
if [[ ! -z ${loaderarch} ]]; then
emake CC=$(tc-getCC) LD=$(tc-getLD) ${loaderarch}
emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch}
fi
emake CC=$(tc-getCC) LD=$(tc-getLD) ${loaderarch} installer
emake CC="$(tc-getCC)" LD="$(tc-getLD)" ${loaderarch} installer
}

src_install() {
# parallel install fails sometimes
einfo "loaderarch=${loaderarch}"
emake -j1 LD=$(tc-getLD) INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
emake -j1 LD="$(tc-getLD)" INSTALLROOT="${D}" MANDIR=/usr/share/man bios ${loaderarch} install
dodoc README NEWS doc/*.txt
}

Expand Down

0 comments on commit 2c743a1

Please sign in to comment.