Skip to content

Commit

Permalink
dev-embedded/avrdude: add 7.0
Browse files Browse the repository at this point in the history
Signed-off-by: Matthew Smith <[email protected]>
  • Loading branch information
MatthewGentoo committed Jul 10, 2022
1 parent c3baaea commit 2c74a52
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-embedded/avrdude/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST avrdude-6.3.tar.gz 909744 BLAKE2B 3c253571a50c423989fc3fd9c5d6fe11b67fad9ca0d94f4bee0de7309fc22ccfe64102fff74fad47ffcb1874870c0aafd0c003df63285bd05c30efd384f5ef9e SHA512 b671008388d6a552e71066fec46429bc7f6639e8eac41113bcbba5a56212b78be31fcf04956b31e11c6b14888b0f6e825f7458395b9ff4fc28406074c7ded2b2
DIST avrdude-7.0.tar.gz 2354082 BLAKE2B 44cc6cb82abd4e44f9e7f72901cd9b2a13c9e7635582993ea9a01ea482709ca6a8a3454980446d1196a67cec19a021133d5821731618350336f81fce09d7c049 SHA512 ca3338e6f2f0efc102e70f72531efbd237c5f7bc282d8db5530038f9e20b18a7c2682343bb2baff08c81f8959b066323a444dd64c2362a340a9d9708f90770e0
DIST avrdude-doc-6.3.pdf 255521 BLAKE2B 3b6a3485b996f0923c00c54970e86c3ab9f40e8a5bd962f5d3e4f87c23c90b61f002b46af9766cc0f117583a54d519c5d8739cb5f8bca0776320243679989716 SHA512 f33b15f6a9247f6646ba8a861f1e86f5d43b1b44438fb95bd53764a73f0c450f669dcb43b6b587390ddbc22dafa02758ddc330a7aab1651ccca7c8da8e00b755
DIST avrdude-doc-6.3.tar.gz 39823 BLAKE2B 170ad1eab743435eb414a2d6547be6c86e4d75aed83836eb29285a8d11a43f7eb878104b3b7a70b528522a415a96a841686d07e82b151fc6f726c1f56d54e801 SHA512 b7abd9d0068d2933a1907655832930c455093b4ffbdc2b6fb2405a821cad0ba1c4de3aa5fa0ea7c9b53d06cfa6d5b5658d30a18a4f5c3884d0e15c171a097b29
64 changes: 64 additions & 0 deletions dev-embedded/avrdude/avrdude-7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake

DESCRIPTION="AVR Downloader/UploaDEr"
HOMEPAGE="https://avrdudes.github.io/avrdude https://github.com/avrdudes/avrdude"
SRC_URI="https://github.com/avrdudes/avrdude/archive/refs/tags/v${PV}.tar.gz -> avrdude-${PV}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="ftdi readline"

RDEPEND="
dev-libs/hidapi
virtual/libelf:=
virtual/libusb:0
virtual/libusb:1
ftdi? ( dev-embedded/libftdi:1= )
readline? ( sys-libs/readline:0= )
"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/bison
sys-devel/flex
"

src_prepare() {
cmake_src_prepare

# CMAKE_INSTALL_LIBDIR is not respected. Fixed in the next release.
sed -i "s@DESTINATION lib@DESTINATION $(get_libdir)@g" \
src/CMakeLists.txt || die

# For some reason 'TYPE SYSCONF' and 'CMAKE_INSTALL_SYSCONFDIR'
# prepends '/usr' so the config ends up getting installed as
# '/usr/etc/avrdude.conf' which is not correct.
sed -i 's@TYPE SYSCONF@DESTINATION ${CMAKE_INSTALL_FULL_SYSCONFDIR}@' \
src/CMakeLists.txt || die
}

src_configure() {
# Optional libraries like libftdi aren't gated behind options and
# find_package calls, but find_library is called directly
# instead.
#
# Set the cache variable to an empty string if we do not want a
# library to be automatically detected.
local mycmakeargs=(
-DBUILD_DOC=OFF # This currently does nothing...
-DBUILD_SHARED_LIBS=ON
-DDEBUG_CMAKE=ON
-DHAVE_LIBFTDI=''
-DHAVE_LIBHID=''
-DHAVE_LINUXGPIO=ON # Seems like there is no reason to have this off.
-DHAVE_LINUXSPI=ON # Ditto.
)
use ftdi || mycmakeargs+=( -DHAVE_LIBFTDI1='' )
use readline || mycmakeargs+=( -DHAVE_LIBREADLINE='' )
cmake_src_configure
}

0 comments on commit 2c74a52

Please sign in to comment.