forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-emulation/dosbox-staging: 0.75.2 bump
Set -DNDEBUG preprocessor flag for release build Fix license (GPL-2+) in current ebuilds Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <[email protected]>
- Loading branch information
Showing
4 changed files
with
52 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST dosbox-staging-0.75.1.tar.gz 1806471 BLAKE2B 5f9f8038327eb46c2c2b5035ca8e2cc93660bb6ce1dfa9572bf67278f14455db723104c0ab4e90b805cc7dbf253f61528ad6a31edb574af57e106f613958aede SHA512 3e14354e4eb697514c4348af2e73e9f2fb84cc3796b5cfea37faac355bd93a54b0f9c717bf0ab75d824cf34e3ee0d40546e2bbf80bc924a37bd8f981f054e4e9 | ||
DIST dosbox-staging-0.75.2.tar.gz 1816233 BLAKE2B 0cb3224a1fe0e01e5069b78c91191f33b6d84dfb21b00ed8cd832225e68e5f66e841506bc7c887da462727b931a6c72b84dbf5e48e4dde21dbf62ffa3da4edc6 SHA512 2988b2cc44d041193d900efc4c6fa516aca6246e51c1dece9b207bd3549a8c76c5bcb2f3f5a90da6bb2b573663bddd0020274f17130548aef9cef1f4adf79220 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
49 changes: 49 additions & 0 deletions
49
games-emulation/dosbox-staging/dosbox-staging-0.75.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# Copyright 2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit autotools desktop flag-o-matic xdg | ||
|
||
DESCRIPTION="Modernized DOSBox soft-fork" | ||
HOMEPAGE="https://dosbox-staging.github.io/" | ||
SRC_URI="https://github.com/dosbox-staging/dosbox-staging/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="alsa debug dynrec network opengl opus" | ||
|
||
RDEPEND="alsa? ( media-libs/alsa-lib ) | ||
debug? ( sys-libs/ncurses:0= ) | ||
network? ( media-libs/sdl2-net ) | ||
opengl? ( virtual/opengl ) | ||
opus? ( media-libs/opusfile ) | ||
media-libs/libpng:0= | ||
media-libs/libsdl2[joystick,opengl?,video,X] | ||
sys-libs/zlib | ||
!games-emulation/dosbox" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="" | ||
|
||
src_prepare() { | ||
default | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
use debug || append-cppflags -DNDEBUG | ||
econf \ | ||
$(use_enable alsa alsa-midi) \ | ||
$(use_enable debug) \ | ||
$(use_enable !dynrec dynamic-x86) \ | ||
$(use_enable dynrec) \ | ||
$(use_enable network) \ | ||
$(use_enable opengl) \ | ||
$(use_enable opus opus-cdda) | ||
} | ||
|
||
src_install() { | ||
default | ||
doicon -s scalable contrib/icons/${PN}.svg | ||
domenu contrib/linux/dosbox-staging.desktop | ||
} |