Skip to content

Commit

Permalink
dev-util/goland: Version bump to 2017.3.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
mrueg committed Mar 27, 2018
1 parent 0dd0b32 commit 2cb4a59
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/goland/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST goland-2017.3.1.tar.gz 213951052 BLAKE2B 019ebf772443dd9f5e81cfb3717f5e4cb19ec3c8a67eb20037b6b72c97bf3e382e073660021aac22c3e6dbef9b71c4642acd026e10f27e09a5c60002cc2fc84e SHA512 b4d0251ede2a80b1cabf6b29e362a1679929d4f24530a88f6bc80482bb8fbd36d0d619d94b0cce45ca2c92142335a84141aa6e54fb42154ac09097e8b7318a16
DIST goland-2017.3.2.tar.gz 214008724 BLAKE2B 682860f2dfaa96a97ac91eed2a49aa4ee524154df5ba10936b1cc2f816e837b21b27f9da9641c06e5b028fb44d03933abc6b64b87e286e1c38a4c08b92dd2626 SHA512 3488905d1c8944b80f24d40e910da2c04f06ee6dcc08620ffbc7b96c0214d28e00f36b85a178ee9ede8c08fda89294e0d10b99c6929eb595284fc937270e17a5
DIST goland-2017.3.3.tar.gz 214166755 BLAKE2B b110123b521280e3b120c4277851f5e110b71d882c90ccabb4045eb0f7c2123d514674b8cb7fc726861787b699a573e3189febead8b402dbf542ac22d6787b7c SHA512 18bc2be621408107f7bcc8b359f07ee8b933a9357f21d272196b5d04d411a720bb8643ac2788ecdc4ee6313b23a39f60e3a28776622b3355d80a73e3197abee4
45 changes: 45 additions & 0 deletions dev-util/goland/goland-2017.3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils

SLOT=0

SRC_URI="http://download.jetbrains.com/go/${P}.tar.gz"
DESCRIPTION="Golang IDE by JetBrains"
HOMEPAGE="http://www.jetbrains.com/go"

KEYWORDS="~amd64"
LICENSE="IDEA
|| ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"

QA_PREBUILT="opt/${P}/*"

S=${WORKDIR}/GoLand-${PV}

RDEPEND="dev-lang/go"

src_prepare() {
default
if ! use arm; then
rm -rf bin/fsnotifier-arm || die
fi
}

src_install() {
local dir="/opt/${P}"

insinto "${dir}"
doins -r *
fperms 755 "${dir}"/bin/{${PN}.sh,fsnotifier{,64}}

make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
newicon "bin/${PN}.png" "${PN}.png"
make_desktop_entry "${PN}" "gogland" "${PN}" "Development;IDE;"

# recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
mkdir -p "${D}/etc/sysctl.d/" || die
echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
}

0 comments on commit 2cb4a59

Please sign in to comment.