Skip to content

Commit

Permalink
media-libs/tiff: Security bump to version 4.0.7 (bug #599746).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
Lars Wendler committed Nov 21, 2016
1 parent 1bec950 commit 2cc194a
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/tiff/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST tiff-3.9.7.tar.gz 1468097 SHA256 f5d64dd4ce61c55f5e9f6dc3920fbe5a41e02c2e607da7117a35eb5c320cef6a SHA512 ca89584a9ffa33b4986e4bc2165043cec239896f1f0ab73db00818d0442b570efaa6345b2ed422e884202324d359713df849bf14782bb0cf3b959655febddd77 WHIRLPOOL c06b35da66c365c1fe7f0e6e06a400e139d3e2b5b280aa764015c2f0383a6191ffb3d335cdf2211b687bbb0caacf641be409148986a9813dfde5822a650a9b1c
DIST tiff-4.0.6.tar.gz 2192991 SHA256 4d57a50907b510e3049a4bba0d7888930fdfc16ce49f1bf693e5b6247370d68c SHA512 2c8dbaaaab9f82a7722bfe8cb6fcfcf67472beb692f1b7dafaf322759e7016dad1bc58457c0f03db50aa5bd088fef2b37358fcbc1524e20e9e14a9620373fdf8 WHIRLPOOL 809e61a22f7d6dfdf81917a084678ec39ed3cff4e03184d61c67501946d3fab0645cb3fe800d9249771879ee91245085e123349f68340bb63bd18024db8e03a6
DIST tiff-4.0.7.tar.gz 2076392 SHA256 9f43a2cfb9589e5cecaa66e16bf87f814c945f22df7ba600d63aac4632c4f019 SHA512 941357bdd5f947cdca41a1d31ae14b3fadc174ae5dce7b7981dbe58f61995f575ac2e97a7cc4fcc435184012017bec0920278263490464644f2cdfad9a6c5ddc WHIRLPOOL 3090a0d8a5ad3595c97888edab3c48379175cad993567d20be5f397b1c5c1d21012de55c5da5e664ee483d294fe9eb5f3464e14f564fb79c1357094ff67e313d
74 changes: 74 additions & 0 deletions media-libs/tiff/tiff-4.0.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit autotools eutils libtool multilib-minimal

DESCRIPTION="Tag Image File Format (TIFF) library"
HOMEPAGE="http://www.remotesensing.org/libtiff/"
SRC_URI="http://download.osgeo.org/libtiff/${P}.tar.gz
ftp://ftp.remotesensing.org/pub/libtiff/${P}.tar.gz"

LICENSE="libtiff"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="+cxx jbig jpeg lzma static-libs test zlib"

RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}] )
jbig? ( >=media-libs/jbigkit-2.1:=[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1:=[${MULTILIB_USEDEP}] )
zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20130224-r9
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)"
DEPEND="${RDEPEND}"

REQUIRED_USE="test? ( jpeg )" #483132

MULTILIB_WRAPPED_HEADERS=(
/usr/include/tiffconf.h
)

src_prepare() {
default

# tiffcp-thumbnail.sh fails as thumbnail binary doesn't get built anymore since tiff-4.0.7
sed '/tiffcp-thumbnail\.sh/d' -i test/Makefile.am || die

eautoreconf
}

multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable static-libs static) \
$(use_enable zlib) \
$(use_enable jpeg) \
$(use_enable jbig) \
$(use_enable lzma) \
$(use_enable cxx) \
--without-x

# remove useless subdirs
if ! multilib_is_native_abi ; then
sed -i \
-e 's/ tools//' \
-e 's/ contrib//' \
-e 's/ man//' \
-e 's/ html//' \
Makefile || die
fi
}

multilib_src_test() {
if ! multilib_is_native_abi ; then
emake -C tools
fi
emake check
}

multilib_src_install_all() {
prune_libtool_files --all
rm -f "${ED}"/usr/share/doc/${PF}/{COPYRIGHT,README*,RELEASE-DATE,TODO,VERSION}
}

0 comments on commit 2cc194a

Please sign in to comment.