forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-video/simplescreenrecorder: Bump to version 0.3.11
Closes: https://bugs.gentoo.org/654170 Package-Manager: Portage-2.3.38, Repoman-2.3.9
- Loading branch information
Lars Wendler
committed
May 22, 2018
1 parent
f2dfa3f
commit 2cd64df
Showing
2 changed files
with
104 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST simplescreenrecorder-0.3.10.tar.gz 1823448 BLAKE2B 5eef2a803be90b357b08ba6a009cd9bfda73bc7c29200de50c32902598b7044aedaa0a39d9eb71ab0a660bb1a3c03f7d57ae2437203037951f06821ce8a417bb SHA512 dc7b9de386b5f87e8315695ef105dea2491d09b98b19029146dd29562fec001bf6b3fd3f30e91bc87bdb55ec87ff213567b5b17a234b0c06c6b7fe93db63d4ae | ||
DIST simplescreenrecorder-0.3.11.tar.gz 1823944 BLAKE2B b7692ad158b4784f0222dd47227b85d33aae7eb416ed87d2eda1040027c910ec8d0ebe6a7e164e77cb9c3f6f2756e15fe97a7f05f45c92465473d2ae90e86b34 SHA512 5919774a00cd7015cd7db40561efaea43809b9465508b7770db9eb0fc87f338746e5cd4a79a0ab6c09e516257fa80184c3dcb5ab400c0ef2c0a8cf50ea2a073f | ||
DIST simplescreenrecorder-0.3.9.tar.gz 1816221 BLAKE2B 995ac44da0a5e65dcb33a10b353085f6907531b2af84a0b4c5898f1a44d45676a759b94facdf7f6f311444bcb1ea2cbd8dcf143b8c6e0efac4a7eb06484d1096 SHA512 36dc30597d1cb07f060dcb667d79074851fec75f369efe349d1a1852110e663f0704fd0ec7d85fd0fc0dac27e478b7422f6e273dfecbb27ddeb6d2228217a3b2 |
103 changes: 103 additions & 0 deletions
103
media-video/simplescreenrecorder/simplescreenrecorder-0.3.11.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,103 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-multilib flag-o-matic xdg-utils | ||
|
||
if [[ ${PV} = 9999 ]]; then | ||
inherit git-r3 | ||
fi | ||
|
||
DESCRIPTION="A Simple Screen Recorder" | ||
HOMEPAGE="https://www.maartenbaert.be/simplescreenrecorder" | ||
LICENSE="GPL-3" | ||
PKGNAME="ssr" | ||
if [[ ${PV} = 9999 ]] ; then | ||
EGIT_REPO_URI="https://github.com/MaartenBaert/${PKGNAME}.git" | ||
EGIT_BOOTSTRAP="" | ||
else | ||
SRC_URI="https://github.com/MaartenBaert/${PKGNAME}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~x86" | ||
S="${WORKDIR}/${PKGNAME}-${PV}" | ||
fi | ||
|
||
SLOT="0" | ||
IUSE="+asm jack mp3 pulseaudio theora vorbis vpx x264" | ||
|
||
RDEPEND=" | ||
dev-qt/qtcore:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtwidgets:5 | ||
dev-qt/qtx11extras:5 | ||
media-libs/alsa-lib:0= | ||
media-libs/mesa[${MULTILIB_USEDEP}] | ||
|| ( | ||
media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?] | ||
media-video/libav[vorbis?,vpx?,x264?,mp3?,theora?] | ||
) | ||
x11-libs/libX11[${MULTILIB_USEDEP}] | ||
x11-libs/libXext | ||
x11-libs/libXfixes[${MULTILIB_USEDEP}] | ||
virtual/glu[${MULTILIB_USEDEP}] | ||
jack? ( virtual/jack ) | ||
pulseaudio? ( media-sound/pulseaudio ) | ||
" | ||
DEPEND="${RDEPEND} | ||
dev-qt/linguist-tools:5 | ||
" | ||
|
||
pkg_setup() { | ||
if [[ ${ABI} == amd64 ]]; then | ||
elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system" | ||
elog "When added 32bit GLInject libraries are also included. This is" | ||
elog "required if you want to use OpenGL recording on 32bit applications." | ||
elog | ||
fi | ||
|
||
if { has_version media-video/ffmpeg[x264] || has_version media-video/libav[x264] ; } && has_version media-libs/x264[10bit] ; then | ||
ewarn | ||
ewarn "media-libs/x264 is currently built with 10bit useflag." | ||
ewarn "This is known to prevent simplescreenrecorder from recording x264 videos" | ||
ewarn "correctly. Please build media-libs/x264 without 10bit if you want to " | ||
ewarn "record videos with x264." | ||
ewarn | ||
fi | ||
|
||
# QT requires -fPIC. Compile fails otherwise. | ||
# Recently removed from the default compile options upstream | ||
# https://github.com/MaartenBaert/ssr/commit/25fe1743058f0d1f95f6fbb39014b6ac146b5180 | ||
append-flags -fPIC | ||
} | ||
|
||
multilib_src_configure() { | ||
local mycmakeargs=( | ||
-DENABLE_32BIT_GLINJECT="$(usex abi_x86_32)" | ||
-DENABLE_X86_ASM="$(usex asm)" | ||
-DWITH_PULSEAUDIO="$(multilib_native_usex pulseaudio)" | ||
-DWITH_JACK="$(multilib_native_usex jack)" | ||
-DWITH_GLINJECT="true" | ||
) | ||
|
||
# libav doesn't have AVFrame::channels | ||
# https://github.com/MaartenBaert/ssr/issues/195#issuecomment-45646159 | ||
if has_version media-video/libav ; then | ||
mycmakeargs+=( -DENABLE_FFMPEG_VERSIONS="false" ) | ||
fi | ||
|
||
if multilib_is_native_abi ; then | ||
mycmakeargs+=( -DWITH_QT5="true" ) | ||
else | ||
mycmakeargs+=( -DWITH_SIMPLESCREENRECORDER="false" ) | ||
fi | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_desktop_database_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_desktop_database_update | ||
} |