Skip to content

Commit

Permalink
sys-process/rtirq: version bump to 20180209
Browse files Browse the repository at this point in the history
- Install systemd service file.
- Bump to EAPI 7.
- Drop explicit RDEPEND on sys-apps/util-linux.
- Group variables as in skel.ebuild.
- Update LICENSE to GPL-2+ in accordance with rtirq.sh.
- Do not use PN variable in src_install.
- Remove OpenRC specific code that was not very useful anyway.
- Use KV_LOCAL from linux-info to detect if the current kernel is
  realtime or not.
- Avoid using grep unnecessarily.

Closes: https://bugs.gentoo.org/653732
Signed-off-by: Karl Linden <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Closes: gentoo#10135
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
karllinden authored and mgorny committed Oct 24, 2018
1 parent 3f368ae commit 2cfc06b
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-process/rtirq/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rtirq-20150216.tar.gz 12249 BLAKE2B b138c3b274e7d0875fc18d21ff77291975f86d841cfd06d704b428bcf7e106fb06b4738a4d8dd88ca2e58fa719b8232ef8a61df0bd088c9a368497e27095bd39 SHA512 4cb4e3a8e314cec238c2a21c975bec258f229b660e0994893b73aa0b16f6041179ff4e220532fde237d70e15fd5420e22ee5dbf84168148060e760d76617b59c
DIST rtirq-20180209.tar.gz 12290 BLAKE2B 432bf6c931b753d4d9a5d7c50a35b0fb9b2161d09c9f762b97a5aae88152de1f3d14a2a4ccc46d8607d7379e4a7a659d603cc09ee20017923b176359eb4b9133 SHA512 9de924e627b91d6df162b6c8c0c3421fbab11f08162abe98b0fac8742ea924a7e0a18aab23d828e19fe81dfdb70f2f6814c7195acbcbc93af9a339dc549190b2
38 changes: 38 additions & 0 deletions sys-process/rtirq/rtirq-20180209.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit linux-info systemd

DESCRIPTION="Modify realtime scheduling policy and priority of IRQ handlers"
HOMEPAGE="http://www.rncbc.org/archive/#rtirq"
SRC_URI="http://www.rncbc.org/archive/${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"

src_prepare() {
get_version

# Correct config file path.
sed -i -e "s:^\(RTIRQ_CONFIG\=\)\(.*\):\1/etc/conf.d/rtirq:" ${PN}.sh || die
sed -i -e "s:/etc/sysconfig/rtirq:/etc/conf.d/rtirq:" ${PN}.conf || die

default
}

src_install() {
dosbin rtirq.sh
doinitd "${FILESDIR}"/rtirq
newconfd rtirq.conf rtirq
systemd_dounit rtirq.service
}

pkg_postinst() {
if [[ ${KV_LOCAL} != *rt* ]] ; then
elog "To use rtirq you need a realtime kernel."
elog "Realtime kernel sources are supplied in sys-kernel/rt-sources."
fi
}

0 comments on commit 2cfc06b

Please sign in to comment.