Skip to content

Commit

Permalink
app-emulation/playonlinux: bump version to 4.3.4
Browse files Browse the repository at this point in the history
- Add app-misc/jq to RDEPEND.
- Remove obsolete net-analyzer/netcat6 from RDEPEND, add
net-analyzer/openbsd-netcat as an alternative to net-analyzer/netcat.
- Switch from gnome2-utils to xdg; inherit desktop and eutils
explicitly.
- Bump EAPI to 7.

Minor and stylistic changes:
- empty line after EAPI;
- use https;
- sort RDEPEND alphabetically.

Closes: https://bugs.gentoo.org/672944
Closes: gentoo#11360
Bug: https://bugs.gentoo.org/573814
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Stefan Strogin <[email protected]>
Signed-off-by: Nick Sarnie <[email protected]>
  • Loading branch information
steils authored and sarnex committed Mar 17, 2019
1 parent abe89b3 commit 2cfc43e
Show file tree
Hide file tree
Showing 2 changed files with 107 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/playonlinux/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST PlayOnLinux_4.2.12.tar.gz 3204230 BLAKE2B 80ef0e5763448da4a37263c64d408e8263771694666a7c704b5900dfe0e52cc18405c34d609d8c49a0d05a383fca2d035e956e3bbe9a9a0c92a4e43b319ed7ba SHA512 f4ededc8fe0117c66fd5672e136e19b9b48a41acdd3e1b1b3dd7fae2c354e77795f0a4f8286b09b7d1813363aee50fa0811c04c3194aaf745963a2e6115b3909
DIST PlayOnLinux_4.3.4.tar.gz 3101890 BLAKE2B d724cbd90a0f1bbc94c6365fcf6511d39ea0e8e9de32f42716111324f69091874ab19d3fa88a6bd9f77ed6308bc03ca708406fdc24faa60bf662e6a4f5d15d86 SHA512 7f2089d37379adee01424777e9c3b7ec16dd56ba2f4b834b4f0447832c050b2df3218a7361e8e735d5cc359aec6a000fea88e11632c9434232e4f749bb21c173
106 changes: 106 additions & 0 deletions app-emulation/playonlinux/playonlinux-4.3.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,106 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 )

inherit desktop eutils python-single-r1 xdg

MY_PN="PlayOnLinux"

DESCRIPTION="Set of scripts to easily install and use Windows games and software"
HOMEPAGE="https://playonlinux.com/"
SRC_URI="https://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="winbind"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

DEPEND=""
RDEPEND="${PYTHON_DEPS}
app-arch/cabextract
app-arch/p7zip
app-arch/unzip
app-crypt/gnupg
app-misc/jq
dev-python/wxpython:3.0[${PYTHON_USEDEP}]
media-gfx/icoutils
|| ( net-analyzer/netcat net-analyzer/openbsd-netcat )
net-misc/wget
virtual/imagemagick-tools
virtual/wine
winbind? ( net-fs/samba[winbind] )
x11-apps/mesa-progs
x11-terms/xterm
"

S="${WORKDIR}/${PN}"

# TODO:
# Having a real install script
# It will let using LANGUAGES easily
# How to deal with Microsoft Fonts installation asked every time ?
# How to deal with wine version installed ? (have a better mgmt of system one)
# Look at debian pkg: https://packages.debian.org/sid/playonlinux

PATCHES=(
"${FILESDIR}/${PN}-4.2.4-pol-bash.patch"
"${FILESDIR}/${PN}-4.2.4-binary-plugin.patch"
"${FILESDIR}/${PN}-4.2.6-stop-update-warning.patch"
)

src_prepare() {
default

python_fix_shebang .

# remove playonmac
rm etc/{playonmac.icns,terminal.applescript} || die

# remove desktop integration
rm etc/{PlayOnLinux.desktop,PlayOnLinux.directory,playonlinux-Programs.menu} || die
}

src_install() {
# all things without exec permissions
insinto "/usr/share/${PN}"
doins -r resources lang lib etc plugins

# bash/ install
exeinto "/usr/share/${PN}/bash"
find "${S}/bash" -type f -exec doexe '{}' +
exeinto "/usr/share/${PN}/bash/expert"
find "${S}/bash/expert" -type f -exec doexe '{}' +

# python/ install
python_moduleinto "/usr/share/${PN}"
python_domodule python

# main executable files
exeinto "/usr/share/${PN}"
doexe ${PN}{,-pkg,-bash,-shell,-url_handler}

# icons
doicon -s 128 etc/${PN}.png
for size in 16 22 32; do
newicon -s $size etc/${PN}$size.png ${PN}.png
done

doman "${FILESDIR}"/playonlinux{,-pkg}.1
dodoc CHANGELOG.md

make_wrapper ${PN} "./${PN}" "/usr/share/${PN}"
make_wrapper ${PN}-pkg "./${PN}-pkg" "/usr/share/${PN}"
make_desktop_entry ${PN} ${MY_PN} ${PN} Game
}

pkg_prerm() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Installed software and games with playonlinux have not been removed."
elog "To remove them, you can re-install playonlinux and remove them using it,"
elog "or do it manually by removing .PlayOnLinux/ in your home directory."
fi
}

0 comments on commit 2cfc43e

Please sign in to comment.