Skip to content

Commit

Permalink
sci-libs/libqalculate: add 5.0.0
Browse files Browse the repository at this point in the history
- SONAME did not change in libqalculate

All tests pass.

Signed-off-by: Christopher Fore <[email protected]>
Closes: gentoo#36217
Signed-off-by: Andrew Ammerlaan <[email protected]>
  • Loading branch information
csfore authored and Nowa-Ammerlaan committed Apr 12, 2024
1 parent 9e2e96f commit 2d0302b
Show file tree
Hide file tree
Showing 2 changed files with 80 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-libs/libqalculate/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST libqalculate-4.6.1.tar.gz 2610769 BLAKE2B 02ad7371c537bf40d98bb1b32877f0a39
DIST libqalculate-4.7.0.tar.gz 2618347 BLAKE2B 1ec01e124d9c96a2651f3e2a82a4eb8ae771b2701d3fd2be0894666e37eccf1e15e779ccfb96ff866c3e3d5a625ca8884961b505f30d34310be1efe69f0ba1d1 SHA512 d72754f00e26daa0afc1357cc30571b5dae28d7f5f79bcdba2f159644216288df20e5a518457fb244fd3057935f7d800a3e95bdf0f04929353841cc8371be138
DIST libqalculate-4.8.0.tar.gz 2625669 BLAKE2B 957adcc6b5dabee4d9d6a593a4d5c894e6db05856875a241b1090bada49a0c802c94076a347df6b9b60d088edcba6f5e50ffa0d4a4517ead6da9cebc2f02c592 SHA512 db41bf883520d72f5d7c80b78492aba5367e74a6c5c452a420d6ecc79ae8f1dfa208c13bfff96ea699d31189cc49c264cf1b543946e4ec39b9df97a386c215ea
DIST libqalculate-4.8.1.tar.gz 2625564 BLAKE2B 017188bd43da03c398ed17e883f460637d1af35df9643ac62c938f5aa189431fee49143d517c2d4489c4cca030f1220129f9dfce448969a9601c74273bfdb1a9 SHA512 e4e3f884ac42b706ee79f8fa37fbff69a30dc3f24edbe66b259507723dc3f028243acea4cb29dd68d933e7e357a55207aaf619fe9f66caa118a212de06c2a8d4
DIST libqalculate-5.0.0.tar.gz 2674322 BLAKE2B 1ae2203c4443b57198a0e7862361f732ae8428cb6b55942f9ff9984f0956c5a2cda3fd9f5a49fa98c10526879e9ce2751a9e5c33d1e6092503640da13844df0d SHA512 d3467e79e1454a76ee0c4d8795241c105d42580f95321e24b0657d99535ed8827809cc7ec0474c9e75cd668158aa84a500e5bd3a92dd0f4a3d1e4fc91811c399
79 changes: 79 additions & 0 deletions sci-libs/libqalculate/libqalculate-5.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,79 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# Bump with sci-calculators/qalculate-gtk and sci-calculators/qalculate-qt

inherit toolchain-funcs

DESCRIPTION="A modern multi-purpose calculator library"
HOMEPAGE="https://qalculate.github.io/"
SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"

LICENSE="GPL-2+"
# SONAME changes pretty often on bumps. Check!
SLOT="0/22"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="curl icu gnuplot +hardened readline test"
RESTRICT="!test? ( test )"

DEPEND="dev-libs/gmp:=
dev-libs/libxml2:2
dev-libs/mpfr:=
virtual/libiconv
curl? ( net-misc/curl )
icu? ( dev-libs/icu:= )
readline? ( sys-libs/readline:= )"
RDEPEND="${DEPEND}
gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
BDEPEND="dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"

src_prepare() {
default

cat >po/POTFILES.skip <<-EOF || die
# Required by make check
data/currencies.xml.in
data/datasets.xml.in
data/elements.xml.in
data/functions.xml.in
data/planets.xml.in
data/prefixes.xml.in
data/units.xml.in
data/variables.xml.in
src/defs2doc.cc
EOF
}

src_configure() {
# Needed for po-defs/Makefile
export CXX_FOR_BUILD="$(tc-getBUILD_CXX)"
export CXXCPP_FOR_BUILD="$(tc-getBUILD_CXX) -E"

# bug #792027
tc-export CC

econf \
$(use_enable test tests) \
$(use_enable test unittests) \
$(use_with curl libcurl) \
$(use_with gnuplot gnuplot-call) \
$(use_enable !hardened insecure) \
$(use_with icu) \
$(use_with readline)
}

src_install() {
# docs/reference/Makefile.am -> referencedir=
emake \
DESTDIR="${D}" \
referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
install

einstalldocs

find "${ED}" -name '*.la' -delete || die
}

0 comments on commit 2d0302b

Please sign in to comment.