forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-video/makemkv: Fix building against Qt 5.7, closes bug #599228
The -std=c++11 flag is needed for building against Qt 5.7. Trouble is that upstream builds with CC rather than CXX. This only exhibits a warning but if you try to force CXX, it fails to build the C parts, which probably explains why upstream did this in the first place. I thought -x none might work but it breaks unless you put it before every C file. Possibly a GCC bug? Ideally upstream would just use automake and avoid this whole mess. The easiest way out is to only apply CXX and -std=c++11 to the makemkv binary, which doesn't have any C sources. The new patch also respects LDFLAGS. CFLAGS (not CXXFLAGS) is already respected by upstream now so src_compile is no longer needed. Some of the src_install stuff has also been dropped in favour of default as we now want upstream behaviour. Package-Manager: portage-2.3.3
- Loading branch information
Showing
2 changed files
with
55 additions
and
20 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
diff -Naur a/Makefile.in b/Makefile.in | ||
--- a/Makefile.in 2016-12-11 16:14:27.000000000 +0000 | ||
+++ b/Makefile.in 2016-12-17 23:13:03.227251463 +0000 | ||
@@ -2,9 +2,11 @@ | ||
include makefile.common | ||
|
||
GCC=@CC@ | ||
+GXX=@CXX@ | ||
MOC=@QT_MOC@ | ||
|
||
CFLAGS=@CFLAGS_OPT@ -D_linux_ -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS | ||
+LDFLAGS=@LDFLAGS@ | ||
DESTDIR=@DESTDIR@ | ||
PREFIX=@prefix@ | ||
ENABLE_GUI=@ENABLE_GUI@ | ||
@@ -51,13 +53,13 @@ | ||
|
||
out/libdriveio.so.0.full: | ||
mkdir -p out | ||
- $(GCC) $(CFLAGS) -D_REENTRANT -shared -Wl,-z,defs -o$@ $(LIBDRIVEIO_INC) $(LIBDRIVEIO_SRC) \ | ||
+ $(GCC) $(CFLAGS) $(LDFLAGS) -D_REENTRANT -shared -Wl,-z,defs -o$@ $(LIBDRIVEIO_INC) $(LIBDRIVEIO_SRC) \ | ||
-fPIC -Xlinker -dy -Xlinker --version-script=libdriveio/src/libdriveio.vers \ | ||
-Xlinker -soname=libdriveio.so.0 -lc -lstdc++ | ||
|
||
out/libmakemkv.so.1.full: tmp/gen_buildinfo.h | ||
mkdir -p out | ||
- $(GCC) $(CFLAGS) -D_REENTRANT -shared -Wl,-z,defs -o$@ $(LIBEBML_INC) $(LIBEBML_DEF) $(LIBMATROSKA_INC) \ | ||
+ $(GCC) $(CFLAGS) $(LDFLAGS) -D_REENTRANT -shared -Wl,-z,defs -o$@ $(LIBEBML_INC) $(LIBEBML_DEF) $(LIBMATROSKA_INC) \ | ||
$(LIBMAKEMKV_INC) $(SSTRING_INC) $(MAKEMKVGUI_INC) $(LIBABI_INC) $(LIBFFABI_INC) $(LIBDCADEC_DEF) \ | ||
$(LIBEBML_SRC) $(LIBMATROSKA_SRC) $(LIBMAKEMKV_SRC) $(GLIBC_SRC) $(SSTRING_SRC) \ | ||
$(LIBABI_SRC) $(LIBABI_SRC_LINUX) $(LIBFFABI_SRC) $(LIBDCADEC_SRC) \ | ||
@@ -67,16 +69,16 @@ | ||
|
||
out/libmmbd.so.0.full: | ||
mkdir -p out | ||
- $(GCC) $(CFLAGS) -D_REENTRANT -shared -Wl,-z,defs -o$@ $(MAKEMKVGUI_INC) $(LIBMMBD_INC) \ | ||
+ $(GCC) $(CFLAGS) $(LDFLAGS) -D_REENTRANT -shared -Wl,-z,defs -o$@ $(MAKEMKVGUI_INC) $(LIBMMBD_INC) \ | ||
$(LIBMAKEMKV_INC) $(SSTRING_INC) $(LIBABI_INC) $(LIBMMBD_SRC) $(LIBMMBD_SRC_LINUX) $(SSTRING_SRC) \ | ||
-fPIC -Xlinker -dy -Xlinker --version-script=libmmbd/src/libmmbd.vers \ | ||
-Xlinker -soname=libmmbd.so.0 -lc -lstdc++ -lrt -lpthread -lcrypto | ||
|
||
out/makemkv.full: $(MAKEMKVGUI_GEN) $(MAKEMKVGUI_SRC_LINUX) tmp/gen_buildinfo.h | ||
mkdir -p out | ||
- $(GCC) $(CFLAGS) -o$@ $(MAKEMKVGUI_INC) $(LIBMAKEMKV_INC) $(SSTRING_INC) $(LIBDRIVEIO_INC) $(LIBABI_INC) \ | ||
+ $(GXX) $(CFLAGS) $(LDFLAGS) -o$@ $(MAKEMKVGUI_INC) $(LIBMAKEMKV_INC) $(SSTRING_INC) $(LIBDRIVEIO_INC) $(LIBABI_INC) \ | ||
$(MAKEMKVGUI_SRC) $(MAKEMKVGUI_SRC_LINUX) $(MAKEMKVGUI_GEN) $(SSTRING_SRC) $(LIBDRIVEIO_SRC_PUB) \ | ||
- -DHAVE_BUILDINFO_H -Itmp \ | ||
+ -std=c++11 -DHAVE_BUILDINFO_H -Itmp \ | ||
@QT_INC@ -lc -lstdc++ \ | ||
@QT_LIB@ -lpthread -lz -lrt | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters