Skip to content

Commit

Permalink
app-backup/spideroak-bin: version bump to 7.5.0
Browse files Browse the repository at this point in the history
Signed-off-by: Anthony G. Basile <[email protected]>
Package-Manager: Portage-2.3.62, Repoman-2.3.11
  • Loading branch information
blueness committed Mar 22, 2019
1 parent 2ffae5c commit 2d3c846
Show file tree
Hide file tree
Showing 2 changed files with 106 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-backup/spideroak-bin/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,5 @@ DIST spideroak-bin-7.2.0_amd64.deb 24854982 BLAKE2B 9eab89f2c7713f9edbf97da98674
DIST spideroak-bin-7.2.0_x86.deb 24773806 BLAKE2B 4c4c778f50efa8b77c6d0b2ff522ce3ccacc9c0b6fba5b9acb8e6ea25816b303b34751e47f3e27f6b014c03e02473d22b1eba280618cdd9b6c639b82f2425d70 SHA512 758bdaefe307c4c7b7eebc47ebbb835e66c0a57350e34a2cd818212de1d800ae432459933d9613af60b877889724fe90726dd6705fa152b2478bd55552e541ba
DIST spideroak-bin-7.3.0_amd64.deb 18514400 BLAKE2B 3c0d617c4b791cc0e5a9c82111c9486c18ab09d2bfc4102d69b266f6e3d4185a9d74d640ddd3733a86dac1f87f3360968636407ee4f3da6c2bd20779c16e6ddb SHA512 f27cfac3f9055281fece38ba68781287cd886c7c40b998e63cfc1aba0a036b375a06b9cc60390b7e4845ef9c4eae2d94914669dd345ba8de90424ff98ec28d58
DIST spideroak-bin-7.3.0_x86.deb 24779422 BLAKE2B 8cdae243794e5de6a8326e335b539d004c0ba0f1121b85067acbffffbef67f4a0c785f3b794abb62a5eedfd459c8e4d5e48cf8848b005ba637150b286b13db22 SHA512 32504b6e6931f1e923d4202f0b3201c93190128d30767ec41ac11cf7c8c751b87094bdedcf44dda3ae8089543418366c5a78093b9236fee5f95e7f89a29141fc
DIST spideroak-bin-7.5.0_amd64.deb 20758038 BLAKE2B ecd549ee0d479f576e8d50b44f4f7a13c4d24445af32f460d34081e5b654586f314399b34cff1c937e157582a143fee6b98641a68655552bb6d3609e532ceba4 SHA512 4af9f6b57d8748c03bccb0ab843cf27f70eac8e8cc5f11bb494c597d5fd29f475bf9c68bce8971d3cc1550a6def7bac6beed78fdfb31961b09be61ee14116ddd
DIST spideroak-bin-7.5.0_x86.deb 24779422 BLAKE2B 8cdae243794e5de6a8326e335b539d004c0ba0f1121b85067acbffffbef67f4a0c785f3b794abb62a5eedfd459c8e4d5e48cf8848b005ba637150b286b13db22 SHA512 32504b6e6931f1e923d4202f0b3201c93190128d30767ec41ac11cf7c8c751b87094bdedcf44dda3ae8089543418366c5a78093b9236fee5f95e7f89a29141fc
104 changes: 104 additions & 0 deletions app-backup/spideroak-bin/spideroak-bin-7.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit eutils unpacker

DESCRIPTION="Secure free online backup, storage, and sharing system"
HOMEPAGE="https://spideroak.com"

SRC_URI_BASE="https://spideroak.com/release/spideroak"
SRC_URI="x86? ( ${SRC_URI_BASE}/deb_x86 -> ${P}_x86.deb )
amd64? ( ${SRC_URI_BASE}/deb_x64 -> ${P}_amd64.deb )"

RESTRICT="mirror strip"

LICENSE="spideroak"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dbus X"

DEPEND="dev-util/patchelf"
RDEPEND="
app-crypt/mit-krb5[keyutils]
media-libs/libpng:1.2
dbus? ( sys-apps/dbus )
X? (
media-libs/fontconfig
media-libs/freetype:2
dev-libs/glib:2
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libXext
x11-libs/libXmu
x11-libs/libXrender
x11-libs/libXt
)
"

S=${WORKDIR}

QA_PREBUILT="*"

src_prepare() {
# Set RPATH for preserve-libs handling (bug #400979).
cd "${S}/opt/SpiderOakONE/lib" || die
local x
for x in `find` ; do
# Use \x7fELF header to separate ELF executables and libraries
[[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
patchelf --set-rpath '$ORIGIN' "${x}" || \
die "patchelf failed on ${x}"
done

#Remove the libraries that break compatibility in modern systems
#SpiderOak will use the system libs instead
rm -f "${S}/opt/SpiderOakONE/lib/libstdc++.so.6"
rm -f "${S}/opt/SpiderOakONE/lib/libgcc_s.so.1"
rm -f "${S}/opt/SpiderOakONE/lib/libpng12.so.0"
rm -f "${S}/opt/SpiderOakONE/lib/libz.so.1"

eapply_user
}

src_install() {
#install the wrapper script
exeinto /usr/bin
doexe usr/bin/SpiderOakONE

# inotify_dir_watcher needs to be marked executable, bug #453266
#chmod a+rx opt/SpiderOakONE/lib/inotify_dir_watcher

#install the executable
exeinto /opt/SpiderOakONE/lib
doexe opt/SpiderOakONE/lib/SpiderOakONE
doexe opt/SpiderOakONE/lib/inotify_dir_watcher
rm -f opt/SpiderOakONE/lib/{SpiderOakONE,inotify_dir_watcher}

#install the prebundled libraries
insinto /opt/SpiderOakONE
doins -r opt/SpiderOakONE/lib

#install the config files
use dbus || rm -rf etc/dbus-1
insinto /
doins -r etc

#install the manpage
doman usr/share/man/man1/SpiderOakONE.1.gz

if use X; then
domenu usr/share/applications/SpiderOakONE.desktop
doicon usr/share/pixmaps/SpiderOakONE.png
fi
}

pkg_postinst() {
if ! use X; then
einfo "For instructions on running SpiderOakONE without a GUI, please read the FAQ:"
einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
fi
}

0 comments on commit 2d3c846

Please sign in to comment.