Skip to content

Commit

Permalink
games-board/pasang-emas: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Aug 5, 2016
1 parent 20a6672 commit 2d48e29
Showing 1 changed file with 70 additions and 0 deletions.
70 changes: 70 additions & 0 deletions games-board/pasang-emas/pasang-emas-3.1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils gnome2-utils

DESCRIPTION="A traditional game of Brunei"
HOMEPAGE="http://pasang-emas.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
extras? ( mirror://sourceforge/${PN}/pasang-emas-themes-1.0.tar.bz2
mirror://sourceforge/${PN}/pet-marble.tar.bz2
mirror://sourceforge/${PN}/pet-fragrance.tar.bz2 )"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="extras nls"

RDEPEND="app-text/gnome-doc-utils
>=x11-libs/gtk+-2.18.2:2
virtual/libintl"
DEPEND="${RDEPEND}
app-text/rarian
nls? ( sys-devel/gettext )"

PATCHES=(
"${FILESDIR}"/${P}-build.patch
)

src_prepare() {
default
sed -i \
-e '/Encoding/d' \
-e '/Icon/s:\.png::' \
data/pasang-emas.desktop.in || die
gnome2_omf_fix
}

src_configure() {
econf \
--localedir=/usr/share/locale \
--with-omf-dir=/usr/share/omf \
--with-help-dir=/usr/share/gnome/help \
$(use_enable nls)
}

src_install() {
default
if use extras; then
insinto /usr/share/${PN}/themes
doins -r \
"${WORKDIR}"/marble \
"${WORKDIR}"/pasang-emas-themes-1.0/{conteng,kaca} \
"${WORKDIR}"/fragrance
fi
use nls || rm -rf "${D}"usr/share/locale
}

pkg_preinst() {
gnome2_scrollkeeper_savelist
}

pkg_postinst() {
gnome2_scrollkeeper_update
}

pkg_postrm() {
gnome2_scrollkeeper_update
}

0 comments on commit 2d48e29

Please sign in to comment.