Skip to content

Commit

Permalink
sci-chemistry/openbabel-python: Backport Fix for gcc 6/7
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=594154
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed May 13, 2017
1 parent e18588d commit 2d4da3b
Show file tree
Hide file tree
Showing 2 changed files with 15 additions and 1 deletion.
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ee545cf..7f4b944e 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -239,7 +239,7 @@ check_type_size(clock_t CLOCK_T)
# Get the GCC version - from KDE4 cmake files
if(CMAKE_COMPILER_IS_GNUCXX)
exec_program(${CMAKE_C_COMPILER} ARGS --version OUTPUT_VARIABLE _gcc_version_info)
- string(REGEX MATCH "[345]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
+ string(REGEX MATCH "[34567]\\.[0-9]\\.[0-9]" _gcc_version "${_gcc_version_info}")
# gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
# patch level, handle this here:
if (NOT _gcc_version)
3 changes: 2 additions & 1 deletion sci-chemistry/openbabel-python/openbabel-python-2.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -30,6 +30,7 @@ PATCHES=(
"${FILESDIR}"/${P}-testpybel.patch
"${FILESDIR}"/${P}-bindings_only.patch
"${FILESDIR}"/${P}-swig-3.0.3.patch
"${FILESDIR}"/${P}-gcc-6_and_7-backport.patch
)

src_prepare() {
Expand Down

0 comments on commit 2d4da3b

Please sign in to comment.