forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-portage/recover-broken-vdb: add 0.0.3
Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
0c589d8
commit 2d58876
Showing
2 changed files
with
30 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST recover-broken-vdb-0.0.2.tar.gz 12038 BLAKE2B ad1c780e6a9499d734839c099c123c525704b00f421d1470801aa791bc691b43b2119c4138bee85f579f3524cf4f8f4544651dab222b86116fb9f1a80c4f319d SHA512 c9c404fbbf8ffa8993a9596a62bb35b88e0f814b5e82c0771c514dcb662a438a1282f23268e4cffd22863246f3a63f3d116630378c0ab10a19966ec0d7b6e8a6 | ||
DIST recover-broken-vdb-0.0.3.tar.gz 12492 BLAKE2B aa3fb529cac6d61ed7f41364c784c3879fe1993ace84ad48e648db4bb970c348a55714091a0c467c75234f8e0eecf448fbd20e198c0998240e5f89d0a285dca1 SHA512 e102406b1921527e2564f28d3fcc28e7507f7148b849f35ba0157fc299135ecfc304a3c60ed06900daea95382645414268eb008dcc405112fdf8d74fc1a64d41 |
29 changes: 29 additions & 0 deletions
29
app-portage/recover-broken-vdb/recover-broken-vdb-0.0.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
DISTUTILS_SINGLE_IMPL=1 | ||
DISTUTILS_USE_SETUPTOOLS=pyproject.toml | ||
PYTHON_COMPAT=( python3_{8..10} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Check Portage's VDB for internal inconsistency on ELF metadata" | ||
HOMEPAGE="https://github.com/thesamesam/recover-broken-vdb" | ||
if [[ ${PV} == *9999 ]] ; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/thesamesam/recover-broken-vdb.git" | ||
else | ||
SRC_URI="https://github.com/thesamesam/recover-broken-vdb/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz" | ||
#KEYWORDS="~amd64" | ||
fi | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
# Require latest version of pax-utils to avoid users breaking their systems again | ||
# The tool itself works fine with older versions | ||
RDEPEND=">=app-misc/pax-utils-1.3.3 | ||
sys-apps/file | ||
$(python_gen_cond_dep 'sys-apps/portage[${PYTHON_USEDEP}]')" |