forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-plugins/kodi-game-libretro-twentyfortyeight: 1.0.0.117 version …
…bump Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Craig Andrews <[email protected]>
- Loading branch information
Showing
2 changed files
with
40 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kodi-game-libretro-twentyfortyeight-1.0.0.116.tar.gz 94694 BLAKE2B 2689fd39310bc62eb3ccdd5b55b59f92ad07d2ca38ad30a2d15bcaed15775d32e886cb2f400544deb74accbb7926c43ca15ad39a03a7658623778fc3b47c20c5 SHA512 7f31a6b0e3dd7ba1e5cc96700653b243c559e17f772aa0b71b46c9bd3eeebf30923236bcb598cefbc7d730d3e9c2cbfee81701899edfee17d5e5a1c509bad0cd | ||
DIST kodi-game-libretro-twentyfortyeight-1.0.0.117.tar.gz 94692 BLAKE2B f685aa7084e0965a05dc0cdf61d105f227c409c6a88e1ad2a028f98e6501476cdea00680038b5ebbd44b24d076774a6bc25a58473ba8d69582485ea23dedccef SHA512 8161eb89ca70d263748d8955305d898dafc2693034b60bb100a4821bc9c7016e0e42d140d1cc8261f941ce0101903d33b395686f69597d3653d62229fd999f52 |
39 changes: 39 additions & 0 deletions
39
.../kodi-game-libretro-twentyfortyeight/kodi-game-libretro-twentyfortyeight-1.0.0.117.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit cmake kodi-addon | ||
|
||
DESCRIPTION="2048 for Kodi" | ||
HOMEPAGE="https://github.com/kodi-game/game.libretro.2048" | ||
SRC_URI="" | ||
|
||
if [[ ${PV} == *9999 ]]; then | ||
SRC_URI="" | ||
EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.2048.git" | ||
inherit git-r3 | ||
else | ||
KEYWORDS="~amd64 ~x86" | ||
CODENAME="Matrix" | ||
SRC_URI="https://github.com/kodi-game/game.libretro.2048/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/game.libretro.2048-${PV}-${CODENAME}" | ||
fi | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
=media-tv/kodi-19* | ||
games-emulation/libretro-twentyfortyeight | ||
" | ||
RDEPEND=" | ||
media-plugins/kodi-game-libretro | ||
${DEPEND} | ||
" | ||
|
||
src_prepare() { | ||
echo 'find_library(2048_LIB NAMES 2048_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-2048.cmake" || die | ||
cmake_src_prepare | ||
} |