Skip to content

Commit

Permalink
sys-apps/toybox: Bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
patricklauer committed Feb 27, 2018
1 parent bbfe51a commit 2d9a195
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/toybox/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,4 @@ DIST toybox-0.7.2.tar.gz 798101 BLAKE2B 0d134fdfe10f77cf4083c5609a9e4ba94bdbfa17
DIST toybox-0.7.3.tar.gz 806773 BLAKE2B 25b9cc7b5edcb342fb4aa51917d66bb6ff8f683399647655754759f55854569e264d68adeb3b180008fa7f0665a708b3935898b7c032947430261510df5377a8 SHA512 8f6fcf156fbfedb706f3048b535369e235c47a40087405e54f0b0de877691c41b700b2ddd8c0d5abd6e09367f313c2eef1bc659331b2391738f6f0eefc9115fd
DIST toybox-0.7.4.tar.gz 817027 BLAKE2B 46997663edea326eb04c630217cca09a61c5add9f01813357831ad1a33ea99870c094abf15aa16c5ad4a5a21ada9a7d7de7660ad2a4831824a7170d472c58f3b SHA512 380e8c22f1bcea34ee345b9bcfd9459c7bcde8518d0f5c74227ced2e59b063f619e1b6314c1af4e0371d7300fe916d55510272469a061c4232005b7533b09022
DIST toybox-0.7.5.tar.gz 818815 BLAKE2B 0d91eb07b9c2e64c611be24eb09aac7ffc26d65f3dd39ee7663419e4eff1e9d559b7b6e8df0dc8e13986124aefa706b343c4a3521466f2bdf657d4c9a82a9fc2 SHA512 f0cc54da2394ed14b41dbc80bf674f86989f0312b645b9e1e5403fb0a3282cafce9608b2d738ab2dbb6fe3779eed70d51133a867c6ea76683dd7e6de245df127
DIST toybox-0.7.6.tar.gz 834351 BLAKE2B 7c6737a8b16f77fd7a5e389be17ef8eb41d28718e46231ec1aa48af0a0ec1cbdc1c0b74670c3f79f58a5b0547f47aa6e5ccbaccc5451b12a80e1c566ee49a30d SHA512 1ed06114f5feb46e642bfeee517366a16c0a5d76562841a3cdf6b003bb330be10d4ac5009c7cf845eb5ea99bb8ae8b4291c413bbd45fd89c2ae3e4a69c1455bb
57 changes: 57 additions & 0 deletions sys-apps/toybox/toybox-0.7.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils multiprocessing savedconfig toolchain-funcs

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gfto/toybox.git"
else
SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

# makefile is stupid
RESTRICT="test"

DESCRIPTION="Common linux commands in a multicall binary"
HOMEPAGE="http://landley.net/code/toybox/"

# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
LICENSE="BSD-2"
SLOT="0"
IUSE=""

src_prepare() {
epatch_user
restore_config .config
}

src_configure() {
if [ -f .config ]; then
yes "" | emake -j1 oldconfig > /dev/null
return 0
else
einfo "Could not locate user configfile, so we will save a default one"
emake defconfig > /dev/null
fi
}

src_compile() {
tc-export CC STRIP
export HOSTCC=$(tc-getBUILD_CC)
unset CROSS_COMPILE
export CPUS=$(makeopts_jobs)
emake V=1
}

src_test() {
emake test
}

src_install() {
save_config .config
newbin generated/unstripped/toybox toybox
}

0 comments on commit 2d9a195

Please sign in to comment.