Skip to content

Commit

Permalink
dev-python/easy-thumbnails: Bump to 2.9
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jul 28, 2024
1 parent f4b3d36 commit 2da88fb
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/easy-thumbnails/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST easy-thumbnails-2.8.5.tar.gz 77401 BLAKE2B 625e01a5bf0af7a88dc965908c7e499bd57bc0860aad663e3dc341060d485885572dfb2b971499080659757eecd01bd3a479d3c2bc8b2bfdbf3ef79a4f1a7255 SHA512 0a659eb2a6067e2e2fa825a3c304ea57bf102902c92c662c6b38f6fc7b4a17883144aea10c67a3d6321c3911e6d5dd2633345d4f180f7f7854b3985772ad0273
DIST easy_thumbnails-2.9.tar.gz 78827 BLAKE2B 96a27894d46d7b16b25b7134ca3b4e57ccf08756ec655bd9e5420c341132176d494c8fbd36ba6b9a9dbca13676fc4896366fdd4a198625f2f47c6e9d6e6bf773 SHA512 659fe283bbf0713f76db9ac04969ed73147919b64537616fb76cf8ceb159ced8ae632dc3e10f87d6f979a2447d1196aa4b21aaeb91d537de4c318a433de8ae9f
45 changes: 45 additions & 0 deletions dev-python/easy-thumbnails/easy-thumbnails-2.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )

inherit distutils-r1 pypi

DESCRIPTION="Easy thumbnails for Django"
HOMEPAGE="
https://github.com/SmileyChris/easy-thumbnails/
https://pypi.org/project/easy-thumbnails/
"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="svg test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-python/django-2.2[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
svg? (
dev-python/reportlab[${PYTHON_USEDEP}]
dev-python/svglib[${PYTHON_USEDEP}]
)
"
BDEPEND="
test? (
$(python_gen_impl_dep sqlite)
${RDEPEND}
dev-python/reportlab[${PYTHON_USEDEP}]
dev-python/svglib[${PYTHON_USEDEP}]
dev-python/testfixtures[${PYTHON_USEDEP}]
)
"

python_test() {
local -x DJANGO_SETTINGS_MODULE=easy_thumbnails.tests.settings
local -x PYTHONPATH="${S}"
django-admin test -v 2 || die "Tests failed with ${EPYTHON}"
}

0 comments on commit 2da88fb

Please sign in to comment.