Skip to content

Commit

Permalink
dev-python/typing: version bump to 3.6.2
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Sep 20, 2017
1 parent 221ef12 commit 2deb66f
Show file tree
Hide file tree
Showing 2 changed files with 31 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/typing/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST typing-3.5.2.2.tar.gz 51101 SHA256 2bce34292653af712963c877f3085250a336738e64f99048d1b8509bebc4772f SHA512 38d8899cf7ccfc86299ea59a234a80a7938ff9e78d84a9593befd163959ee90af3201dfd495e172904bc6423919b338bee470d166e9c41d9697662c27ed2fbc8 WHIRLPOOL 7cb2dad3b1f3fb5c50801d92336de755c96cf8fde984da2b18525ec53be391d02d1bd8f0d934bdd1708caa1465f3f1e0ea4d7b4fbc86eb411868de5c1db125d5
DIST typing-3.5.3.0.tar.gz 60350 SHA256 ca2daac7e393e8ee86e9140cd0cf0172ff6bb50ebdf0b06281770f98f31bff21 SHA512 e1930de61cbb0b49ebeec49b87ce3a60752ed062ebf44ff2c5becf2e19a22726d08607ce6723b5b4e633190d8a9686176d44f7672c44bd246acb8e367c5d3c37 WHIRLPOOL d1e4f29b684084ca4370ed74d68e05f9723314f9144b825fb5b085c38644bf8460c2b1266382427d281550d43b85aa3395415f161a52d4769de24ded2b9777eb
DIST typing-3.6.2.tar.gz 78726 SHA256 d514bd84b284dd3e844f0305ac07511f097e325171f6cc4a20878d11ad771849 SHA512 a975980e7ba6ec3e15c938336877071785bec7212443da079770348ab9441c8d918cd806e85ebea8af66a5d94f684566ea07b55e7623ab11e7d922c8c3dfe981 WHIRLPOOL 0259037ee7c135b7f9a6887eb6a9cb95a181254880e6e13ccc3bab88385b0c0df1a5db1d7bfdaf250b4ec5e624d82c85c97521b670b1b2177298586ea3ef87b7
30 changes: 30 additions & 0 deletions dev-python/typing/typing-3.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )

inherit distutils-r1

DESCRIPTION="Type Hints for Python"
HOMEPAGE="https://docs.python.org/3/library/typing.html https://pypi.python.org/pypi/typing"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x64-solaris"
IUSE=""

DEPEND=""
RDEPEND=""

python_test() {
if [[ ${EPYTHON} == python2* || ${EPYTHON} == pypy ]]; then
cd "${S}"/python2 || die
else
cd "${S}"/src || die
fi

"${PYTHON}" test_typing.py || die "tests failed under ${EPYTHON}"
}

0 comments on commit 2deb66f

Please sign in to comment.