Skip to content

Commit

Permalink
dev-go/go-oauth2: version bump to 0_pre20160220
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
zmedico committed Feb 20, 2016
1 parent 862b5c5 commit 2df931f
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-go/go-oauth2/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST gcloud-golang-872c736f496c2ba12786bedbb8325576bbdb33cf.tar.gz 217728 SHA256 d4dc2064cc999c9c527fe50a05c44357d3471379bea3f82a95bfebbaa5373552 SHA512 45f0533c842a59dfee3b6d3f1facb9535466119601644a9a2c8c8b4f573889713b1d82d0acdeef96ea246d47d79402d09592b25da3ffbf73953bd28bf5b92ed9 WHIRLPOOL fadd0c32fbfcca9c01ad0a11f64ea4625cda858e4d241bcad35cdc1292bf258a370f4fdd73ecb7bb613fc1f0e8a52154dc3582dbcd776517713468cb2ab7c18a
DIST gcloud-golang-e34a32f9b0ecbc0784865fb2d47f3818c09521d4.tar.gz 168358 SHA256 817456c3b49ff6917604d201041d4f555e7f42328d5df036c68c26bf50c7455c SHA512 135124280cdbf0a9e62f811164b4b97f0ee5142736cc4a06efafd48162a89dd1a6f186264c925da27adc970c964ab0af75423025fd125b772ddb99320b816219 WHIRLPOOL 66a445585c17d0331b0ce24d9bde8c8942ba39d1d404e1b3b73cbaf173327ab0c43af5b7e980accf697100b12e3a544334a07f43f9f17ebac93ee7907b92b7ac
DIST go-oauth2-0_pre20150701.tar.gz 32040 SHA256 ce9b602dd7f05c819002d6400585c2f09e8e1880a0fe358a4d4f56a6594ccedd SHA512 d809e1d63c7b5a4b388616d930cb22978b1653e2314b208d12679242bdd0e9d72f275f5ade7aa468b1dcf3960aa70ff94183ae1dd04325b24cdd20ef4834880a WHIRLPOOL 984438676de52f635206a3bb19b77e7f05c9c78a2ce6beabbe82cc22fb28fa0c7e3717a596a9b0c967615574ad6e53da0510bc1ecd0a38edd23680622320d6a0
DIST go-oauth2-0_pre20160220.tar.gz 32040 SHA256 ce9b602dd7f05c819002d6400585c2f09e8e1880a0fe358a4d4f56a6594ccedd SHA512 d809e1d63c7b5a4b388616d930cb22978b1653e2314b208d12679242bdd0e9d72f275f5ade7aa468b1dcf3960aa70ff94183ae1dd04325b24cdd20ef4834880a WHIRLPOOL 984438676de52f635206a3bb19b77e7f05c9c78a2ce6beabbe82cc22fb28fa0c7e3717a596a9b0c967615574ad6e53da0510bc1ecd0a38edd23680622320d6a0
66 changes: 66 additions & 0 deletions dev-go/go-oauth2/go-oauth2-0_pre20160220.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils golang-base

MY_PN=${PN##*-}
GO_PN=golang.org/x/${MY_PN}
EGIT_COMMIT="8914e5017ca260f2a3a1575b1e6868874050d95e"

HOMEPAGE="https://godoc.org/${GO_PN}"
DESCRIPTION="Go client implementation for OAuth 2.0 spec"
SRC_URI="
https://github.com/golang/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
https://github.com/GoogleCloudPlatform/gcloud-golang/archive/872c736f496c2ba12786bedbb8325576bbdb33cf.tar.gz -> gcloud-golang-872c736f496c2ba12786bedbb8325576bbdb33cf.tar.gz"

SLOT="0/${PVR}"
LICENSE="BSD"
KEYWORDS="~amd64"
IUSE=""

DEPEND="
dev-go/go-net:=
dev-go/go-tools"
RDEPEND=""

S="${WORKDIR}/src/${GO_PN}"

EGIT_CHECKOUT_DIR="${S}"
STRIP_MASK="*.a"

src_unpack() {
default
mkdir -p src/${GO_PN%/*} || die
mv ${MY_PN}-${EGIT_COMMIT} src/${GO_PN} || die

# Create a writable GOROOT in order to avoid sandbox violations.
export GOROOT="${WORKDIR}/goroot" GOPATH="${WORKDIR}/:$(get_golibdir_gopath)"
cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
rm -rf "${GOROOT}/src/${GO_PN}" || die

mkdir -p "${GOROOT}/src/google.golang.org" || die
rm -rf "${GOROOT}/src/google.golang.org"/* || die
rm -rf "${GOROOT}/pkg/${KERNEL}_${ARCH}/google.golang.org" || die
mv gcloud-golang-872c736f496c2ba12786bedbb8325576bbdb33cf "${GOROOT}/src/google.golang.org/cloud" || die
}

src_compile() {
go install -v -x -work google.golang.org/cloud/compute/metadata || die
go install -v -x -work ${GO_PN}/... || die
}

src_test() {
# google/example_test.go imports appengine, introducing a circular dep
mv google/example_test.go{,_}
go test -x -v ${GO_PN}/... || die $?
mv google/example_test.go{_,}
}

src_install() {
insinto /usr/lib/go
insopts -m0644 -p # preserve timestamps for bug 551486
doins -r "${WORKDIR}"/{pkg,src}
}

0 comments on commit 2df931f

Please sign in to comment.