forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-cdr/dolphin-plugins-mountiso: 24.04.90 version bump
Signed-off-by: Andreas Sturmlechner <[email protected]>
- Loading branch information
Showing
2 changed files
with
64 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST dolphin-plugins-23.04.3.tar.xz 272912 BLAKE2B f0eb8bbab16d66f1e964131b436af7d3ae8febc26cf4fe394489a978c701ef2f5689bea7daf9eed8d7ef2f1f2bdba000a487cf7f0704ad30bd25e2d403ce5fae SHA512 8f487ba0bcbe561915064247ddb2327c3b7c8fa6ffc5c511d9c9ef37bd4f28a624533ce7a2da2a86b10b65f37915ca10840517872b40c2fd014cead6da5972c8 | ||
DIST dolphin-plugins-23.08.5.tar.xz 274124 BLAKE2B c8b43bd7f87c7221023e75e3f66b450844b379d5bfc95e37ce01dfe983ba3dc234a319da2aaf0596e6eb54319bc4310c718b57d52d070f0f86cd67c6f67a8c4b SHA512 2dd30070660df63b988cda2e14f3ddc27a0cf451119d2a6b121cb9cbeb8788b94498ef25ca434501843784a8e24c4539fe17cc0ab5a158befbc9db5792944852 | ||
DIST dolphin-plugins-24.02.2.tar.xz 298356 BLAKE2B e40f64b6a97961ba9f614ba2a795d42c460b65073e1ab5c502cbd87f4810e0e381562890646501446af544aec5e7f790be266ec41407ef156e8a27ac0ba0d555 SHA512 585249422ef1637c2caee044a71d11c621127ef578131d2323e879b12bee2f17082c4811273e6bb0013d1386f7010ded187627965bfce0b1b412b25048cd11d8 | ||
DIST dolphin-plugins-24.04.90.tar.xz 304688 BLAKE2B 9cb14275badd693abc2dab46f4e9192c63ff0e01ba0f7d5356df14b7c9fdb93c58e6b2fe22e4bd384c7a39457697fc3087093287c357758f86e1d9bb0f1cafc9 SHA512 94bd585ba80304728b228f2a2e623b5f05ecb4a73a80806aa47b4bd6506ec4a7aea52cdeebd3f31de80efe4cd8d2bcaf805de89abd736f87600726593224f5da |
63 changes: 63 additions & 0 deletions
63
app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.04.90.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,63 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
ECM_HANDBOOK="false" | ||
KDE_ORG_CATEGORY="sdk" | ||
KDE_ORG_NAME="dolphin-plugins" | ||
MY_PLUGIN_NAME="mountiso" | ||
KFMIN=6.0.0 | ||
PVCUT=$(ver_cut 1-3) | ||
QTMIN=6.6.2 | ||
inherit ecm gear.kde.org | ||
|
||
DESCRIPTION="Dolphin plugin for ISO loopback device mounting" | ||
HOMEPAGE="https://apps.kde.org/dolphin_plugins/" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="6" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
>=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets] | ||
>=kde-apps/dolphin-${PVCUT}:6 | ||
>=kde-frameworks/kcompletion-${KFMIN}:6 | ||
>=kde-frameworks/kconfig-${KFMIN}:6 | ||
>=kde-frameworks/kcoreaddons-${KFMIN}:6 | ||
>=kde-frameworks/ki18n-${KFMIN}:6 | ||
>=kde-frameworks/kio-${KFMIN}:6 | ||
>=kde-frameworks/ktextwidgets-${KFMIN}:6 | ||
>=kde-frameworks/solid-${KFMIN}:6 | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
ecm_src_prepare | ||
# qtconcurrent only required by git | ||
ecm_punt_qt_module Concurrent | ||
# kxmlgui, qtnetwork only required by dropbox | ||
ecm_punt_qt_module Network | ||
ecm_punt_kf_module XmlGui | ||
# delete non-${PN} translations | ||
find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DBUILD_${MY_PLUGIN_NAME}=ON | ||
-DBUILD_bazaar=OFF | ||
-DBUILD_dropbox=OFF | ||
-DBUILD_git=OFF | ||
-DBUILD_hg=OFF | ||
-DBUILD_makefileactions=OFF | ||
-DBUILD_svn=OFF | ||
) | ||
ecm_src_configure | ||
} | ||
|
||
src_install() { | ||
ecm_src_install | ||
rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die | ||
} |