forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-action/extreme-tuxracer: version bump (bug #578406)
Package-Manager: portage-2.2.26
- Loading branch information
Michael Sterrett
committed
Mar 29, 2016
1 parent
7d78390
commit 2e7174d
Showing
2 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST etr-0.6.0.tar.xz 32889668 SHA256 44312719a1e9aa33e5aa0c8ad50bb52df702d64fd2d16bf2abda62ee27bf893a SHA512 c3127dd1f8d9b856cc42808713a53b48a64821f020ecf3bfaae8be96e36eaddfadfedcf394d445ea1f49df650763b50d35a5ad9cac03308bcb1a4a473e4906d8 WHIRLPOOL d003d5ef070ed15d4521cc2025ceb372b18b69f3172065159b5fd18bf5f2126da4cc8c179b95311c63afd5093ec2700483697544ade7ad02e1f255e1cdfc44e4 | ||
DIST etr-0.7.1.tar.xz 44306872 SHA256 a47bd5c998b97e5cbc522f36318a7fa2cd9b9d2a2134efb224aaa452b9b148c4 SHA512 e6f4cb6fa59ac3534aac79822b398f59d94885530ba1ded15b96da6f5750946547f8a491349095d9a27d39e6a02f18e9bdaff6ea409f36f00c5309cd81d98c71 WHIRLPOOL 72c5434edce7c2bfcc59b997761a3154b68c4b8b8e7d564843fb16689a3f9e951fdcf87830e6f0b787c86d5b3969703f32db33e2bef691882d4d0269d25fb5b3 |
53 changes: 53 additions & 0 deletions
53
games-action/extreme-tuxracer/extreme-tuxracer-0.7.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit eutils autotools gnome2-utils games | ||
|
||
DESCRIPTION="High speed arctic racing game based on Tux Racer" | ||
HOMEPAGE="http://extremetuxracer.sourceforge.net/" | ||
SRC_URI="mirror://sourceforge/extremetuxracer/etr-${PV/_/}.tar.xz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="virtual/opengl | ||
virtual/glu | ||
>=media-libs/libsfml-2.2 | ||
media-libs/freetype:2" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/etr-${PV/_/} | ||
|
||
src_prepare() { | ||
# kind of ugly in there so we'll do it ourselves | ||
sed -i -e '/SUBDIRS/s/resources doc//' Makefile.am || die | ||
eautoreconf | ||
} | ||
|
||
src_install() { | ||
default | ||
dodoc doc/{code,courses_events,guide,score_algorithm} | ||
doicon -s 48 resources/etr.png | ||
doicon -s scalable resources/etr.svg | ||
domenu resources/etr.desktop | ||
prepgamesdirs | ||
} | ||
|
||
pkg_preinst() { | ||
games_pkg_preinst | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
games_pkg_postinst | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |