Skip to content

Commit

Permalink
sys-cluster/kubectl: Initial version
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
mrueg committed Feb 14, 2017
1 parent 97ea863 commit 2eabfd1
Show file tree
Hide file tree
Showing 3 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-cluster/kubectl/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST kubernetes-1.5.2.tar.gz 22165963 SHA256 e1c4050ff67d31a2a98d303785f52fbf5033c2f33b61d525a821fb82c8820eae SHA512 9c29767a356619cc6d4e49c37ab502706666e0857cad0695023b831d7a8d750169d9d7da55c35fbc109ad47466a1add7253196d816c96ca60468d5e41ca8876a WHIRLPOOL 07fa17d259669f548f295dc827fdb3850af203121a50e8885eb4d402c48c7ca06d4df798bea392fadaad0e70f70d46270c456f7e088dc0dd5b1618148c3e48fe
38 changes: 38 additions & 0 deletions sys-cluster/kubectl/kubectl-1.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit user golang-build golang-vcs-snapshot

EGO_PN="k8s.io/kubernetes/..."
ARCHIVE_URI="https://github.com/kubernetes/kubernetes/archive/v${PV}.tar.gz -> kubernetes-${PV}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="CLI to run commands against Kubernetes clusters"
HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
SRC_URI="${ARCHIVE_URI}"

LICENSE="Apache-2.0"
SLOT="0"
IUSE=""

DEPEND="dev-go/go-bindata"

RESTRICT="test"

src_prepare() {
default
sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" src/${EGO_PN%/*}/hack/lib/golang.sh || die
sed -i -e "/export PATH/d" src/${EGO_PN%/*}/hack/generate-bindata.sh || die
}

src_compile() {
LDFLAGS="" GOPATH="${WORKDIR}/${P}" emake -j1 -C src/${EGO_PN%/*} WHAT=cmd/${PN}
}

src_install() {
pushd src/${EGO_PN%/*} || die
dobin _output/bin/${PN}
popd || die
}
8 changes: 8 additions & 0 deletions sys-cluster/kubectl/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Manuel Rüger</name>
</maintainer>
</pkgmetadata>

0 comments on commit 2eabfd1

Please sign in to comment.