Skip to content

Commit

Permalink
media-libs/Field3D: EAPI-7 bump, USE mpi, add proper src_configure()
Browse files Browse the repository at this point in the history
Properly disabling Doxygen (don't even build it if it ain't finished).

Closes: https://bugs.gentoo.org/573440
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed May 21, 2019
1 parent 9906825 commit 2ec025c
Showing 1 changed file with 18 additions and 11 deletions.
29 changes: 18 additions & 11 deletions media-libs/Field3D/Field3D-1.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit cmake-utils

Expand All @@ -12,17 +12,24 @@ SRC_URI="https://github.com/imageworks/Field3D/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~x86"
IUSE="mpi"

BDEPEND="virtual/pkgconfig"
RDEPEND="
>=dev-libs/boost-1.62:=
>=media-libs/ilmbase-2.2.0:=
sci-libs/hdf5:=
virtual/mpi"

DEPEND="${RDEPEND}
virtual/pkgconfig"

PATCHES=( "${FILESDIR}/Field3D-1.7.2-Use-PkgConfig-for-IlmBase.patch" )

# Docs are not finished yet.
mycmakeargs=( -DINSTALL_DOCS=OFF )
mpi? ( virtual/mpi )
"
DEPEND="${RDEPEND}"

PATCHES=( "${FILESDIR}/${P}-Use-PkgConfig-for-IlmBase.patch" )

src_configure() {
local mycmakeargs=(
-DINSTALL_DOCS=OFF # Docs are not finished yet.
-DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON
$(cmake-utils_use_find_package mpi MPI)
)
cmake-utils_src_configure
}

0 comments on commit 2ec025c

Please sign in to comment.