Skip to content

Commit

Permalink
dev-util/envman: new ebuild, version 1.2.0
Browse files Browse the repository at this point in the history
  • Loading branch information
koral-- authored and tonyvroon committed Jul 17, 2018
1 parent cabd4d7 commit 2ed2865
Show file tree
Hide file tree
Showing 3 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/envman/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST envman-1.2.0.tar.gz 2997860 BLAKE2B e49d3b421fb1ab226de4430e90d8c684bc3a2554205c6383a140c0832134eaba338797dca44668fc2473d248940b5499395ab3a6d3359382305fd8a719772257 SHA512 5245aea8c280a6d6022e8132216891f09abee707c0ed736bfe6b4882aa23880a771dce5371b8ba5fcdd41fa951606727e7582442d897058b25985cf9dd5a9d18
38 changes: 38 additions & 0 deletions dev-util/envman/envman-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit golang-build

EGO_ON="github.com/bitrise-io"
EGO_PN="${EGO_ON}/${PN}"

DESCRIPTION="Environment variable manager for Bitrise CLI."
HOMEPAGE="https://www.bitrise.io/cli"
SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"

S="${WORKDIR}/src/${EGO_ON}/${PN}"

src_unpack() {
unpack ${A}
mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/envman" || die "Couldn't move sources to GOPATH"
}

src_compile() {
GOPATH="${WORKDIR}" go build -v -o bin/envman || die "Couldn't compile envman"
}

src_test() {
GOPATH="${WORKDIR}" go test ./... || die "Tests failed"
}

src_install() {
dobin bin/envman
dodoc README.md
}
19 changes: 19 additions & 0 deletions dev-util/envman/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Karol Wrótniak</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
<longdescription>Environment variable manager for Bitrise CLI. Part of the Bitrise Continuous Integration, Delivery and Automations Stack, with stepman and bitrise. For a nice &amp; quick intro you should check: https://www.bitrise.io/cli</longdescription>
<upstream>
<bugs-to>https://github.com/bitrise-io/envman/issues</bugs-to>
<changelog>https://github.com/bitrise-io/envman/blob/master/CHANGELOG.md</changelog>
<doc>https://github.com/bitrise-io/envman/blob/master/README.md</doc>
<remote-id type="github">bitriseio/envman</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 2ed2865

Please sign in to comment.