Skip to content

Commit

Permalink
gnome-base/gnome-session: version bump 3.22.1 → 3.22.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
EvaSDK committed Nov 12, 2016
1 parent e9a3d0a commit 2ee2ac5
Show file tree
Hide file tree
Showing 2 changed files with 123 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/gnome-session/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gnome-session-3.20.2.tar.xz 785952 SHA256 025f97e0b9f5431890598d6130040e1e7071771cc29e1d29d8e2e7c84d95f6da SHA512 0973c9763195a79038d99139f56eff8d7ad1fccc4c4e41a6439b5c65c615059a21446545af70f4ed83ec6925fd61a7664e70eec844dfe5e2a1001dffdbbea13a WHIRLPOOL 4a3cf1580b966a0b617e78db45635ec66d7bdfb6d5b183390edb07aaae3911876ff4af774cb0ae93c6ee4316555303812fcff40efce1827946457cb2a0646f61
DIST gnome-session-3.22.1.tar.xz 775664 SHA256 a09f7ee1706d85bb2b66f9a1f7082f737d072b44805e13f6c9f14538616373a5 SHA512 f3a42590f915a9067d330da563dc509f98eb4114c0808c070ac0b4cb27dc12ff366ba50e449385c5b9d2aad8425d3c5aff1239920f47a4001c0bd084dcf93420 WHIRLPOOL c1e13c43a62e3a671de1cbe3193047e19bff5239164231ab9d7cbf951c18a905e3b94686daaaeb53fac045697bf4d23d23b6a6a75552a1a32501aa939ffa15bc
DIST gnome-session-3.22.2.tar.xz 776772 SHA256 361a31edb4f8c6d410f1029eee089422e25a2da6c287ead40fccdea5bda450f5 SHA512 2c84a3a791d740c8edc2af96e8ed0b56f56dfac20fde6e8bc23a7aa75c0a004e98fcb9bb85b043ed3b1cd57cdc889348c461d9536cd2631dd53d8a0d6f8e2acf WHIRLPOOL b2fbfb0ecbd5b54714a900d8615c04b1ac0bee51e6c2d8ff11c2592769cd42292af0db9f86a51655bda943c7cc880155d403854629ec8810578f02232dfec29f
122 changes: 122 additions & 0 deletions gnome-base/gnome-session/gnome-session-3.22.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,122 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit gnome2

DESCRIPTION="Gnome session manager"
HOMEPAGE="https://git.gnome.org/browse/gnome-session"

LICENSE="GPL-2 LGPL-2 FDL-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="doc elibc_FreeBSD ipv6 systemd"

# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).
# gdk-pixbuf used in the inhibit dialog
COMMON_DEPEND="
>=dev-libs/glib-2.46.0:2[dbus]
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.18.0:3
>=dev-libs/json-glib-0.10
>=gnome-base/gnome-desktop-3.18:3=
elibc_FreeBSD? ( dev-libs/libexecinfo )
media-libs/mesa[egl,gles2]
media-libs/libepoxy
x11-libs/libSM
x11-libs/libICE
x11-libs/libXau
x11-libs/libX11
x11-libs/libXcomposite
x11-libs/libXext
x11-libs/libXrender
x11-libs/libXtst
x11-misc/xdg-user-dirs
x11-misc/xdg-user-dirs-gtk
x11-apps/xdpyinfo
systemd? ( >=sys-apps/systemd-183:0= )
"
# Pure-runtime deps from the session files should *NOT* be added here
# Otherwise, things like gdm pull in gnome-shell
# gnome-themes-standard is needed for the failwhale dialog themeing
# sys-apps/dbus[X] is needed for session management
RDEPEND="${COMMON_DEPEND}
gnome-base/gnome-settings-daemon
>=gnome-base/gsettings-desktop-schemas-0.1.7
x11-themes/adwaita-icon-theme
sys-apps/dbus[X]
!systemd? (
sys-auth/consolekit
>=dev-libs/dbus-glib-0.76
)
"
DEPEND="${COMMON_DEPEND}
dev-libs/libxslt
>=dev-util/intltool-0.40.6
>=sys-devel/gettext-0.10.40
virtual/pkgconfig
!<gnome-base/gdm-2.20.4
doc? (
app-text/xmlto
dev-libs/libxslt )
"
# gnome-common needed for eautoreconf
# gnome-base/gdm does not provide gnome.desktop anymore

src_configure() {
# 1. Avoid automagic on old upower releases
# 2. xsltproc is always checked due to man configure
# switch, even if USE=-doc
# 3. Disable old gconf support as other distributions did long time
# ago
gnome2_src_configure \
--disable-deprecation-flags \
--disable-gconf \
--enable-session-selector \
$(use_enable doc docbook-docs) \
$(use_enable ipv6) \
$(use_enable systemd) \
$(use_enable !systemd consolekit) \
UPOWER_CFLAGS="" \
UPOWER_LIBS=""
# gnome-session-selector pre-generated man page is missing
#$(usex !doc XSLTPROC=$(type -P true))
}

src_install() {
gnome2_src_install

dodir /etc/X11/Sessions
exeinto /etc/X11/Sessions
doexe "${FILESDIR}/Gnome"

insinto /usr/share/applications
newins "${FILESDIR}/defaults.list-r3" gnome-mimeapps.list

dodir /etc/X11/xinit/xinitrc.d/
exeinto /etc/X11/xinit/xinitrc.d/
newexe "${FILESDIR}/15-xdg-data-gnome-r1" 15-xdg-data-gnome

# This should be done here as discussed in bug #270852
newexe "${FILESDIR}/10-user-dirs-update-gnome-r1" 10-user-dirs-update-gnome

# Set XCURSOR_THEME from current dconf setting instead of installing
# default cursor symlink globally and affecting other DEs (bug #543488)
# https://bugzilla.gnome.org/show_bug.cgi?id=711703
newexe "${FILESDIR}/90-xcursor-theme-gnome" 90-xcursor-theme-gnome
}

pkg_postinst() {
gnome2_pkg_postinst

if ! has_version gnome-base/gdm && ! has_version kde-base/kdm; then
ewarn "If you use a custom .xinitrc for your X session,"
ewarn "make sure that the commands in the xinitrc.d scripts are run."
fi
}

0 comments on commit 2ee2ac5

Please sign in to comment.