Skip to content

Commit

Permalink
gui-wm/sway: tweak for gcc-10, bug #708704
Browse files Browse the repository at this point in the history
Apply upstream 29a5ce5 "Fix compiling with -fno-common ".

Reported-by: Jeroen Roovers
Closes: https://bugs.gentoo.org/708704
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Apr 17, 2020
1 parent 4cdd503 commit 2ef12a3
Show file tree
Hide file tree
Showing 2 changed files with 160 additions and 0 deletions.
42 changes: 42 additions & 0 deletions gui-wm/sway/files/sway-1.4-gcc-10.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
https://bugs.gentoo.org/708704

From 29a5ce5f65d04b046271fbe53850836c77bbee80 Mon Sep 17 00:00:00 2001
From: thermitegod <[email protected]>
Date: Thu, 23 Jan 2020 18:12:00 -0700
Subject: [PATCH] Fix compiling with -fno-common

---
include/sway/server.h | 4 ++--
sway/main.c | 1 +
2 files changed, 3 insertions(+), 2 deletions(-)

--- a/include/sway/server.h
+++ b/include/sway/server.h
@@ -78,7 +78,7 @@ struct sway_server {
list_t *dirty_nodes;
};

-struct sway_server server;
+extern struct sway_server server;

struct sway_debug {
bool noatomic; // Ignore atomic layout updates
@@ -92,7 +92,7 @@ struct sway_debug {
} damage;
};

-struct sway_debug debug;
+extern struct sway_debug debug;

/* Prepares an unprivileged server_init by performing all privileged operations in advance */
bool server_privileged_prepare(struct sway_server *server);
--- a/sway/main.c
+++ b/sway/main.c
@@ -27,6 +27,7 @@
static bool terminate_request = false;
static int exit_value = 0;
struct sway_server server = {0};
+struct sway_debug debug = {0};

void sway_terminate(int exit_code) {
if (!server.wl_display) {
118 changes: 118 additions & 0 deletions gui-wm/sway/sway-1.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,118 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit eutils meson

DESCRIPTION="i3-compatible Wayland window manager"
HOMEPAGE="https://swaywm.org"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
else
MY_PV=${PV/_rc/-rc}
SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi

LICENSE="MIT"
SLOT="0"
IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd tray wallpapers X zsh-completion"
REQUIRED_USE="?? ( elogind systemd )
tray? ( || ( elogind systemd ) )"

DEPEND="
>=dev-libs/json-c-0.13:0=
>=dev-libs/libinput-1.6.0:0=
dev-libs/libpcre
dev-libs/wayland
x11-libs/cairo
x11-libs/libxkbcommon
x11-libs/pango
x11-libs/pixman
media-libs/mesa[gles2]
elogind? ( >=sys-auth/elogind-239 )
swaybar? ( x11-libs/gdk-pixbuf:2 )
swaybg? ( gui-apps/swaybg )
swayidle? ( gui-apps/swayidle )
swaylock? ( gui-apps/swaylock )
systemd? ( >=sys-apps/systemd-239 )
X? ( x11-libs/libxcb:0= )
"
if [[ ${PV} == 9999 ]]; then
DEPEND+="~gui-libs/wlroots-9999:=[elogind=,systemd=,X=]"
else
DEPEND+="
>=gui-libs/wlroots-0.10.0:=[elogind=,systemd=,X=]
<gui-libs/wlroots-0.11.0:=[elogind=,systemd=,X=]
"
fi
RDEPEND="
x11-misc/xkeyboard-config
${DEPEND}
"
BDEPEND="
>=dev-libs/wayland-protocols-1.14
virtual/pkgconfig
"
if [[ ${PV} == 9999 ]]; then
BDEPEND+="man? ( ~app-text/scdoc-9999 )"
else
BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
fi

PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)

src_prepare() {
default

use swaybar || sed -e "s/subdir('swaybar')//g" -e "/sway-bar.[0-9].scd/d" \
-e "/completions\/[a-z]\+\/_\?swaybar/d" -i meson.build || die
use swaymsg || sed -e "s/subdir('swaymsg')//g" -e "/swaymsg.[0-9].scd/d" \
-e "/completions\/[a-z]\+\/_\?swaymsg/d" -i meson.build || die
use swaynag || sed -e "s/subdir('swaynag')//g" -e "/swaynag.[0-9].scd/d" \
-e "/completions\/[a-z]\+\/_\?swaynag/d" -i meson.build || die
}

src_configure() {
local emesonargs=(
-Dman-pages=$(usex man enabled disabled)
-Dtray=$(usex tray enabled disabled)
-Dxwayland=$(usex X enabled disabled)
$(meson_use wallpapers default-wallpaper)
$(meson_use fish-completion fish-completions)
$(meson_use zsh-completion zsh-completions)
"-Dbash-completions=true"
"-Dwerror=false"
)

if use swaybar; then
emesonargs+=("-Dgdk-pixbuf=enabled")
else
emesonargs+=("-Dgdk-pixbuf=disabled")
fi

meson_src_configure
}

pkg_preinst() {
if ! use systemd && ! use elogind; then
fowners root:0 /usr/bin/sway
fperms 4511 /usr/bin/sway
fi
}

pkg_postinst() {
if ! use systemd && ! use elogind; then
elog ""
elog "If you use ConsoleKit2, remember to launch sway using:"
elog "exec ck-launch-session sway"
elog ""
elog "If your system does not set the XDG_RUNTIME_DIR environment"
elog "variable, you must set it manually to run Sway. See wiki"
elog "for details: https://wiki.gentoo.org/wiki/Sway"
fi
}

0 comments on commit 2ef12a3

Please sign in to comment.