forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/jupyter-collaboration: new package, add 2.0.5
This is renamed from the previous jupyter-server-ydoc. profiles/arch/amd64/x32: mask jupyter-collaboration on x32. Reference: https://jupyterlab.readthedocs.io/en/latest/user/rtc.html Bug: https://bugs.gentoo.org/915824 Signed-off-by: Benda Xu <[email protected]>
- Loading branch information
Showing
5 changed files
with
98 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST jupyter_collaboration-2.0.5.tar.gz 4806126 BLAKE2B 5df0d7f782f9574e9f48ea805786b8e85a71fa2938189eef31e0d674e7c173f14d388952e33529f6666cecd9754191caaaeacea30cb090452d8545a19e3951d3 SHA512 e1375bc0559a06596e565cfe3b9b0f9a83a95a64d8a474cf7065172f9df5b84faa4f1966867bb475610df4662205146bb5720005601bafe77790e541681a3e8d |
42 changes: 42 additions & 0 deletions
42
dev-python/jupyter-collaboration/files/jupyter-collaboration-2.0.5-no-node-for-version.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
Index: jupyter_collaboration-2.0.3/pyproject.toml | ||
=================================================================== | ||
--- jupyter_collaboration-2.0.3.orig/pyproject.toml | ||
+++ jupyter_collaboration-2.0.3/pyproject.toml | ||
@@ -3,10 +3,11 @@ | ||
|
||
[build-system] | ||
build-backend = "hatchling.build" | ||
-requires = ["hatchling>=1.4.0", "hatch-nodejs-version", "jupyterlab>=4.0.0"] | ||
+requires = ["hatchling>=1.4.0", "jupyterlab>=4.0.0"] | ||
|
||
[project] | ||
name = "jupyter_collaboration" | ||
+version = "2.0.5" | ||
readme = "README.md" | ||
license = { file = "LICENSE" } | ||
requires-python = ">=3.8" | ||
@@ -34,7 +35,7 @@ dependencies = [ | ||
"jupyter_server_fileid>=0.7.0,<1", | ||
"jsonschema>=4.18.0" | ||
] | ||
-dynamic = ["version", "description", "authors", "urls", "keywords"] | ||
+dynamic = ["description", "authors", "urls", "keywords"] | ||
|
||
[project.optional-dependencies] | ||
dev = [ | ||
@@ -63,15 +64,9 @@ line-length = 100 | ||
[tool.isort] | ||
profile = "black" | ||
|
||
-[tool.hatch.version] | ||
-source = "nodejs" | ||
- | ||
[tool.hatch.build.hooks.version] | ||
path = "jupyter_collaboration/_version.py" | ||
|
||
-[tool.hatch.metadata.hooks.nodejs] | ||
-fields = ["description", "authors", "urls"] | ||
- | ||
[tool.hatch.build.targets.sdist] | ||
artifacts = ["/jupyter_collaboration/labextension"] | ||
exclude = ["/.github", "/binder", "node_modules"] |
42 changes: 42 additions & 0 deletions
42
dev-python/jupyter-collaboration/jupyter-collaboration-2.0.5.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=hatchling | ||
PYTHON_COMPAT=( python3_1{1..2} ) | ||
|
||
inherit distutils-r1 pypi | ||
|
||
DESCRIPTION="JupyterLab Extension enabling Real-Time Collaboration" | ||
HOMEPAGE="https://github.com/jupyterlab/jupyter-collaboration" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
IUSE="" | ||
RDEPEND="dev-python/pycrdt-websocket[${PYTHON_USEDEP}] | ||
>=dev-python/jupyterlab-4[${PYTHON_USEDEP}] | ||
>=dev-python/jupyter-ydoc-2[${PYTHON_USEDEP}] | ||
dev-python/jupyter-server-fileid[${PYTHON_USEDEP}] | ||
" | ||
BDEPEND="dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/pytest-jupyter[${PYTHON_USEDEP}] | ||
dev-python/pytest-timeout[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}-2.0.5-no-node-for-version.patch" | ||
) | ||
|
||
distutils_enable_tests pytest | ||
|
||
src_install() { | ||
distutils-r1_src_install | ||
|
||
# hatchling cannot install into /etc while specifying prefix as /usr | ||
mv -v "${ED}"{/usr,}/etc || die | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Gentoo Science Project</name> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="pypi">jupyter-collaboration</remote-id> | ||
<remote-id type="github">jupyterlab/jupyter-collaboration</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters