Skip to content

Commit

Permalink
media-tv/kodi: version bump to 15.2 #564162
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Nov 8, 2015
1 parent 056dcf0 commit 2f3a6fd
Show file tree
Hide file tree
Showing 2 changed files with 286 additions and 0 deletions.
2 changes: 2 additions & 0 deletions media-tv/kodi/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,5 @@ DIST kodi-14.1-generated-addons.tar.xz 71072 SHA256 0666eae88a3214f7577544975524
DIST kodi-14.1.tar.gz 70832109 SHA256 a38059e292cf8523918834e49fcc2d688525ceb7951ddf7f5ee535f4147255d6 SHA512 05dccad279073fc804faf2f179ba370f612d53c823dd333fdd151e05de37eb8202cc981ba48afff695d475bafde9c8f05f562fe09883593a70299a2f098a9849 WHIRLPOOL 464ff2673c9e65466dff73d3c91b8754ee68d64b4a18ebb0b0c6e8efa2da1cc32ab22686530a8469a105bf7a089d8928db64c5c61d272462c13485006875b506
DIST kodi-15.1-generated-addons.tar.xz 73988 SHA256 97f0236542044a909d982cbf9a031f76395a59a1d4a79187c1102845579ed8f2 SHA512 559c188471c84503840b8b2010b73f15cf083367a1e1d0d5cfe7c144e36821a07c6fff1ff379ad8e8b254bc0cc2555c0a17ae998003adf86b051febde97bf2f1 WHIRLPOOL 01b76391d6aa7c624ad23329c962416cdf4662b96e99724bb566d7ed20b08b1525acd4f12671eef04ac10e5255d097f7c2452d2bfd87f7dfd3f4c1cd621fe2a6
DIST kodi-15.1.tar.gz 61477835 SHA256 72b2610d8fbff807128d74429f25bf6716ba880c27c2c5d9fad012ec7fc70705 SHA512 b597253aa51d3d446ecb85ffe163362b5e55717d6fee16eab81725b9cdf0a5a9e4a2291aa526b9e63fbb34ef206100df30c9368684e2ddedc49e35f140d604f0 WHIRLPOOL 3596c00f9d25193e1e84cdfbf7fe5a6e6bdcce37caa710b8dd2b0b7aaa043164410459009dc793991373886abed8755298ee8803edf7b90227509d0c3578b8b9
DIST kodi-15.2-generated-addons.tar.xz 73912 SHA256 8c604be6188e03569209632dca96a9e333fa898e41651ac81f7fad2a45163610 SHA512 094ac1373a80d08371daad8fb1ee4422b8c16f77430fcd4a2b78ed0dc1883027086081e5788e07333c345121a20fda89b0bd5bcb2c8922b79573aca6e4726b9a WHIRLPOOL 560b8de1fa506ea1a73b5a0c539563649159dbb83b9996dc550e706037c5ff15dc657f382e55b2812797c1eee596b2b3b84a0061b6c74b2a5179a126a1841583
DIST kodi-15.2.tar.gz 61484128 SHA256 dd8aeb942e6de5d1488e243e1346cff3f6597e21b5131a3ba72ff5cc82037110 SHA512 870f67b83aaa96b1a4111f34824eb47c24616d067adf930f4456ca8f1ac57052c41aa73915304ea85b1d10390865b88d88c85e6cd425b42ec5a504908adf4b67 WHIRLPOOL 5d484ff8eb8b48de643bf6dbff0ca824d528143d2f6f78f124bae19a0f67db72271c865786520672ef716cedba4ad4ad11c59fe857c8b34ec9331724f09046c2
284 changes: 284 additions & 0 deletions media-tv/kodi/kodi-15.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,284 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

# Does not work with py3 here
# It might work with py:2.5 but I didn't test that
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"

inherit eutils linux-info python-single-r1 multiprocessing autotools toolchain-funcs

CODENAME="Isengard"
case ${PV} in
9999)
EGIT_REPO_URI="git://github.com/xbmc/xbmc.git"
inherit git-r3
;;
*|*_p*)
MY_PV=${PV/_p/_r}
MY_P="${PN}-${MY_PV}"
SRC_URI="http://mirrors.kodi.tv/releases/source/${MY_PV}-${CODENAME}.tar.gz -> ${P}.tar.gz
https://github.com/xbmc/xbmc/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz
!java? ( http://mirrors.kodi.tv/releases/source/${MY_P}-generated-addons.tar.xz )"
KEYWORDS="~amd64 ~x86"

S=${WORKDIR}/xbmc-${PV}-${CODENAME}
;;
esac

DESCRIPTION="Kodi is a free and open source media-player and entertainment hub"
HOMEPAGE="http://kodi.tv/ http://kodi.wiki/"

LICENSE="GPL-2"
SLOT="0"
IUSE="airplay alsa avahi bluetooth bluray caps cec css dbus debug +fishbmc gles goom java joystick midi mysql nfs +opengl profile +projectm pulseaudio +rsxs rtmp +samba sftp +spectrum test +texturepacker udisks upnp upower +usb vaapi vdpau +waveform webserver +X"
REQUIRED_USE="
rsxs? ( X )
udisks? ( dbus )
upower? ( dbus )
"

COMMON_DEPEND="${PYTHON_DEPS}
app-arch/bzip2
app-arch/unzip
app-arch/zip
app-i18n/enca
airplay? ( app-pda/libplist )
dev-libs/boost
dev-libs/expat
dev-libs/fribidi
dev-libs/libcdio[-minimal]
cec? ( >=dev-libs/libcec-3.0 )
dev-libs/libpcre[cxx]
dev-libs/libxml2
dev-libs/libxslt
>=dev-libs/lzo-2.04
dev-libs/tinyxml[stl]
dev-libs/yajl
dev-python/simplejson[${PYTHON_USEDEP}]
media-fonts/corefonts
media-fonts/roboto
alsa? ( media-libs/alsa-lib )
media-libs/flac
media-libs/fontconfig
media-libs/freetype
media-libs/jasper
media-libs/jbigkit
>=media-libs/libass-0.9.7
bluray? ( media-libs/libbluray )
css? ( media-libs/libdvdcss )
media-libs/libmad
media-libs/libmodplug
media-libs/libmpeg2
media-libs/libogg
media-libs/libpng:0=
projectm? ( media-libs/libprojectm )
media-libs/libsamplerate
joystick? ( media-libs/libsdl2 )
>=media-libs/taglib-1.8
media-libs/libvorbis
media-libs/tiff:0=
pulseaudio? ( media-sound/pulseaudio )
media-sound/wavpack
>=media-video/ffmpeg-2.6:=[encode]
rtmp? ( media-video/rtmpdump )
avahi? ( net-dns/avahi )
nfs? ( net-fs/libnfs:= )
webserver? ( net-libs/libmicrohttpd[messages] )
sftp? ( net-libs/libssh[sftp] )
net-misc/curl
samba? ( >=net-fs/samba-3.4.6[smbclient(+)] )
bluetooth? ( net-wireless/bluez )
dbus? ( sys-apps/dbus )
caps? ( sys-libs/libcap )
sys-libs/zlib
virtual/jpeg:0=
usb? ( virtual/libusb:1 )
mysql? ( virtual/mysql )
opengl? (
virtual/glu
virtual/opengl
>=media-libs/glew-1.5.6
)
gles? (
media-libs/mesa[gles2]
)
vaapi? ( x11-libs/libva[opengl] )
vdpau? (
|| ( x11-libs/libvdpau >=x11-drivers/nvidia-drivers-180.51 )
media-video/ffmpeg[vdpau]
)
X? (
x11-apps/xdpyinfo
x11-apps/mesa-progs
x11-libs/libXinerama
x11-libs/libXrandr
x11-libs/libXrender
)"
RDEPEND="${COMMON_DEPEND}
!media-tv/xbmc
udisks? ( sys-fs/udisks:0 )
upower? ( || ( sys-power/upower sys-power/upower-pm-utils ) )"
DEPEND="${COMMON_DEPEND}
app-arch/xz-utils
dev-lang/swig
dev-util/gperf
texturepacker? ( media-libs/giflib )
X? ( x11-proto/xineramaproto )
dev-util/cmake
x86? ( dev-lang/nasm )
java? ( virtual/jre )
test? ( dev-cpp/gtest )"
# Force java for latest git version to avoid having to hand maintain the
# generated addons package. #488118
[[ ${PV} == "9999" ]] && DEPEND+=" virtual/jre"

CONFIG_CHECK="~IP_MULTICAST"
ERROR_IP_MULTICAST="
In some cases Kodi needs to access multicast addresses.
Please consider enabling IP_MULTICAST under Networking options.
"

pkg_setup() {
check_extra_config
python-single-r1_pkg_setup
}

src_unpack() {
[[ ${PV} == "9999" ]] && git-r3_src_unpack || default
}

src_prepare() {
epatch "${FILESDIR}"/${PN}-9999-no-arm-flags.patch #400617
epatch "${FILESDIR}"/${PN}-15.1-texturepacker.patch
epatch_user #293109

# some dirs ship generated autotools, some dont
multijob_init
local d dirs=(
tools/depends/native/TexturePacker/src/configure
$(printf 'f:\n\t@echo $(BOOTSTRAP_TARGETS)\ninclude bootstrap.mk\n' | emake -f - f)
)
for d in "${dirs[@]}" ; do
[[ -e ${d} ]] && continue
pushd ${d/%configure/.} >/dev/null || die
AT_NOELIBTOOLIZE="yes" AT_TOPLEVEL_EAUTORECONF="yes" \
multijob_child_init eautoreconf
popd >/dev/null
done
multijob_finish
elibtoolize

if [[ ${PV} == "9999" ]] || use java ; then #558798
tc-env_build emake -f codegenerator.mk
fi

# Disable internal func checks as our USE/DEPEND
# stuff handles this just fine already #408395
export ac_cv_lib_avcodec_ff_vdpau_vc1_decode_picture=yes

# Fix the final version string showing as "exported"
# instead of the SVN revision number.
export HAVE_GIT=no GIT_REV=${EGIT_VERSION:-exported}

# avoid long delays when powerkit isn't running #348580
sed -i \
-e '/dbus_connection_send_with_reply_and_block/s:-1:3000:' \
xbmc/linux/*.cpp || die

# Tweak autotool timestamps to avoid regeneration
find . -type f -exec touch -r configure {} +
}

src_configure() {
# Disable documentation generation
export ac_cv_path_LATEX=no
# Avoid help2man
export HELP2MAN=$(type -P help2man || echo true)
# No configure flage for this #403561
export ac_cv_lib_bluetooth_hci_devid=$(usex bluetooth)
# Requiring java is asine #434662
[[ ${PV} != "9999" ]] && export ac_cv_path_JAVA_EXE=$(which $(usex java java true))

econf \
--docdir=/usr/share/doc/${PF} \
--disable-ccache \
--disable-optimizations \
--with-ffmpeg=shared \
$(use_enable alsa) \
$(use_enable airplay) \
$(use_enable avahi) \
$(use_enable bluray libbluray) \
$(use_enable caps libcap) \
$(use_enable cec libcec) \
$(use_enable css dvdcss) \
$(use_enable dbus) \
$(use_enable debug) \
$(use_enable fishbmc) \
$(use_enable gles) \
$(use_enable goom) \
$(use_enable joystick) \
$(use_enable midi mid) \
$(use_enable mysql) \
$(use_enable nfs) \
$(use_enable opengl gl) \
$(use_enable profile profiling) \
$(use_enable projectm) \
$(use_enable pulseaudio pulse) \
$(use_enable rsxs) \
$(use_enable rtmp) \
$(use_enable samba) \
$(use_enable sftp ssh) \
$(use_enable spectrum) \
$(use_enable usb libusb) \
$(use_enable test gtest) \
$(use_enable texturepacker) \
$(use_enable upnp) \
$(use_enable vaapi) \
$(use_enable vdpau) \
$(use_enable waveform) \
$(use_enable webserver) \
$(use_enable X x11)
}

src_compile() {
emake V=1
}

src_install() {
default
rm "${ED}"/usr/share/doc/*/{LICENSE.GPL,copying.txt}*

domenu tools/Linux/kodi.desktop
newicon media/icon48x48.png kodi.png

# Remove optional addons (platform specific).
local disabled_addons=(
repository.pvr-{android,ios,osx{32,64},win32}.xbmc.org
visualization.dxspectrum
visualization.vortex
)
rm -rf "${disabled_addons[@]/#/${ED}/usr/share/kodi/addons/}"

# Remove fonconfig settings that are used only on MacOSX.
# Can't be patched upstream because they just find all files and install
# them into same structure like they have in git.
rm -rf "${ED}"/usr/share/kodi/system/players/dvdplayer/etc

# Replace bundled fonts with system ones
# teletext.ttf: unknown
# bold-caps.ttf: unknown
# roboto: roboto-bold, roboto-regular
# arial.ttf: font mashed from droid/roboto, not removed wrt bug#460514
rm -rf "${ED}"/usr/share/kodi/addons/skin.confluence/fonts/Roboto-*
dosym /usr/share/fonts/roboto/Roboto-Regular.ttf \
/usr/share/kodi/addons/skin.confluence/fonts/Roboto-Regular.ttf
dosym /usr/share/fonts/roboto/Roboto-Bold.ttf \
/usr/share/kodi/addons/skin.confluence/fonts/Roboto-Bold.ttf

python_domodule tools/EventClients/lib/python/xbmcclient.py
python_newscript "tools/EventClients/Clients/Kodi Send/kodi-send.py" kodi-send
}

0 comments on commit 2f3a6fd

Please sign in to comment.