Skip to content

Commit

Permalink
media-plugins/amb-plugins: fix HOMEPAGE, SRC_URI, EAPI=5. bug #437186
Browse files Browse the repository at this point in the history
The HOMEPAGE and SRC_URI for kokkinizita upstream was changed
some time ago. These changes point said variables to the new
location. The previous ebuild was EAPI=3 which is deprecated so
bumped to EAPI=5, revbumped and modified ebuild accordingly.

Bug: https://bugs.gentoo.org/show_bug.cgi?id=437186
  • Loading branch information
gavlee committed Oct 15, 2015
1 parent d166ce8 commit 2f71f65
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions media-plugins/amb-plugins/amb-plugins-0.8.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit multilib toolchain-funcs eutils

MY_P=${P/amb/AMB}

DESCRIPTION="AMB-plugins ladspa plugin package. Filters by Fons Adriaensen"
HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/"
SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="media-libs/ladspa-sdk"
RDEPEND="${DEPEND}"

S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}/${P}-Makefile.patch"
}

src_compile() {
emake CXX="$(tc-getCXX)"
}

src_install() {
dodoc AUTHORS README
insinto /usr/$(get_libdir)/ladspa
insopts -m0755
doins *.so
}

0 comments on commit 2f71f65

Please sign in to comment.